]> git.pld-linux.org Git - packages/fceultra.git/commitdiff
- updated to 2.2.1 auto/th/fceultra-2.2.1-1
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 14 Jul 2013 18:08:29 +0000 (20:08 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 14 Jul 2013 18:08:29 +0000 (20:08 +0200)
fceultra-build.patch [deleted file]
fceultra.spec
format-security.patch [new file with mode: 0644]
lua51.patch [new file with mode: 0644]

diff --git a/fceultra-build.patch b/fceultra-build.patch
deleted file mode 100644 (file)
index a4c8820..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
---- fceu2.1.5/src/file.cpp~    2010-09-19 02:05:09.000000000 +0200
-+++ fceu2.1.5/src/file.cpp     2012-02-12 10:11:53.832509623 +0100
-@@ -310,7 +310,7 @@
-                               if(magic==0x088b1f) {
-                                        // maybe gzip... 
--                                      void* gzfile = gzopen(fileToOpen.c_str(),"rb");
-+                                      gzFile gzfile = gzopen(fileToOpen.c_str(),"rb");
-                                       if(gzfile) {
-                                               delete fp;
---- fceu2.1.5/SConstruct~      2011-06-04 07:26:55.000000000 +0200
-+++ fceu2.1.5/SConstruct       2012-02-12 10:15:10.593425125 +0100
-@@ -39,6 +39,8 @@
-   env.Append(CCFLAGS = os.environ['CFLAGS'].split())
- if os.environ.has_key('LDFLAGS'):
-   env.Append(LINKFLAGS = os.environ['LDFLAGS'].split())
-+if os.environ.has_key('LIBS'):
-+  env.Append(LIBS = os.environ['LIBS'].split())
- print "platform: ", env['PLATFORM']
index 740cf8c99875e18e96ccfb0a22ebb14ab14e6951..fa8dfee31c87abe9e7f0f9fe33d322bfdff11644 100644 (file)
@@ -4,13 +4,14 @@
 Summary:       FCE Ultra - Linux Nintendo Entertainment System emulator
 Summary(pl.UTF-8):     FCE Ultra - linuksowy emulator systemu Nintendo
 Name:          fceultra
 Summary:       FCE Ultra - Linux Nintendo Entertainment System emulator
 Summary(pl.UTF-8):     FCE Ultra - linuksowy emulator systemu Nintendo
 Name:          fceultra
-Version:       2.1.5
-Release:       5
+Version:       2.2.1
+Release:       1
 License:       GPL v2+
 Group:         X11/Applications/Games
 License:       GPL v2+
 Group:         X11/Applications/Games
-Source0:       http://downloads.sourceforge.net/fceultra/fceux-%{version}.src.tar.bz2
-# Source0-md5: e8b20e62bbbb061b1a59d51b47c827bd
-Patch0:                %{name}-build.patch
+Source0:       http://downloads.sourceforge.net/fceultra/fceux-%{version}.src.tar.gz
+# Source0-md5: 696d0186afb17f3b70d4aa9e9f5cf1d1
+Patch0:                lua51.patch
+Patch1:                format-security.patch
 URL:           http://fceultra.sourceforge.net/
 BuildRequires: OpenGL-GLU-devel
 BuildRequires: SDL >= 1.2.14
 URL:           http://fceultra.sourceforge.net/
 BuildRequires: OpenGL-GLU-devel
 BuildRequires: SDL >= 1.2.14
@@ -29,9 +30,9 @@ FCE Ultra is a cross platform, NTSC and PAL Famicom/NES emulator.
 FCE Ultra to wieloplatformowy emulator konsoli Famicom/NES/Pegasus.
 
 %prep
 FCE Ultra to wieloplatformowy emulator konsoli Famicom/NES/Pegasus.
 
 %prep
-%setup -q -n fceu%{version}
-%undos src/file.cpp
+%setup -q -n fceux-%{version}
 %patch0 -p1
 %patch0 -p1
+%patch1 -p1
 
 %build
 CC="%{__cc}" \
 
 %build
 CC="%{__cc}" \
@@ -52,5 +53,5 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
 
 %files
 %defattr(644,root,root,755)
-%doc Authors.txt README-SDL TODO-PROJECT TODO-SDL changelog.txt documentation
+%doc Authors README-SDL TODO-SDL changelog.txt documentation
 %attr(755,root,root) %{_bindir}/fceux
 %attr(755,root,root) %{_bindir}/fceux
diff --git a/format-security.patch b/format-security.patch
new file mode 100644 (file)
index 0000000..0cefb7f
--- /dev/null
@@ -0,0 +1,11 @@
+--- fceux-2.2.1/src/drivers/sdl/sdl.cpp~       2013-03-02 20:46:34.000000000 +0100
++++ fceux-2.2.1/src/drivers/sdl/sdl.cpp        2013-07-14 20:06:36.493322816 +0200
+@@ -934,7 +934,7 @@
+       if(gtkIsStarted == true && noGui == 0)
+       {
+               GtkWidget* d;
+-              d = gtk_message_dialog_new(GTK_WINDOW(MainWindow), GTK_DIALOG_MODAL,        GTK_MESSAGE_ERROR, GTK_BUTTONS_OK, errormsg);
++              d = gtk_message_dialog_new(GTK_WINDOW(MainWindow), GTK_DIALOG_MODAL,        GTK_MESSAGE_ERROR, GTK_BUTTONS_OK, "%s", errormsg);
+               gtk_dialog_run(GTK_DIALOG(d));
+               gtk_widget_destroy(d);
+       }
diff --git a/lua51.patch b/lua51.patch
new file mode 100644 (file)
index 0000000..24a9d3c
--- /dev/null
@@ -0,0 +1,13 @@
+--- fceux-2.2.1/SConstruct~    2013-03-10 22:21:52.000000000 +0100
++++ fceux-2.2.1/SConstruct     2013-07-14 20:04:15.261914050 +0200
+@@ -125,8 +125,8 @@
+       # Should work on any *nix
+       env.Append(CCFLAGS = ["-DLUA_USE_LINUX"])
+     lua_available = False
+-    if conf.CheckLib('lua5.1'):
+-      env.Append(LINKFLAGS = ["-ldl", "-llua5.1"])
++    if conf.CheckLib('lua51'):
++      env.Append(LINKFLAGS = ["-ldl", "-llua51"])
+       lua_available = True
+     elif conf.CheckLib('lua'):
+       env.Append(LINKFLAGS = ["-ldl", "-llua"])
This page took 0.067102 seconds and 4 git commands to generate.