]> git.pld-linux.org Git - packages/fbida.git/blobdiff - fbida.spec
- unified cairogl bcond name
[packages/fbida.git] / fbida.spec
index 82d63d018b7f8e663c7ade3e242d802c9b744130..ac697d8e36885e67ca5de0eb31eb9d49b3ed678f 100644 (file)
@@ -2,50 +2,58 @@
 # - package thumbnail.cgi (in %{_libdir}/cgi-bin?)
 #
 # Conditional build:
-%bcond_without curl    # without URL support
-%bcond_without exif    # without EXIF tags support
-%bcond_without gif     # without GIF images support
-%bcond_without lirc    # without LIRC control support
-%bcond_without motif   # don't build (Motif-based) ida
-%bcond_without pcd     # without PCD images support
-%bcond_without png     # without PNG images support
-%bcond_without sane    # without SANE scanning support (in ida)
-%bcond_without tiff    # without TIFF images support
-#
-%if !%{with motif}
+%bcond_without curl            # without URL support
+%bcond_without exif            # without EXIF tags support
+%bcond_without gif             # without GIF images support
+%bcond_without lirc            # without LIRC control support
+%bcond_without motif           # don't build (Motif-based) ida
+%bcond_without pcd             # without PCD images support
+%bcond_without sane            # without SANE scanning support (in ida)
+%bcond_without webp            # without WebP images support
+%bcond_with    cairogl         # with Cairo-GL support (in fbpdf program)
+
+%if %{without motif}
 # SANE used only in ida
 %undefine      with_sane
 %endif
 Summary:       fbida - a few applications for viewing and editing images
 Summary(pl.UTF-8):     fbida - kilka aplikacji do oglądania i edycji obrazków
 Name:          fbida
-Version:       2.07
-Release:       2
+Version:       2.14
+Release:       1
 License:       GPL
 Group:         Applications/Graphics
-Source0:       http://dl.bytesex.org/releases/fbida/%{name}-%{version}.tar.gz
-# Source0-md5: 3e05910fb7c1d9b2bd3e272d96db069c
+Source0:       https://www.kraxel.org/releases/fbida/%{name}-%{version}.tar.gz
+# Source0-md5: f5475b359461d2d995bde59e13cc584f
 Patch0:                %{name}-config-noforce.patch
 Patch1:                %{name}-desktop.patch
-Patch2:                %{name}-libpng-1.4.patch
-URL:           http://linux.bytesex.org/fbida/
+URL:           https://www.kraxel.org/blog/linux/fbida/
+BuildRequires: EGL-devel
 BuildRequires: ImageMagick-devel
+BuildRequires: Mesa-libgbm-devel
+BuildRequires: cairo-devel
 %{?with_curl:BuildRequires:    curl-devel}
 BuildRequires: fontconfig-devel
 BuildRequires: freetype-devel >= 2.0.0
 # -Wno-pointer-sign
 BuildRequires: gcc >= 5:4.0
 %{?with_gif:BuildRequires:     giflib-devel}
+BuildRequires: libdrm-devel
+BuildRequires: libepoxy-devel
 BuildRequires: libexif-devel >= 1:0.6.9
 BuildRequires: libjpeg-devel
 %{?with_pcd:BuildRequires:     libpcd-devel >= 1:1.0.1}
-%{?with_png:BuildRequires:     libpng-devel}
-%{?with_tiff:BuildRequires:    libtiff-devel}
+BuildRequires: libpng-devel
+BuildRequires: libtiff-devel >= 4
+%{?with_webp:BuildRequires:    libwebp-devel}
 %{?with_lirc:BuildRequires:    lirc-devel}
 # acc. to README lesstif is not sufficient
-%{?with_motif:BuildRequires:   openmotif-devel >= 2.0}
+%{?with_motif:BuildRequires:   motif-devel >= 2.0}
 BuildRequires: perl-base
+BuildRequires: pixman-devel
 BuildRequires: pkgconfig
+%{?with_cairogl:BuildRequires: pkgconfig(cairo-gl)}
+BuildRequires: poppler-glib-devel
 %{?with_sane:BuildRequires:    sane-backends-devel}
 BuildRequires: util-linux
 BuildRequires: which
@@ -104,6 +112,17 @@ Ten pakiet zawiera także dodatkowe narzędzia:
 - exiftran - działające z linii poleceń narzędzie do wykonywania
   bezstratnych przekształceń obrazków JPEG
 
+%package -n fbpdf
+Summary:       Linux FrameBuffer PDF viewer
+Summary(pl.UTF-8):     Przeglądarka plików PDF dla linuksowego framebuffera
+Group:         Applications/Graphics
+
+%description -n fbpdf
+Linux FrameBuffer PDF viewer.
+
+%description -n fbpdf -l pl.UTF-8
+Przeglądarka plików PDF dla linuksowego framebuffera.
+
 %package -n ida
 Summary:       Small and fast image viewer, Motif-based
 Summary(pl.UTF-8):     Mała, szybka przeglądarka obrazków oparta na Motifie
@@ -123,21 +142,20 @@ Dostępne jest też trochę podstawowych funkcji edycyjnych.
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
 
 %build
 CFLAGS="%{rpmcflags}" \
 %{__make} \
        CC="%{__cc}" \
        verbose=yes \
+       %{!?with_cairogl:HAVE_CAIRO_GL=no} \
        %{!?with_pcd:HAVE_LIBPCD=no} \
-       %{!?with_gif:HAVE_LIBUNGIF=no} \
-       %{!?with_png:HAVE_LIBPNG=no} \
-       %{!?with_tiff:HAVE_LIBTIFF=no} \
-       %{!?with_sane:HAVE_LIBSANE=no} \
-       %{!?with_curl:HAVE_LIBCURL=no} \
-       %{!?with_lirc:HAVE_LIBLIRC=no} \
-       %{!?with_motif:HAVE_MOTIF=no}
+       %{!?with_gif:HAVE_LIBGIF=no} \
+       %{!?with_webp:HAVE_LIBWEBP=no} \
+       %{!?with_motif:HAVE_MOTIF=no} \
+       %{?with_sane:HAVE_LIBSANE=yes} \
+       %{?with_curl:HAVE_LIBCURL=yes} \
+       %{?with_lirc:HAVE_LIBLIRC=yes}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -146,14 +164,14 @@ rm -rf $RPM_BUILD_ROOT
        DESTDIR=$RPM_BUILD_ROOT \
        prefix=%{_prefix} \
        INSTALL_BINARY=install \
+       %{!?with_cairogl:HAVE_CAIRO_GL=no} \
        %{!?with_pcd:HAVE_LIBPCD=no} \
-       %{!?with_gif:HAVE_LIBUNGIF=no} \
-       %{!?with_png:HAVE_LIBPNG=no} \
-       %{!?with_tiff:HAVE_LIBTIFF=no} \
-       %{!?with_sane:HAVE_LIBSANE=no} \
-       %{!?with_curl:HAVE_LIBCURL=no} \
-       %{!?with_lirc:HAVE_LIBLIRC=no} \
-       %{!?with_motif:HAVE_MOTIF=no}
+       %{!?with_gif:HAVE_LIBGIF=no} \
+       %{!?with_webp:HAVE_LIBWEBP=no} \
+       %{!?with_motif:HAVE_MOTIF=no} \
+       %{?with_sane:HAVE_LIBSANE=yes} \
+       %{?with_curl:HAVE_LIBCURL=yes} \
+       %{?with_lirc:HAVE_LIBLIRC=yes}
 
 %if %{with motif}
 install -D desktop/ida.desktop $RPM_BUILD_ROOT%{_desktopdir}/ida.desktop
@@ -171,6 +189,10 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/fbgs.1*
 %{_mandir}/man1/fbi.1*
 
+%files -n fbpdf
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/fbpdf
+
 %if %{with motif}
 %files -n ida
 %defattr(644,root,root,755)
This page took 0.134965 seconds and 4 git commands to generate.