]> git.pld-linux.org Git - packages/fbida.git/blob - fbida.spec
208bb24d0532234a0836fdf8c25efd7632f0d075
[packages/fbida.git] / fbida.spec
1 # TODO:
2 # - package thumbnail.cgi (in %{_libdir}/cgi-bin?)
3 # Conditional build:
4 %bcond_without  curl    # without URL support
5 %bcond_without  exif    # without EXIF tags support
6 %bcond_without  gif     # without GIF images support
7 %bcond_without  lirc    # without LIRC control support
8 %bcond_without  motif   # don't build (Motif-based) ida
9 %bcond_without  pcd     # without PCD images support
10 %bcond_without  png     # without PNG images support
11 %bcond_without  sane    # without SANE scanning support (in ida)
12 %bcond_without  tiff    # without TIFF images support
13 #
14 %if %{without motif}
15 # SANE used only in ida
16 %undefine       with_sane
17 %endif
18 Summary:        fbida - a few applications for viewing and editing images
19 Summary(pl):    fbida - kilka aplikacji do ogl±dania i edycji obrazków
20 Name:           fbida
21 Version:        2.03
22 Release:        1
23 License:        GPL
24 Group:          Applications/Graphics
25 Source0:        http://dl.bytesex.org/releases/fbida/%{name}-%{version}.tar.gz
26 # Source0-md5:  8fd76661686a38a7bcd251b7aadc73eb
27 Patch0:         %{name}-fbgs.patch
28 Patch1:         %{name}-config-noforce.patch
29 Patch2:         %{name}-desktop.patch
30 URL:            http://linux.bytesex.org/fbida/
31 %{?with_curl:BuildRequires:     curl-devel}
32 BuildRequires:  fontconfig-devel
33 BuildRequires:  freetype-devel >= 2.0.0
34 %{?with_gif:BuildRequires:      giflib-devel}
35 BuildRequires:  libexif-devel >= 1:0.6.9
36 BuildRequires:  libjpeg-devel
37 %{?with_pcd:BuildRequires:      libpcd-devel >= 1:1.0.1}
38 %{?with_png:BuildRequires:      libpng-devel}
39 %{?with_lirc:BuildRequires:     lirc-devel}
40 %{?with_tiff:BuildRequires:     libtiff-devel}
41 # acc. to README lesstif is not sufficient
42 %{?with_motif:BuildRequires:    openmotif-devel >= 2.0}
43 BuildRequires:  pkgconfig
44 %{?with_sane:BuildRequires:     sane-backends-devel}
45 BuildRequires:  perl-base
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %define         _appdefsdir     /usr/X11R6/lib/X11/app-defaults
49
50 %description
51 The fbida project contains a few applications for viewing and editing
52 images, with the main focus being photos. The applications are:
53 - fbi - image viewer for the Linux framebuffer console
54 - fbgs - wrapper script for viewing PS/PDF files using fbi
55 - ida - Motif-based application for viewing images
56 - exiftran - command-line tool to do lossless transformations of JPEG
57   images
58 - thumbnail.cgi - small and fast CGI program to extract EXIF
59   thumbnails from JPEG images and send them to the web browser
60
61 %description -l pl
62 Projekt fbida zawiera kilka aplikacji do ogl±dania i edycji obrazków,
63 g³ównie przeznaczonych dla zdjêæ. Te aplikacje to:
64 - fbi - przegl±darka dla linuksowej konsoli z framebufferem
65 - fbgs - skrypt do ogl±dania plików PS/PDF przy u¿yciu fbi
66 - ida - oparta na Motifie aplikacja do ogl±dania obrazków
67 - exiftran - dzia³aj±ce z linii poleceñ narzêdzie do wykonywania
68   bezstratnych przekszta³ceñ obrazków JPEG
69 - thumbnail.cgi - ma³y i szybki program CGI do wyci±gania miniaturek
70   EXIF z obrazków JPEG i wysy³ania ich do przegl±darki WWW
71
72 %package -n fbi
73 Summary:        Linux FrameBuffer Imageviewer
74 Summary(pl):    Przegl±darka obrazków dla linuksowego framebuffera
75 Group:          Applications/Graphics
76
77 %description -n fbi
78 This is a image viewer for linux framebuffer devices. It supports
79 PhotoCD, JPEG and PPM directly. GIF, TIFF and PNG are handled with the
80 netpbm tools, for anything else convert from the ImageMagick package
81 is used as external converter.
82
83 This package contains also additional utilities:
84 - fbgs - wrapper script for viewing PS/PDF files using fbi
85 - exiftran - command-line tool to do lossless transformations of JPEG
86   images
87
88 %description -n fbi -l pl
89 To jest przegl±darka obrazków korzystaj±ca z framebuffera. Obs³uguje
90 bezpo¶rednio PhotoCD, JPEG i PPM; GIF, TIFF i PNG poprzez narzêdzia z
91 pakietu netpbm-progs; inne obrazki poprzez program convert z pakietu
92 ImageMagick.
93
94 Ten pakiet zawiera tak¿e dodatkowe narzêdzia:
95 - fbgs - skrypt do ogl±dania plików PS/PDF przy u¿yciu fbi
96 - exiftran - dzia³aj±ce z linii poleceñ narzêdzie do wykonywania
97   bezstratnych przekszta³ceñ obrazków JPEG
98
99 %package -n ida
100 Summary:        Small and fast image viewer, Motif-based
101 Summary(pl):    Ma³a, szybka przegl±darka obrazków oparta na Motifie
102 Group:          X11/Applications/Graphics
103
104 %description -n ida
105 Ida is a small and fast image viewer, Motif-based. For people who
106 don't want the KDE/GNOME overhead. Some basic editing functions are
107 available too.
108
109 %description -n ida -l pl
110 Ida to ma³a i szybka przegl±darka obrazków oparta na Motifie.
111 Przeznaczona jest dla ludzi, którzy nie chc± narzutu KDE/GNOME.
112 Dostêpne jest te¿ trochê podstawowych funkcji edycyjnych.
113
114 %prep
115 %setup -q
116 %patch0 -p1
117 %patch1 -p1
118 %patch2 -p1
119
120 %build
121 CFLAGS="%{rpmcflags}" \
122 %{__make} \
123         CC="%{__cc}" \
124         verbose=yes \
125         %{!?with_pcd:HAVE_LIBPCD=no} \
126         %{!?with_gif:HAVE_LIBUNGIF=no} \
127         %{!?with_png:HAVE_LIBPNG=no} \
128         %{!?with_tiff:HAVE_LIBTIFF=no} \
129         %{!?with_sane:HAVE_LIBSANE=no} \
130         %{!?with_curl:HAVE_LIBCURL=no} \
131         %{!?with_lirc:HAVE_LIBLIRC=no} \
132         %{!?with_motif:HAVE_MOTIF=no}
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136
137 %{__make} install \
138         DESTDIR=$RPM_BUILD_ROOT \
139         prefix=%{_prefix} \
140         INSTALL_BINARY=install \
141         %{!?with_pcd:HAVE_LIBPCD=no} \
142         %{!?with_gif:HAVE_LIBUNGIF=no} \
143         %{!?with_png:HAVE_LIBPNG=no} \
144         %{!?with_tiff:HAVE_LIBTIFF=no} \
145         %{!?with_sane:HAVE_LIBSANE=no} \
146         %{!?with_curl:HAVE_LIBCURL=no} \
147         %{!?with_lirc:HAVE_LIBLIRC=no} \
148         %{!?with_motif:HAVE_MOTIF=no}
149
150 %if %{with motif}
151 install -D desktop/ida.desktop $RPM_BUILD_ROOT%{_desktopdir}/ida.desktop
152 %endif
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %files -n fbi
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_bindir}/exiftran
160 %attr(755,root,root) %{_bindir}/fbgs
161 %attr(755,root,root) %{_bindir}/fbi
162 %{_mandir}/man1/exiftran.1*
163 %{_mandir}/man1/fbgs.1*
164 %{_mandir}/man1/fbi.1*
165
166 %if %{with motif}
167 %files -n ida
168 %defattr(644,root,root,755)
169 %doc README TODO
170 %attr(755,root,root) %{_bindir}/ida
171 %{_mandir}/man1/ida.1*
172 %{_appdefsdir}/Ida
173 %{_desktopdir}/ida.desktop
174 %endif
This page took 0.051211 seconds and 2 git commands to generate.