]> git.pld-linux.org Git - packages/fasm.git/blob - fasm.spec
dae1852e5b0abda0fcfbe79e5392275dc649963c
[packages/fasm.git] / fasm.spec
1 #
2 # Conditional build:
3 %bcond_with     bootstrap       # use included binary
4 #
5 Summary:        Flat asembler
6 Summary(pl):    "P³aski" assembler
7 Name:           fasm
8 Version:        1.64
9 Release:        1
10 License:        distributable
11 Group:          Development/Tools
12 Source0:        http://flatassembler.net/%{name}-%{version}.tgz
13 # Source0-md5:  5f6642679611f00b53fcadd69348e1b5
14 URL:            http://flatassembler.net/
15 %if %{without bootstrap}
16 BuildRequires:  fasm
17 %endif
18 ExclusiveArch:  %{ix86}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         no_install_post_strip   1
22
23 %description
24 The flat assembler is a fast and efficient self-assembling 80x86
25 assembler for DOS, Windows and Linux operating systems. Currently it
26 supports all 8086-80486/Pentium instructions with MMX, SSE, SSE2, SSE3
27 and 3DNow! extensions, can produce output in binary, MZ, PE, COFF or
28 ELF format. It includes the powerful but easy to use macroinstruction
29 support and does multiple passes to optimize the instruction codes for
30 size. The flat assembler is self-compilable and the full source code
31 is included.
32
33 %description -l pl
34 P³aski asembler jest szybkim i efektywnym, samo-asembluj±cy siê
35 asemblerem 80x86 dla systemów DOS, Windows i Linux. Aktualnie
36 obs³uguje wszystkie instrukcje 8086-80486/Pentium z rozszerzeniami
37 MMX, SSE, SSE2, SSE3 i 3DNow!, mo¿e produkowaæ programy w formacie
38 binarnym, MZ, PE, COFF lub ELF. Zawiera potê¿ne, ale proste wsparcie
39 dla makroinstrukcji oraz wielokrotnie optymalizuje kod dla rozmiaru.
40 P³aski asembler potrafi sam siê skompilowaæ oraz zawiera pe³en kod
41 ¼ród³owy.
42
43 %prep
44 %setup -q -n %{name}
45
46 %build
47 %if %{without bootstrap}
48 ASM=%{name}
49 %else
50 ASM=../../%{name}
51 %endif
52 cd source/Linux
53 $ASM %{name}.asm
54 chmod +x %{name}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 install -D source/Linux/%{name} $RPM_BUILD_ROOT%{_bindir}/%{name}
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc *.txt
67 %attr(755,root,root) %{_bindir}/*
This page took 0.055898 seconds and 2 git commands to generate.