]> git.pld-linux.org Git - packages/fasm.git/blob - fasm.spec
- initital rpm version
[packages/fasm.git] / fasm.spec
1 %bcond_with     bootstrap       # use included binary
2 Summary:        Flat assembler
3 Summary(pl):    "P³aski" assembler
4 Name:           fasm
5 Version:        1.54
6 Release:        1
7 License:        distributable
8 Group:          Development/Tools
9 Source0:        http://flatassembler.net/%{name}-%{version}.tar.gz
10 # Source0-md5:  407df366e89a4229f7689514d1d3ddbb
11 URL:            http://flatassembler.net/
12 %if %{without bootstrap}
13 BuildRequires:  fasm
14 %endif
15 ExclusiveArch:  %{ix86}
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         no_install_post_strip   1
19
20 %description
21 The flat assembler is a fast and efficient self-assembling 80x86
22 assembler for DOS, Windows and Linux operating systems. Currently it
23 supports all 8086-80486/Pentium instructions with MMX, SSE, SSE2, SSE3
24 and 3DNow! extensions, can produce output in binary, MZ, PE, COFF or
25 ELF format. It includes the powerful but easy to use macroinstruction
26 support and does multiple passes to optimize the instruction codes for
27 size. The flat assembler is self-compilable and the full source code
28 is included.
29
30 %description -l pl
31 P³aski assembler jest szybkim i efektywnym, samo-assembluj±cy siê
32 assemblerem 80x86 dla DOS, Windows i Linux. Aktualnie obs³uguje
33 wszystkie instrukcje 8086-80486/Pentium z rozszerzeniami MMX, SSE,
34 SSE2, SSE3 i 3DNow! , mo¿e produkowaæ programy w formacie binarnym,
35 MZ, PE, COFF lub ELF. Zawiera potê¿ne, ale proste wsparcie dla
36 makroinstrukcji oraz wielokrotnie optymalizuje kod dla rozmiaru.
37 P³aski assembler potrafi sam siê skompilowaæ oraz zawiera pe³en kod
38 ¼ród³owy.
39
40 %prep
41 %setup -q -n %{name}
42
43 %build
44 %if %{without bootstrap}
45 ASM=%{name}
46 %else
47 ASM=../../%{name}
48 %endif
49 cd source/Linux
50 $ASM %{name}.asm
51 chmod +x %{name}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -D source/Linux/%{name} $RPM_BUILD_ROOT%{_bindir}/%{name}
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc *.txt
63 %attr(755,root,root) %{_bindir}/*
This page took 0.063345 seconds and 3 git commands to generate.