]> git.pld-linux.org Git - packages/farstream.git/blob - farstream.spec
d1434a7ba1f828de2b5c53c63d1bd21512893415
[packages/farstream.git] / farstream.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        Audio/Video Communications Framework
7 Summary(pl.UTF-8):      Szkielet komunikacji Audio/Video
8 Name:           farstream
9 Version:        0.2.7
10 Release:        1
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        http://freedesktop.org/software/farstream/releases/farstream/%{name}-%{version}.tar.gz
14 # Source0-md5:  bb56af4cbf2cd42f35353f20cf04bc17
15 URL:            http://www.freedesktop.org/wiki/Software/Farstream
16 BuildRequires:  autoconf >= 2.60
17 BuildRequires:  automake
18 BuildRequires:  glib2-devel >= 1:2.32.0
19 BuildRequires:  gobject-introspection-devel >= 0.10.1
20 BuildRequires:  gstreamer-devel >= 1.4
21 BuildRequires:  gstreamer-plugins-base-devel >= 1.4
22 BuildRequires:  gtk-doc >= 1.18
23 BuildRequires:  gupnp-igd-devel >= 0.2
24 BuildRequires:  libnice-devel >= 0.1.8
25 BuildRequires:  libtool
26 BuildRequires:  pkgconfig
27 BuildRequires:  python >= 2.1
28 Requires:       glib2 >= 1:2.32.0
29 Requires:       gstreamer >= 1.4
30 Requires:       gstreamer-plugins-base >= 1.4
31 Requires:       gupnp-igd >= 0.2
32 Requires:       libnice >= 0.1.8
33 Obsoletes:      farsight2 < 0.0.32
34 Obsoletes:      python-farsight2 < 0.0.32
35 Obsoletes:      python-farstream < 0.2.0
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 The Farstream (formerly Farsight) project is an effort to create a
40 framework to deal with all known audio/video conferencing protocols.
41 On one side it offers a generic API that makes it possible to write
42 plugins for different streaming protocols, on the other side it offers
43 an API for clients to use those plugins.
44
45 The main target clients for Farstream are Instant Messaging
46 applications. These applications should be able to use Farstream for
47 all their Audio/Video conferencing needs without having to worry about
48 any of the lower level streaming and NAT traversal issues.
49
50 %description -l pl.UTF-8
51 Projekt Farstream (dawniej Farsight) to próba stworzenia szkieletu
52 obsługującego wszystkie znane protokoły konferencji audio/video. Z
53 jednej strony oferuje ogólne API umożliwiające pisanie wtyczek dla
54 różnych protokołów strumieniowych, z drugiej strony oferuje API dla
55 klientów, pozwalającyce im używać tych wtyczek.
56
57 Głównymi klientami szkieletu Farstream mają być aplikacje
58 komunikatorów (IM). Powinny być w stanie używać Farstreama do potrzeb
59 konferencji audio/video bez konieczności obsługi niskopoziomowych
60 poziomów strumieni i omijania NAT-u.
61
62 %package devel
63 Summary:        Header files for Farstream library
64 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Farstream
65 Group:          Development/Libraries
66 Requires:       %{name} = %{version}-%{release}
67 Requires:       glib2-devel >= 1:2.32.0
68 Requires:       gstreamer-devel >= 1.4
69 Requires:       gstreamer-plugins-base-devel >= 1.4
70 Obsoletes:      farsight2-devel < 0.0.32
71
72 %description devel
73 Header files for Farstream library.
74
75 %description devel -l pl.UTF-8
76 Pliki nagłówkowe biblioteki Farstream.
77
78 %package static
79 Summary:        Static Farstream library
80 Summary(pl.UTF-8):      Statyczna biblioteka Farstream
81 Group:          Development/Libraries
82 Requires:       %{name}-devel = %{version}-%{release}
83 Obsoletes:      farsight2-static < 0.0.32
84
85 %description static
86 Static Farstream library.
87
88 %description static -l pl.UTF-8
89 Statyczna biblioteka Farstream.
90
91 %package apidocs
92 Summary:        Farstream API documentation
93 Summary(pl.UTF-8):      Dokumentacja API biblioteki Farstream
94 Group:          Documentation
95 Requires:       gtk-doc-common
96 Obsoletes:      farsight2-apidocs < 0.0.32
97
98 %description apidocs
99 API documentation for Farstream library.
100
101 %description apidocs -l pl.UTF-8
102 Dokumentacja API biblioteki Farstream.
103
104 %prep
105 %setup -q
106
107 %build
108 %{__libtoolize}
109 %{__aclocal} -I m4 -I common/m4
110 %{__autoconf}
111 %{__autoheader}
112 %{__automake}
113 %configure \
114         %{__enable_disable apidocs gtk-doc} \
115         %{__enable_disable static_libs static} \
116         --disable-silent-rules \
117         --with-html-dir=%{_gtkdocdir}
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 %{__rm} $RPM_BUILD_ROOT%{_libdir}/{farstream-0.2,gstreamer-1.0}/*.{a,la}
127 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post   -p /sbin/ldconfig
133 %postun -p /sbin/ldconfig
134
135 %files
136 %defattr(644,root,root,755)
137 %doc AUTHORS ChangeLog NEWS README
138 %attr(755,root,root) %{_libdir}/libfarstream-0.2.so.*.*.*
139 %attr(755,root,root) %ghost %{_libdir}/libfarstream-0.2.so.5
140 %{_libdir}/girepository-1.0/Farstream-0.2.typelib
141 %dir %{_libdir}/farstream-0.2
142 %attr(755,root,root) %{_libdir}/farstream-0.2/libmulticast-transmitter.so
143 %attr(755,root,root) %{_libdir}/farstream-0.2/libnice-transmitter.so
144 %attr(755,root,root) %{_libdir}/farstream-0.2/librawudp-transmitter.so
145 %attr(755,root,root) %{_libdir}/farstream-0.2/libshm-transmitter.so
146 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libfsmsnconference.so
147 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libfsrawconference.so
148 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libfsrtpconference.so
149 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libfsrtpxdata.so
150 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libfsvideoanyrate.so
151 %{_datadir}/farstream
152
153 %files devel
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_libdir}/libfarstream-0.2.so
156 %{_datadir}/gir-1.0/Farstream-0.2.gir
157 %{_includedir}/farstream-0.2
158 %{_pkgconfigdir}/farstream-0.2.pc
159
160 %if %{with static_libs}
161 %files static
162 %defattr(644,root,root,755)
163 %{_libdir}/libfarstream-0.2.a
164 %endif
165
166 %if %{with apidocs}
167 %files apidocs
168 %defattr(644,root,root,755)
169 %{_gtkdocdir}/farstream-libs-0.2
170 %{_gtkdocdir}/farstream-plugins-0.2
171 %endif
This page took 0.056825 seconds and 2 git commands to generate.