]> git.pld-linux.org Git - packages/farstream.git/blob - farstream.spec
30fde6b376d84aa86ef533f3ab5d87962366544a
[packages/farstream.git] / farstream.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        Audio/Video Communications Framework
7 Summary(pl.UTF-8):      Szkielet komunikacji Audio/Video
8 Name:           farstream
9 Version:        0.2.4
10 Release:        1
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        http://freedesktop.org/software/farstream/releases/farstream/%{name}-%{version}.tar.gz
14 # Source0-md5:  edcc75cbf7c811cfe3de9b00b9808682
15 Patch0:         %{name}-doc.patch
16 URL:            http://www.freedesktop.org/wiki/Software/Farstream
17 BuildRequires:  autoconf >= 2.60
18 BuildRequires:  automake
19 BuildRequires:  glib2-devel >= 1:2.32.0
20 BuildRequires:  gobject-introspection-devel >= 0.10.1
21 BuildRequires:  gstreamer-devel >= 1.0.0
22 BuildRequires:  gstreamer-plugins-base-devel >= 1.0.0
23 BuildRequires:  gtk-doc >= 1.8
24 BuildRequires:  gupnp-igd-devel >= 0.2
25 BuildRequires:  libnice-devel >= 0.1.3
26 BuildRequires:  libtool
27 BuildRequires:  pkgconfig
28 BuildRequires:  python >= 2.1
29 Requires:       glib2 >= 1:2.32.0
30 Requires:       gstreamer >= 1.0.0
31 Requires:       gstreamer-plugins-base >= 1.0.0
32 Requires:       gupnp-igd >= 0.2
33 Requires:       libnice >= 0.1.3
34 Obsoletes:      farsight2 < 0.0.32
35 Obsoletes:      python-farsight2 < 0.0.32
36 Obsoletes:      python-farstream < 0.2.0
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 The Farstream (formerly Farsight) project is an effort to create a
41 framework to deal with all known audio/video conferencing protocols.
42 On one side it offers a generic API that makes it possible to write
43 plugins for different streaming protocols, on the other side it offers
44 an API for clients to use those plugins.
45
46 The main target clients for Farstream are Instant Messaging
47 applications. These applications should be able to use Farstream for
48 all their Audio/Video conferencing needs without having to worry about
49 any of the lower level streaming and NAT traversal issues.
50
51 %description -l pl.UTF-8
52 Projekt Farstream (dawniej Farsight) to próba stworzenia szkieletu
53 obsługującego wszystkie znane protokoły konferencji audio/video. Z
54 jednej strony oferuje ogólne API umożliwiające pisanie wtyczek dla
55 różnych protokołów strumieniowych, z drugiej strony oferuje API dla
56 klientów, pozwalającyce im używać tych wtyczek.
57
58 Głównymi klientami szkieletu Farstream mają być aplikacje
59 komunikatorów (IM). Powinny być w stanie używać Farstreama do potrzeb
60 konferencji audio/video bez konieczności obsługi niskopoziomowych
61 poziomów strumieni i omijania NAT-u.
62
63 %package devel
64 Summary:        Header files for Farstream library
65 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Farstream
66 Group:          Development/Libraries
67 Requires:       %{name} = %{version}-%{release}
68 Requires:       glib2-devel >= 1:2.32.0
69 Requires:       gstreamer-devel >= 1.0.0
70 Requires:       gstreamer-plugins-base-devel >= 1.0.0
71 Obsoletes:      farsight2-devel < 0.0.32
72
73 %description devel
74 Header files for Farstream library.
75
76 %description devel -l pl.UTF-8
77 Pliki nagłówkowe biblioteki Farstream.
78
79 %package static
80 Summary:        Static Farstream library
81 Summary(pl.UTF-8):      Statyczna biblioteka Farstream
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{version}-%{release}
84 Obsoletes:      farsight2-static < 0.0.32
85
86 %description static
87 Static Farstream library.
88
89 %description static -l pl.UTF-8
90 Statyczna biblioteka Farstream.
91
92 %package apidocs
93 Summary:        Farstream API documentation
94 Summary(pl.UTF-8):      Dokumentacja API biblioteki Farstream
95 Group:          Documentation
96 Requires:       gtk-doc-common
97 Obsoletes:      farsight2-apidocs < 0.0.32
98
99 %description apidocs
100 API documentation for Farstream library.
101
102 %description apidocs -l pl.UTF-8
103 Dokumentacja API biblioteki Farstream.
104
105 %prep
106 %setup -q
107 %patch0 -p1
108
109 %build
110 %{__libtoolize}
111 %{__aclocal} -I m4 -I common/m4
112 %{__autoconf}
113 %{__autoheader}
114 %{__automake}
115 %configure \
116         %{__enable_disable apidocs gtk-doc} \
117         %{__enable_disable static_libs static} \
118         --disable-silent-rules \
119         --with-html-dir=%{_gtkdocdir}
120 %{__make}
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 %{__rm} $RPM_BUILD_ROOT%{_libdir}/{farstream-0.2,gstreamer-1.0}/*.{a,la}
129 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post   -p /sbin/ldconfig
135 %postun -p /sbin/ldconfig
136
137 %files
138 %defattr(644,root,root,755)
139 %doc AUTHORS ChangeLog NEWS README
140 %attr(755,root,root) %{_libdir}/libfarstream-0.2.so.*.*.*
141 %attr(755,root,root) %ghost %{_libdir}/libfarstream-0.2.so.2
142 %{_libdir}/girepository-1.0/Farstream-0.2.typelib
143 %dir %{_libdir}/farstream-0.2
144 %attr(755,root,root) %{_libdir}/farstream-0.2/libmulticast-transmitter.so
145 %attr(755,root,root) %{_libdir}/farstream-0.2/libnice-transmitter.so
146 %attr(755,root,root) %{_libdir}/farstream-0.2/librawudp-transmitter.so
147 %attr(755,root,root) %{_libdir}/farstream-0.2/libshm-transmitter.so
148 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libfsmsnconference.so
149 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libfsrawconference.so
150 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libfsrtcpfilter.so
151 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libfsrtpconference.so
152 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libfsvideoanyrate.so
153 %{_datadir}/farstream
154
155 %files devel
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_libdir}/libfarstream-0.2.so
158 %{_datadir}/gir-1.0/Farstream-0.2.gir
159 %{_includedir}/farstream-0.2
160 %{_pkgconfigdir}/farstream-0.2.pc
161
162 %if %{with static_libs}
163 %files static
164 %defattr(644,root,root,755)
165 %{_libdir}/libfarstream-0.2.a
166 %endif
167
168 %if %{with apidocs}
169 %files apidocs
170 %defattr(644,root,root,755)
171 %{_gtkdocdir}/farstream-libs-0.2
172 %{_gtkdocdir}/farstream-plugins-0.2
173 %endif
This page took 0.100222 seconds and 2 git commands to generate.