]> git.pld-linux.org Git - packages/farsight2.git/blob - farsight2.spec
- added make patch
[packages/farsight2.git] / farsight2.spec
1 Summary:        Audio/Video Communications Framework
2 Name:           farsight2
3 Version:        0.0.21
4 Release:        2
5 License:        LGPL v2+
6 Group:          Libraries
7 Source0:        http://farsight.freedesktop.org/releases/farsight2/%{name}-%{version}.tar.gz
8 # Source0-md5:  5898612c389f3538a4160e677c03087a
9 Patch0:         %{name}-make.patch
10 URL:            http://farsight.freedesktop.org/
11 BuildRequires:  autoconf >= 2.60
12 BuildRequires:  automake
13 BuildRequires:  docbook-dtd412-xml
14 BuildRequires:  glib2-devel >= 1:2.16.0
15 BuildRequires:  gstreamer-devel >= 0.10.23
16 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.23
17 BuildRequires:  gtk-doc >= 1.8
18 BuildRequires:  gupnp-devel >= 0.13
19 BuildRequires:  gupnp-igd-devel
20 BuildRequires:  libnice-devel >= 0.0.9
21 BuildRequires:  libtool
22 BuildRequires:  pkgconfig
23 BuildRequires:  python-devel >= 1:2.4
24 BuildRequires:  python-gstreamer-devel >= 0.10.10
25 BuildRequires:  python-pygtk-devel >= 2:2.12.0
26 BuildRequires:  rpm-pythonprov
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 The Farsight project is an effort to create a framework to deal with
31 all known audio/video conferencing protocols. On one side it offers a
32 generic API that makes it possible to write plugins for different
33 streaming protocols, on the other side it offers an API for clients to
34 use those plugins.
35
36 The main target clients for Farsight are Instant Messaging
37 applications. These applications should be able to use Farsight for
38 all their Audio/Video conferencing needs without having to worry about
39 any of the lower level streaming and NAT traversal issues.
40
41 %package devel
42 Summary:        Header files for farsight2 library
43 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki farsight2
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       gstreamer-devel >= 0.10.23
47 Requires:       gstreamer-plugins-base-devel >= 0.10.23
48
49 %description devel
50 Header files for farsight2 library.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe biblioteki farsight2.
54
55 %package static
56 Summary:        Static farsight2 library
57 Summary(pl.UTF-8):      Statyczna biblioteka farsight2
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 Static farsight2 library.
63
64 %description static -l pl.UTF-8
65 Statyczna biblioteka farsight2.
66
67 %package apidocs
68 Summary:        farsight2 library API documentation
69 Summary(pl.UTF-8):      Dokumentacja API biblioteki farsight2
70 Group:          Documentation
71 Requires:       gtk-doc-common
72
73 %description apidocs
74 farsight2 library API documentation.
75
76 %description apidocs -l pl.UTF-8
77 Dokumentacja API biblioteki farsight2.
78
79 %package -n python-farsight2
80 Summary:        farsight2 Python bindings
81 Summary(pl.UTF-8):      Wiązania Pythona do farsight2
82 Group:          Libraries/Python
83 Requires:       %{name} = %{version}-%{release}
84
85 %description -n python-farsight2
86 farsight2 Python bindings.
87
88 %description -n python-farsight2 -l pl.UTF-8
89 Wiązania Pythona do farsight2.
90
91 %prep
92 %setup -q
93 %patch0 -p1
94
95 %build
96 %{__gtkdocize}
97 %{__libtoolize}
98 %{__aclocal} -I common/m4 -I m4
99 %{__autoconf}
100 %{__autoheader}
101 %{__automake}
102 %configure \
103         --enable-gtk-doc \
104         --with-html-dir=%{_gtkdocdir}
105
106 %{__make}
107
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 %{__rm} $RPM_BUILD_ROOT%{_libdir}/farsight2-0.0/*.{a,la}
116 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gstreamer-0.10/*.{a,la}
117 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post   -p /sbin/ldconfig
123 %postun -p /sbin/ldconfig
124
125 %files
126 %defattr(644,root,root,755)
127 %doc AUTHORS ChangeLog NEWS README
128 %attr(755,root,root) %{_libdir}/libgstfarsight-0.10.so.*.*.*
129 %attr(755,root,root) %ghost %{_libdir}/libgstfarsight-0.10.so.0
130 %dir %{_libdir}/farsight2-0.0
131 %attr(755,root,root) %{_libdir}/farsight2-0.0/libmulticast-transmitter.so
132 %attr(755,root,root) %{_libdir}/farsight2-0.0/libnice-transmitter.so
133 %attr(755,root,root) %{_libdir}/farsight2-0.0/librawudp-transmitter.so
134 %attr(755,root,root) %{_libdir}/gstreamer-0.10/libfsfunnel.so
135 %attr(755,root,root) %{_libdir}/gstreamer-0.10/libfsmsnconference.so
136 %attr(755,root,root) %{_libdir}/gstreamer-0.10/libfsrtcpfilter.so
137 %attr(755,root,root) %{_libdir}/gstreamer-0.10/libfsrtpconference.so
138 %attr(755,root,root) %{_libdir}/gstreamer-0.10/libfsvideoanyrate.so
139
140 %files devel
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_libdir}/libgstfarsight-0.10.so
143 %{_libdir}/libgstfarsight-0.10.la
144 %{_includedir}/gstreamer-0.10/gst/farsight
145 %{_pkgconfigdir}/farsight2-0.10.pc
146
147 %files static
148 %defattr(644,root,root,755)
149 %{_libdir}/libgstfarsight-0.10.a
150
151 %files apidocs
152 %defattr(644,root,root,755)
153 %{_gtkdocdir}/farsight2-libs-0.10
154 %{_gtkdocdir}/farsight2-plugins-0.10
155
156 %files -n python-farsight2
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{py_sitedir}/farsight.so
This page took 0.08258 seconds and 3 git commands to generate.