]> git.pld-linux.org Git - packages/farsight2.git/blob - farsight2.spec
4728e3757f86611ed5da2c9fa9e7242fe9a6c53e
[packages/farsight2.git] / farsight2.spec
1 Summary:        Audio/Video Communications Framework
2 Name:           farsight2
3 Version:        0.0.23
4 Release:        1
5 License:        LGPL v2+
6 Group:          Libraries
7 URL:            http://farsight.freedesktop.org/
8 Source0:        http://farsight.freedesktop.org/releases/farsight2/%{name}-%{version}.tar.gz
9 # Source0-md5:  0e534ae97139a68cee16b5190cc5cd9c
10 BuildRequires:  autoconf >= 2.60
11 BuildRequires:  automake
12 BuildRequires:  docbook-dtd412-xml
13 BuildRequires:  glib2-devel >= 1:2.16.0
14 BuildRequires:  gstreamer-devel >= 0.10.23
15 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.23
16 BuildRequires:  gtk-doc >= 1.8
17 BuildRequires:  gupnp-devel >= 0.13
18 BuildRequires:  gupnp-igd-devel
19 BuildRequires:  libnice-devel >= 0.1.0
20 BuildRequires:  libtool
21 BuildRequires:  pkgconfig
22 BuildRequires:  python-devel >= 1:2.4
23 BuildRequires:  python-gstreamer-devel >= 0.10.10
24 BuildRequires:  python-pygtk-devel >= 2:2.12.0
25 BuildRequires:  rpm-pythonprov
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 The Farsight project is an effort to create a framework to deal with
30 all known audio/video conferencing protocols. On one side it offers a
31 generic API that makes it possible to write plugins for different
32 streaming protocols, on the other side it offers an API for clients to
33 use those plugins.
34
35 The main target clients for Farsight are Instant Messaging
36 applications. These applications should be able to use Farsight for
37 all their Audio/Video conferencing needs without having to worry about
38 any of the lower level streaming and NAT traversal issues.
39
40 %package devel
41 Summary:        Header files for farsight2 library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki farsight2
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       gstreamer-devel >= 0.10.23
46 Requires:       gstreamer-plugins-base-devel >= 0.10.23
47
48 %description devel
49 Header files for farsight2 library.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe biblioteki farsight2.
53
54 %package static
55 Summary:        Static farsight2 library
56 Summary(pl.UTF-8):      Statyczna biblioteka farsight2
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 Static farsight2 library.
62
63 %description static -l pl.UTF-8
64 Statyczna biblioteka farsight2.
65
66 %package apidocs
67 Summary:        farsight2 library API documentation
68 Summary(pl.UTF-8):      Dokumentacja API biblioteki farsight2
69 Group:          Documentation
70 Requires:       gtk-doc-common
71
72 %description apidocs
73 farsight2 library API documentation.
74
75 %description apidocs -l pl.UTF-8
76 Dokumentacja API biblioteki farsight2.
77
78 %package -n python-farsight2
79 Summary:        farsight2 Python bindings
80 Summary(pl.UTF-8):      Wiązania Pythona do farsight2
81 Group:          Libraries/Python
82 Requires:       %{name} = %{version}-%{release}
83
84 %description -n python-farsight2
85 farsight2 Python bindings.
86
87 %description -n python-farsight2 -l pl.UTF-8
88 Wiązania Pythona do farsight2.
89
90 %prep
91 %setup -q
92
93 %build
94 %{__gtkdocize}
95 %{__libtoolize}
96 %{__aclocal} -I common/m4 -I m4
97 %{__autoconf}
98 %{__autoheader}
99 %{__automake}
100 %configure \
101         --enable-gtk-doc \
102         --with-html-dir=%{_gtkdocdir}
103
104 %{__make}
105
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 %{__rm} $RPM_BUILD_ROOT%{_libdir}/farsight2-0.0/*.{a,la}
114 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gstreamer-0.10/*.{a,la}
115 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post   -p /sbin/ldconfig
121 %postun -p /sbin/ldconfig
122
123 %files
124 %defattr(644,root,root,755)
125 %doc AUTHORS ChangeLog NEWS README
126 %attr(755,root,root) %{_libdir}/libgstfarsight-0.10.so.*.*.*
127 %attr(755,root,root) %ghost %{_libdir}/libgstfarsight-0.10.so.0
128 %dir %{_libdir}/farsight2-0.0
129 %attr(755,root,root) %{_libdir}/farsight2-0.0/libmulticast-transmitter.so
130 %attr(755,root,root) %{_libdir}/farsight2-0.0/libnice-transmitter.so
131 %attr(755,root,root) %{_libdir}/farsight2-0.0/librawudp-transmitter.so
132 %attr(755,root,root) %{_libdir}/farsight2-0.0/libshm-transmitter.so
133 %attr(755,root,root) %{_libdir}/gstreamer-0.10/libfsfunnel.so
134 %attr(755,root,root) %{_libdir}/gstreamer-0.10/libfsmsnconference.so
135 %attr(755,root,root) %{_libdir}/gstreamer-0.10/libfsrtcpfilter.so
136 %attr(755,root,root) %{_libdir}/gstreamer-0.10/libfsrtpconference.so
137 %attr(755,root,root) %{_libdir}/gstreamer-0.10/libfsvideoanyrate.so
138
139 %files devel
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_libdir}/libgstfarsight-0.10.so
142 %{_libdir}/libgstfarsight-0.10.la
143 %{_includedir}/gstreamer-0.10/gst/farsight
144 %{_pkgconfigdir}/farsight2-0.10.pc
145
146 %files static
147 %defattr(644,root,root,755)
148 %{_libdir}/libgstfarsight-0.10.a
149
150 %files apidocs
151 %defattr(644,root,root,755)
152 %{_gtkdocdir}/farsight2-libs-0.10
153 %{_gtkdocdir}/farsight2-plugins-0.10
154
155 %files -n python-farsight2
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{py_sitedir}/farsight.so
This page took 0.062918 seconds and 2 git commands to generate.