]> git.pld-linux.org Git - packages/fann.git/blob - fann.spec
- updated python.patch, release 3
[packages/fann.git] / fann.spec
1 Summary:        A fast artificial neural network library
2 Summary(pl):    Szybka biblioteka do tworzenia sztucznych sieci neuronowych
3 Name:           fann
4 Version:        1.1.0
5 Release:        3
6 License:        LGPL
7 Group:          Libraries
8 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
9 # Source0-md5:  f8280e9849cfbf5ddf769713ce7f7fba
10 Patch0:         %{name}-python.patch
11 URL:            http://fann.sf.net/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  libtool
15 BuildRequires:  python-devel >= 1:2.3
16 BuildRequires:  swig
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Fast Artificial Neural Network (FANN) Library is written in ANSI C.
21 The library implements multilayer feedforward ANNs, up to 150 times
22 faster than other libraries. FANN supports execution in fixed point,
23 for fast execution on systems like the iPAQ.
24
25 %description -l pl
26 FANN (Fast Artificial Neural Network - szybkie sztuczne sieci
27 neuronowe) to biblioteka napisana w ANSI C, implementuj±ca
28 wielowarstwowe sztuczne sieci neuronowe, do 150 razy szybsza od innych
29 bibliotek. FANN obs³uguje operacje sta³oprzecinkowe w celu szybkiego
30 dzia³ania na systemach typu iPAQ.
31
32 %package devel
33 Summary:        Development libraries for FANN
34 Summary(pl):    Pliki nag³ówkowe FANN
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37
38 %description devel
39 This package is only needed if you intend to develop and/or compile
40 programs based on the FANN library.
41
42 %description devel -l pl
43 Pliki nag³ówkowe FANN, potrzebne do tworzenia programów napisanych w
44 oparciu o bibliotekê FANN.
45
46 %package static
47 Summary:        FANN static libraries
48 Summary(pl):    Biblioteki statyczne FANN
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{version}-%{release}
51
52 %description static
53 FANN static libraries.
54  
55 %description static -l pl
56 Biblioteki statyczne FANN.
57
58 %package -n python-%{name}
59 Summary:        Python support for FANN
60 Summary(pl):    Modu³ jêzyka Python dla biblioteki FANN
61 Group:          Libraries/Python
62 Requires:       %{name} = %{version}-%{release}
63 %pyrequires_eq  python-libs
64
65 %description -n python-%{name}
66 Python support for FANN.
67
68 %description -n python-%{name} -l pl
69 Modu³ jêzyka Python dla biblioteki FANN.
70
71 %prep
72 %setup -q
73 %patch0 -p1
74
75 %build
76 %{__libtoolize}
77 %{__aclocal}
78 %{__autoconf}
79 %{__automake}
80 %configure
81 %{__make}
82 %{__make} -C doc html-single
83 cd python
84 CFLAGS="%{rpmcflags}" \
85 %{__make}
86 %py_comp .
87 %py_ocomp .
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91
92 %{__make} install \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 install -d $RPM_BUILD_ROOT%{py_sitedir}
96 install -d $RPM_BUILD_ROOT%{_examplesdir}/{python-%{name}-%{version},%{name}-%{version}}
97
98 install python/{fann.pyc,fann.pyo,_fann.so} $RPM_BUILD_ROOT%{py_sitedir}
99 install python/simple_train.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
100 install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post   -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
107
108 %files
109 %defattr(644,root,root,755)
110 %doc AUTHORS ChangeLog NEWS README TODO
111 %attr(755,root,root) %{_libdir}/lib*.so.*.*
112
113 %files devel
114 %defattr(644,root,root,755)
115 %doc doc/fann.html
116 %attr(755,root,root) %{_libdir}/lib*.so
117 %{_libdir}/lib*.la
118 %{_includedir}/*.h
119 %{_pkgconfigdir}/fann.pc
120 %{_examplesdir}/%{name}-%{version}
121
122 %files static
123 %defattr(644,root,root,755)
124 %{_libdir}/lib*.a
125
126 %files -n python-%{name}
127 %defattr(644,root,root,755)
128 %attr(755,root,root) %{py_sitedir}/*.so
129 %{py_sitedir}/*.py[co]
130 %{_examplesdir}/python-%{name}-%{version}
This page took 0.061934 seconds and 3 git commands to generate.