]> git.pld-linux.org Git - packages/fann.git/blob - fann.spec
- more todo
[packages/fann.git] / fann.spec
1 #
2 # TODO:
3 # - add C examples
4 # - fix BRs
5 # - optflags for binary part of python module
6
7 Summary:        A fast artificial neural network library
8 Summary(pl):    Szybka biblioteka do tworzenia sztucznych sieci neuronowych
9 Name:           fann
10 Version:        1.1.0
11 Release:        1
12 License:        LGPL
13 Group:          Libraries
14 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
15 # Source0-md5:  f8280e9849cfbf5ddf769713ce7f7fba
16 Patch0:         %{name}-python.patch
17 URL:            http://fann.sf.net/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  libtool
21 BuildRequires:  python-devel >= 2.3
22 BuildRequires:  swig
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Fast Artificial Neural Network (FANN) Library is written in ANSI C.
27 The library implements multilayer feedforward ANNs, up to 150 times
28 faster than other libraries. FANN supports execution in fixed point,
29 for fast execution on systems like the iPAQ.
30
31 %description -l pl
32 FANN (Fast Artificial Neural Network - szybkie sztuczne sieci
33 neuronowe) to biblioteka napisana w ANSI C, implementuj±ca
34 wielowarstwowe sztuczne sieci neuronowe, do 150 razy szybsza od innych
35 bibliotek. FANN obs³uguje operacje sta³oprzecinkowe w celu szybkiego
36 dzia³ania na systemach typu iPAQ.
37
38 %package devel
39 Summary:        Development libraries for FANN
40 Summary(pl):    Pliki nag³ówkowe FANN
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43
44 %description devel
45 This package is only needed if you intend to develop and/or compile
46 programs based on the FANN library.
47
48 %description devel -l pl
49 Pliki nag³ówkowe FANN, potrzebne do tworzenia programów napisanych w
50 oparciu o bibliotekê FANN.
51
52 %package static
53 Summary:        FANN static libraries
54 Summary(pl):    Biblioteki statyczne FANN
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 FANN static libraries.
60  
61 %description static -l pl
62 Biblioteki statyczne FANN.
63
64 %package -n python-%{name}
65 Summary:        Python support for FANN
66 Summary(pl):    Modu³ jêzyka Python dla biblioteki FANN
67 Group:          Libraries/Python
68 Requires:       %{name} = %{version}-%{release}
69 %pyrequires_eq  python-libs
70
71 %description -n python-%{name}
72 Python support for FANN.
73
74 %description -n python-%{name} -l pl
75 Modu³ jêzyka Python dla biblioteki FANN.
76
77 %prep
78 %setup -q
79 %patch0 -p1
80
81 %build
82 %{__libtoolize}
83 %{__aclocal}
84 %{__autoconf}
85 %{__automake}
86 %configure
87 %{__make}
88 %{__make} -C doc html-single
89 cd python
90 CFLAGS="%{rpmcflags}" \
91 %{__make}
92 %py_comp .
93 %py_ocomp .
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %{__make} install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 install -d $RPM_BUILD_ROOT{%{py_sitedir},%{_examplesdir}/python-%{name}-%{version}}
102 install python/{fann.pyc,fann.pyo,_fann.so} $RPM_BUILD_ROOT%{py_sitedir}
103 install python/simple_train.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post   -p /sbin/ldconfig
109 %postun -p /sbin/ldconfig
110
111 %files
112 %defattr(644,root,root,755)
113 %doc AUTHORS ChangeLog NEWS README TODO
114 %attr(755,root,root) %{_libdir}/lib*.so.*.*
115
116 %files devel
117 %defattr(644,root,root,755)
118 %doc doc/fann.html
119 %attr(755,root,root) %{_libdir}/lib*.so
120 %{_libdir}/lib*.la
121 %{_includedir}/*.h
122 %{_pkgconfigdir}/fann.pc
123
124 %files static
125 %defattr(644,root,root,755)
126 %{_libdir}/lib*.a
127
128 %files -n python-%{name}
129 %defattr(644,root,root,755)
130 %attr(755,root,root) %{py_sitedir}/*.so
131 %{py_sitedir}/*.py[co]
132 %{_examplesdir}/python-%{name}-%{version}
This page took 0.052247 seconds and 3 git commands to generate.