]> git.pld-linux.org Git - packages/fakeroot.git/commitdiff
- raw version from MDK.
authorkloczek <kloczek@pld-linux.org>
Wed, 4 Apr 2001 18:09:58 +0000 (18:09 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    fakeroot.spec -> 1.1

fakeroot.spec [new file with mode: 0644]

diff --git a/fakeroot.spec b/fakeroot.spec
new file mode 100644 (file)
index 0000000..90b6cfa
--- /dev/null
@@ -0,0 +1,65 @@
+%define name fakeroot
+%define version 0.4.4
+%define release 1mdk
+%define debver 4.1
+
+Summary: Gives a fake root environment
+Name: %{name}
+Version: %{version}
+Release: %{release}
+Source0: %{name}_%{version}-%{debver}.tar.bz2
+Copyright: GPL
+Group: Development/Tools
+BuildRoot: /tmp/%{name}-buildroot
+Prefix: %{_prefix}
+
+%description
+This package is intended to enable something like:
+  fakeroot rpm --rebuild
+i.e. to remove the need to become root for a package build.
+This is done by setting LD_PRELOAD to a "libfakeroot.so.0.0",
+that provides wrappers around chown, chmod, mknod, stat,
+etc.
+
+If you don't understand any of this, you do not need this!
+
+%prep
+%setup
+
+%build
+%configure
+
+make    CFLAGS="-g -O2 -Wall -W -pedantic"\
+         CXXFLAGS="-g -O2 -Wall -W -pedantic"
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+mkdir -p $RPM_BUILD_ROOT/usr
+make CFLAGS="-g -O2 -Wall -W -pedantic"\
+     CXXFLAGS="-g -O2 -Wall -W -pedantic"\
+     prefix=$RPM_BUILD_ROOT/usr install
+install -d -m 0755 $RPM_BUILD_ROOT/usr/bin/
+install -m 0755 scripts/fakeroot $RPM_BUILD_ROOT/usr/bin/
+install -d -m 0755 $RPM_BUILD_ROOT/usr/lib/libfakeroot
+bzip2 -9f $RPM_BUILD_ROOT/usr/man/man*/*
+strip $RPM_BUILD_ROOT/usr/bin/faked
+strip $RPM_BUILD_ROOT/usr/lib/libfakeroot/libfakeroot.so.0.0.1
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-,root,root,0755)
+/usr/bin/*
+/usr/lib/libfakeroot/*
+%doc DEBUG
+%doc /usr/man/man*/*
+
+%changelog
+
+* Mon Jan 17 2000 Frederic Lepied <flepied@mandrakesoft.com> 0.4.4-1mdk
+
+- firct mandrake version.
+
+# end of file
This page took 0.064775 seconds and 4 git commands to generate.