]> git.pld-linux.org Git - packages/fakebo.git/blob - fakebo.spec
- added
[packages/fakebo.git] / fakebo.spec
1 Summary:        Fakes trojan servers and logs incoming requests
2 Name:           fakebo
3 Version:        0.4.1
4 Release:        1
5 License:        GPL
6 Group:          X11/Utilities
7 Group(pl):      X11/Narzêdzia
8 Source0:        ftp://ftp.linux.hr/pub/fakebo/%{name}-%{version}.tar.gz
9 Source1:        fakebo.init
10 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11 URL:            http://cvs.linux.hr/fakebo/
12 Requires:       /sbin/chkconfig
13
14 %description
15 FakeBO fakes trojan server responses (Back Orifice, NetBus, etc.) and
16 logs every attempt to a logfile or stdout. It is able to send fake
17 pings and replies back to the client trying to access your system.
18
19 %prep
20 %setup -q
21 %build
22 LDFLAGS="-s"; export LDFLAGS
23 %configure
24 %{__make}
25
26 %install
27 rm -rf $RPM_BUILD_ROOT
28
29 %{__make} install DESTDIR=$RPM_BUILD_ROOT
30
31 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
32 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/fakebo
33
34 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/*/* INSTALL HACKING \
35         AUTHORS TODO NEWS ChangeLog README custom.replies
36
37 %clean
38 rm -rf $RPM_BUILD_ROOT
39
40 %post
41 /sbin/chkconfig --add fakebo
42 if [ -f /var/lock/subsys/fakebo ]; then
43         /etc/rc.d/init.d/fakebo restart 1>&2
44 else
45         echo "Run \"/etc/rc.d/init.d/fakebo start\" to start fakebo daemon."
46 fi
47
48
49 %postun
50 if [ "$1" = 0 ]; then
51         if [ -f /var/lock/subsys/fakebo ]; then
52                 /etc/rc.d/init.d/fakebo stop 1>&2
53         fi
54         /sbin/chkconfig --del fakebo
55 fi
56
57 %files
58 %defattr(644,root,root,755)
59 %attr(755,root,root) %{_bindir}/fakebo
60 %attr(754,root,root) /etc/rc.d/init.d/fakebo
61 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/fakebo.conf
62 %{_mandir}/man1/fakebo.1*
63 %doc {INSTALL,HACKING,AUTHORS,TODO,NEWS,ChangeLog,README,custom.replies}.gz
This page took 0.70582 seconds and 3 git commands to generate.