]> git.pld-linux.org Git - packages/faad2.git/commitdiff
- updated to 2.7 auto/th/faad2-2_7-1 auto/ti/faad2-2.7-1
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 25 Oct 2010 20:40:33 +0000 (20:40 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- updated backward_compat,make,mp4ff patches
- removed obsolete ac patch
- added man patch and mv to install man page as faad2(1)

Changed files:
    faad2-ac.patch -> 1.2
    faad2-backward_compat.patch -> 1.3
    faad2-make.patch -> 1.4
    faad2-man.patch -> 1.1
    faad2-mp4ff.patch -> 1.3
    faad2.spec -> 1.37

faad2-ac.patch [deleted file]
faad2-backward_compat.patch
faad2-make.patch
faad2-man.patch [new file with mode: 0644]
faad2-mp4ff.patch
faad2.spec

diff --git a/faad2-ac.patch b/faad2-ac.patch
deleted file mode 100644 (file)
index 942f9e3..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -Nur faad2-orig/configure.in faad2/configure.in
---- faad2-orig/configure.in    2009-09-16 15:02:53.000000000 +0200
-+++ faad2/configure.in 2009-09-16 15:03:40.000000000 +0200
-@@ -16,6 +16,7 @@
- dnl Checks for programs.
- AC_PROG_CC
-+AC_PROG_CXX
- AC_PROG_CPP
- dnl disable for mpeg4ip plugin
- dnl AC_PROG_CXX
index 9b3c63528b10c7529d4766dc764b41945dc93bfb..a951cd3c9de8fdced2dd37290c10275205f7a382 100644 (file)
@@ -11,7 +11,7 @@
  drm_dec.c error.c filtbank.c \
 --- faad2/libfaad/decoder.c.orig       2007-11-01 13:33:30.000000000 +0100
 +++ faad2/libfaad/decoder.c    2007-11-04 12:36:41.315350439 +0100
-@@ -1115,3 +1115,47 @@
+@@ -1115,3 +1115,57 @@
  
      return NULL;
  }
 +#ifndef NO_BACKWARD_COMPAT
 +#  define ALIAS(type, func, target) type NEAACDECAPI func __attribute__((alias(#target)))
 +
++#undef faacDecGetErrorMessage
 +ALIAS(char*, faacDecGetErrorMessage(uint8_t errcode),
 +      NeAACDecGetErrorMessage);
 +
++#undef faacDecSetConfiguration
 +ALIAS(uint8_t, faacDecSetConfiguration(NeAACDecHandle hDecoder,
 +                                     NeAACDecConfigurationPtr config),
 +      NeAACDecSetConfiguration);
 +
++#undef faacDecGetCurrentConfiguration
 +ALIAS(NeAACDecConfigurationPtr, faacDecGetCurrentConfiguration(NeAACDecHandle hDecoder),
 +      NeAACDecGetCurrentConfiguration);
 +
++#undef faacDecInit
 +ALIAS(int32_t, faacDecInit(NeAACDecHandle hDecoder, uint8_t *buffer,
 +                         uint32_t buffer_size, uint32_t *samplerate, uint8_t *channels),
 +      NeAACDecInit);
 +
++#undef faacDecInit2
 +ALIAS(int8_t, faacDecInit2(NeAACDecHandle hDecoder, uint8_t *pBuffer,
 +                         uint32_t SizeOfDecoderSpecificInfo,
 +                         uint32_t *samplerate, uint8_t *channels),
 +      NeAACDecInit2);
 +
 +#ifdef DRM
++#undef faacDecInitDRM
 +ALIAS(int8_t, faacDecInitDRM(NeAACDecHandle *hDecoder, uint32_t samplerate,
 +                           uint8_t channels),
 +      NeAACDecInitDRM);
 +#endif
 +
++#undef faacDecPostSeekReset
 +ALIAS(void, faacDecPostSeekReset(NeAACDecHandle hDecoder, int32_t frame),
 +      NeAACDecPostSeekReset);
 +
++#undef faacDecOpen
 +ALIAS(NeAACDecHandle, faacDecOpen(void),
 +      NeAACDecOpen);
 +
++#undef faacDecClose
 +ALIAS(void, faacDecClose(NeAACDecHandle hDecoder),
 +      NeAACDecClose);
 +
++#undef faacDecDecode
 +ALIAS(void*, faacDecDecode(NeAACDecHandle hDecoder,
 +                         NeAACDecFrameInfo *hInfo,
 +                         uint8_t *buffer, uint32_t buffer_size),
@@ -61,7 +71,7 @@
 +#endif
 --- faad2/libfaad/mp4.c.orig   2007-11-01 13:33:32.000000000 +0100
 +++ faad2/libfaad/mp4.c        2007-11-04 12:35:57.860874110 +0100
-@@ -296,3 +296,13 @@
+@@ -296,3 +296,14 @@
  
      return result;
  }
@@ -69,6 +79,7 @@
 +#ifndef NO_BACKWARD_COMPAT
 +#  define ALIAS(type, func, target) type NEAACDECAPI func __attribute__((alias(#target)))
 +
++#undef AudioSpecificConfig
 +ALIAS(int8_t, AudioSpecificConfig(uint8_t *pBuffer,
 +                                uint32_t buffer_size,
 +                                mp4AudioSpecificConfig *mp4ASC),
index fbd3cb351eecf1e4055b12111da6af17def3c40a..c8e54f555ba5c2762aef8b4e3c0647fccd9f2245 100644 (file)
@@ -1,14 +1,3 @@
---- faad2/libfaad/Makefile.am.orig     2004-11-08 09:06:09.000000000 +0100
-+++ faad2/libfaad/Makefile.am  2007-11-04 11:44:26.132686561 +0100
-@@ -3,7 +3,7 @@ lib_LTLIBRARIES = libfaad.la
- include_HEADERS = $(top_srcdir)/include/faad.h \
-                   $(top_srcdir)/include/neaacdec.h
--libfaad_la_LDFLAGS = -lm
-+libfaad_la_LIBADD = -lm
- libfaad_la_SOURCES = bits.c cfft.c decoder.c drc.c \
- drm_dec.c error.c filtbank.c \
 --- faad2/plugins/xmms/src/Makefile.am.orig    2006-09-25 21:52:53.000000000 +0200
 +++ faad2/plugins/xmms/src/Makefile.am 2007-11-04 11:45:59.870028348 +0100
 @@ -1,7 +1,7 @@
diff --git a/faad2-man.patch b/faad2-man.patch
new file mode 100644 (file)
index 0000000..3b08ebb
--- /dev/null
@@ -0,0 +1,9 @@
+--- faad2-2.7/frontend/Makefile.am.orig        2010-10-25 20:33:12.575740205 +0200
++++ faad2-2.7/frontend/Makefile.am     2010-10-25 21:05:15.419741043 +0200
+@@ -1,5 +1,5 @@
+ bin_PROGRAMS = faad
+-man_MANS = faad.man
++man_MANS = faad.1
+ INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/common/faad \
+          -I$(top_srcdir)/common/mp4ff
index 08ecfdec7c94cfc431f991fb0b772434a1d3aa7e..615d58b2a5971f5d72914be666e8895136f30753 100644 (file)
@@ -1,15 +1,36 @@
---- faad2/common/mp4ff/Makefile.am.wiget       2009-10-28 18:54:29.000000000 +0100
-+++ faad2/common/mp4ff/Makefile.am     2009-10-28 18:56:28.000000000 +0100
-@@ -1,8 +1,9 @@
--noinst_LTLIBRARIES = libmp4ff.la
+--- faad2-2.7/common/mp4ff/Makefile.am.orig    2009-02-06 15:24:21.000000000 +0100
++++ faad2-2.7/common/mp4ff/Makefile.am 2010-10-25 19:57:49.095738529 +0200
+@@ -1,7 +1,7 @@
+-lib_LIBRARIES = libmp4ff.a
+-include_HEADERS = mp4ff.h mp4ffint.h
 +lib_LTLIBRARIES = libmp4ff.la
-+
-+include_HEADERS = mp4ff.h mp4ff_int_types.h
++include_HEADERS = mp4ff.h mp4ffint.h mp4ff_int_types.h
  
- libmp4ff_la_CFLAGS = -DUSE_TAGGING=1
+-libmp4ff_a_CFLAGS = -DUSE_TAGGING=1
++libmp4ff_la_CFLAGS = -DUSE_TAGGING=1
+-libmp4ff_a_SOURCES = mp4ff.c mp4atom.c mp4meta.c mp4sample.c mp4util.c \
++libmp4ff_la_SOURCES = mp4ff.c mp4atom.c mp4meta.c mp4sample.c mp4util.c \
+                    mp4tagupdate.c mp4ff.h mp4ffint.h mp4ff_int_types.h
+--- faad2-2.7/frontend/Makefile.am.orig        2009-02-06 17:03:37.000000000 +0100
++++ faad2-2.7/frontend/Makefile.am     2010-10-25 20:08:54.015739367 +0200
+@@ -5,7 +5,7 @@
+          -I$(top_srcdir)/common/mp4ff
+ faad_LDADD = $(top_builddir)/libfaad/libfaad.la \
+-           $(top_builddir)/common/mp4ff/libmp4ff.a
++           $(top_builddir)/common/mp4ff/libmp4ff.la
+ faad_SOURCES = main.c \
+              audio.c audio.h \
+--- faad2-2.7/plugins/xmms/src/Makefile.am.orig        2010-10-25 20:09:20.343741882 +0200
++++ faad2-2.7/plugins/xmms/src/Makefile.am     2010-10-25 20:32:37.203740205 +0200
+@@ -7,7 +7,7 @@
+        -I$(top_srcdir)/include -I$(top_srcdir)/common/mp4ff
+ libmp4_la_LIBADD = $(top_builddir)/libfaad/libfaad.la \
+-       $(top_builddir)/common/mp4ff/libmp4ff.a
++       $(top_builddir)/common/mp4ff/libmp4ff.la
+ libmp4_la_LDFLAGS = -module -avoid-version $(local_LDFLAGS) -lpthread
  
- libmp4ff_la_SOURCES = mp4ff.c mp4atom.c mp4meta.c mp4sample.c mp4util.c \
--   mp4tagupdate.c mp4ff.h mp4ffint.h mp4ff_int_types.h \
-+   mp4tagupdate.c mp4ffint.h \
-    drms.h drms.c drmstables.h
--
index 8a86eaa9a31829ce3c67fec9fcab4cb4e5a5871e..a37c0dedaa72b454e80e245c625a7330acd570c6 100644 (file)
@@ -9,18 +9,18 @@
 Summary:       Freeware Advanced Audio Decoder 2
 Summary(pl.UTF-8):     Darmowy zaawansowany dekoder audio
 Name:          faad2
-Version:       2.6.1
-Release:       6
-License:       GPL
+Version:       2.7
+Release:       1
+License:       GPL v2+
 Group:         Applications/Sound
-Source0:       http://downloads.sourceforge.net/faac/%{name}-%{version}.tar.gz
-# Source0-md5: 74e92df40c270f216a8305fc87603c8a
+Source0:       http://downloads.sourceforge.net/faac/%{name}-%{version}.tar.bz2
+# Source0-md5: 4c332fa23febc0e4648064685a3d4332
 Patch0:                %{name}-make.patch
 Patch1:                %{name}-mpeg4ip.patch
 Patch2:                %{name}-soname.patch
 Patch3:                %{name}-backward_compat.patch
-Patch4:                %{name}-ac.patch
-Patch5:                %{name}-mp4ff.patch
+Patch4:                %{name}-mp4ff.patch
+Patch5:                %{name}-man.patch
 URL:           http://www.audiocoding.com/
 %{?with_mpeg4ip:BuildRequires: SDL-devel}
 BuildRequires: autoconf
@@ -108,13 +108,14 @@ XMMS plugin for AAC files.
 Wtyczka XMMS do plików AAC.
 
 %prep
-%setup -q -n %{name}
+%setup -q
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
+mv -f frontend/faad.{man,1}
 
 %build
 %{__libtoolize}
@@ -135,8 +136,8 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-rm -f $RPM_BUILD_ROOT%{xmms_input_plugindir}/*.{la,a}
-rm -f $RPM_BUILD_ROOT%{_libdir}/mp4player_plugin/*.{la,a}
+%{__rm} $RPM_BUILD_ROOT%{xmms_input_plugindir}/*.{la,a}
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/mp4player_plugin/*.{la,a}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -147,6 +148,7 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/faad
+%{_mandir}/man1/faad.1*
 
 %files libs
 %defattr(644,root,root,755)
@@ -165,6 +167,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/faad.h
 %{_includedir}/mp4ff.h
 %{_includedir}/mp4ff_int_types.h
+%{_includedir}/mp4ffint.h
 %{_includedir}/neaacdec.h
 
 %if %{with static_libs}
This page took 0.049751 seconds and 4 git commands to generate.