]> git.pld-linux.org Git - packages/f2c.git/blob - f2c.spec
- use -fPIC for libf2c
[packages/f2c.git] / f2c.spec
1 Summary:        The f2c Fortran to C/C++ conversion program and libraries
2 Summary(pl):    Program f2c do t³umaczenia z Fortranu na C/C++ i biblioteki
3 Name:           f2c
4 Version:        20031027
5 Release:        1
6 License:        Distributable
7 Group:          Development/Languages/Fortran
8 Source0:        %{name}-%{version}.tar.bz2
9 # Source0-md5:  bcd2c9ba1307c9fc9f73027c3c4e3d4c
10 Patch0:         %{name}-20031027.patch
11 URL:            ftp://ftp.netlib.org/f2c/
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 f2c converts Fortran 77 source code to C or C++ source files. If no
16 Fortran files are named on the command line, f2c can read Fortran from
17 standard input and write C to standard output.
18
19 f2c can also be used (with the -P option) to generate ANSI C header
20 files for calling Fortran routines from C.
21
22 %description -l pl
23 f2c s³u¿y do t³umaczenia kodu ¼ród³owego w Fortranie 77 na kod
24 daj±c w wyniku pliki z kodem ¼ród³owym w C lub C++. Je¶li w wierszu
25 polecenia nie zostan± podane ¿adne pliki, f2c bêdzie oczekiwa³ kodu w
26 Fortranie na standardowym wej¶ciu i pisa³ kod w C na standardowe
27 wyj¶cie.
28
29 f2c mo¿e równie¿ s³u¿yæ (z opcj± -P) do generowania plików
30 nag³ówkowych ANSI C w celu wywo³ywania procedur fortranowskich z C.
31
32 %prep
33 %setup -q
34 %patch0 -p1
35
36 %build
37 %ifarch alpha
38 MFLAG=-mieee
39 %endif
40
41 mkdir -p libf2c/PIC
42
43 cp -f libf2c/makefile.u libf2c/Makefile
44 cp -f src/makefile.u src/Makefile
45 make -C src f2c \
46         CC="%{__cc}" \
47         RPM_OPT_FLAGS="%{rpmcflags}" \
48         MFLAG="$MFLAG"
49 make -C libf2c \
50         CC="%{__cc}" \
51         RPM_OPT_FLAGS="%{rpmcflags} -fPIC" \
52         MFLAG="$MFLAG" 
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir},%{_includedir}}
57
58 install libf2c/libf2c.a $RPM_BUILD_ROOT%{_libdir}
59 install f2c.h $RPM_BUILD_ROOT%{_includedir}
60 install src/f2c $RPM_BUILD_ROOT%{_bindir}
61 install fc $RPM_BUILD_ROOT%{_bindir}
62 install src/f2c.1t $RPM_BUILD_ROOT%{_mandir}/man1/f2c.1
63 install libf2c/libf2c.so.0.22 $RPM_BUILD_ROOT%{_libdir}
64 ln -sf libf2c.so.0.22 $RPM_BUILD_ROOT%{_libdir}/libf2c.so
65
66 rm -rf $RPM_BUILD_ROOT%{_prefix}/liblibf2c.so
67  
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %post   -p /sbin/ldconfig
72 %postun -p /sbin/ldconfig
73
74 %files
75 %defattr(644,root,root,755)
76 %doc f2c.ps README permission disclaimer changes src/Notice
77 %attr(755,root,root) %{_bindir}/*
78 %attr(755,root,root) %{_libdir}/libf2c.so.*.*
79 %attr(755,root,root) %{_libdir}/libf2c.so
80 %{_libdir}/libf2c.a
81 %{_includedir}/f2c.h
82 %{_mandir}/*/*
This page took 0.055644 seconds and 3 git commands to generate.