]> git.pld-linux.org Git - packages/f-spot.git/commitdiff
- fix compilation issues with new mono in taglib
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 28 Oct 2010 20:43:21 +0000 (20:43 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  https://bugzilla.gnome.org/show_bug.cgi?id=629222

Changed files:
    f-spot-taglib.patch -> 1.1
    f-spot.spec -> 1.104

f-spot-taglib.patch [new file with mode: 0644]
f-spot.spec

diff --git a/f-spot-taglib.patch b/f-spot-taglib.patch
new file mode 100644 (file)
index 0000000..e2d48e6
--- /dev/null
@@ -0,0 +1,47 @@
+From c1ef435b47a111046b86a5df33d98829762dc3ab Mon Sep 17 00:00:00 2001
+From: Marek Habersack <grendel@twistedcode.net>
+Date: Wed, 15 Sep 2010 23:18:08 +0200
+Subject: [PATCH] All fields of a struct must be initialized before the constructor returns
+
+---
+ src/TagLib/IFD/Entries/Rational.cs  |    6 ++++--
+ src/TagLib/IFD/Entries/SRational.cs |    6 ++++--
+ 2 files changed, 8 insertions(+), 4 deletions(-)
+
+diff --git a/src/TagLib/IFD/Entries/Rational.cs b/src/TagLib/IFD/Entries/Rational.cs
+index e8a69c5..2113a9a 100644
+--- f-spot-0.8.0/lib/TagLib/TagLib/src/TagLib/IFD/Entries/Rational.cs~
++++ f-spot-0.8.0/lib/TagLib/TagLib/src/TagLib/IFD/Entries/Rational.cs
+@@ -62,8 +62,10 @@ namespace TagLib.IFD.Entries
+               /// </param>
+               public Rational (uint numerator, uint denominator)
+               {
+-                      Numerator = numerator;
+-                      Denominator = denominator;
++                      if (denominator == 0)
++                              throw new ArgumentException ("denominator");
++                      this.numerator = numerator;
++                      this.denominator = denominator;
+               }
+ #endregion
+diff --git a/src/TagLib/IFD/Entries/SRational.cs b/src/TagLib/IFD/Entries/SRational.cs
+index f80dee8..59ca58a 100644
+--- f-spot-0.8.0/lib/TagLib/TagLib/src/TagLib/IFD/Entries/SRational.cs~
++++ f-spot-0.8.0/lib/TagLib/TagLib/src/TagLib/IFD/Entries/SRational.cs
+@@ -62,8 +62,10 @@ namespace TagLib.IFD.Entries
+               /// </param>
+               public SRational (int numerator, int denominator)
+               {
+-                      Numerator = numerator;
+-                      Denominator = denominator;
++                      if (denominator == 0)
++                              throw new ArgumentException ("denominator");
++                      this.numerator = numerator;
++                      this.denominator = denominator;
+               }
+ #endregion
+-- 
+1.7.2.3
+
index fc4f193e116b940260c68dd8cd24e613eb34ce01..71cf86cb2fe6f424a53bf66366eb41f940dd72c0 100644 (file)
@@ -11,6 +11,7 @@ License:      GPL
 Group:         X11/Applications/Graphics
 Source0:       http://ftp.gnome.org/Public/GNOME/sources/f-spot/0.8/%{name}-%{version}.tar.bz2
 # Source0-md5: f7d52adbf280c972adccd66338e49f3d
+Patch0:                %{name}-taglib.patch
 URL:           http://www.gnome.org/projects/f-spot/
 BuildRequires: GConf2-devel >= 2.14.0
 BuildRequires: autoconf
@@ -69,6 +70,7 @@ Moduł F-Spot dla gnome-screensavera.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %{__intltoolize}
This page took 0.07487 seconds and 4 git commands to generate.