]> git.pld-linux.org Git - packages/ezcomponents.git/blob - ezcomponents.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/ezcomponents.git] / ezcomponents.spec
1 Summary:        eZ Components
2 Name:           ezcomponents
3 Version:        2008.2
4 Release:        0.1
5 License:        New BSD License
6 Group:          Development/Languages/PHP
7 Source0:        http://ezcomponents.org/files/downloads/%{name}-%{version}.tar.bz2
8 # Source0-md5:  57b211e2e85670633ebb165e14742f95
9 URL:            http://www.ezcomponents.org/
10 BuildRequires:  php-common >= 4:5.2.1
11 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
12 BuildRequires:  rpmbuild(macros) >= 1.461
13 BuildArch:      noarch
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         _appdir %{php_data_dir}/%{name}
17
18 # fool adapter: allow version macro in url
19 %define         docver  %{version}
20
21 %description
22 eZ Components is an enterprise ready general purpose PHP components
23 library used independently or together for PHP application
24 development. With eZ Components, developers do not have to reinvent
25 the wheel, instead they can concentrate on solving customer-specific
26 needs.
27
28 %package Archive
29 Summary:        Archive
30 Group:          Development/Languages/PHP
31 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Archive.html
32 Requires:       %{name} = %{version}-%{release}
33
34 %description Archive
35 The component allows you to create, modify, and extract archive files
36 of various formats. The currently supported archives formats are Tar
37 (with the flavours: ustar, v7, pax, and gnu) and Zip.
38
39 %package Authentication
40 Summary:        Authentication
41 Group:          Development/Languages/PHP
42 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Authentication.html
43 Requires:       %{name} = %{version}-%{release}
44
45 %description Authentication
46 The purpose of the Authentication component is to provide support for
47 different means of identification and authentication of users using
48 different providers and protocols.
49
50 %package AuthenticationDatabaseTiein
51 Summary:        AuthenticationDatabaseTiein
52 Group:          Development/Languages/PHP
53 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_AuthenticationDatabaseTiein.html
54 Requires:       %{name} = %{version}-%{release}
55
56 %description AuthenticationDatabaseTiein
57 The purpose of the Authentication component is to provide support for
58 different means of identification and authentication of users using
59 different providers and protocols.
60
61 %package Base
62 Summary:        Base
63 Group:          Development/Languages/PHP
64 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Base.html
65 Requires:       %{name} = %{version}-%{release}
66
67 %description Base
68 The Base package provides the basic infrastructure that all packages
69 rely on. Therefore every component relies on this package.
70
71 %package Cache
72 Summary:        Cache
73 Group:          Development/Languages/PHP
74 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Cache.html
75 Requires:       %{name} = %{version}-%{release}
76
77 %description Cache
78 A solution for caching, supporting multiple backends allowing you to
79 specify the best performing solution for your caching-problem.
80
81 %package Configuration
82 Summary:        Configuration
83 Group:          Development/Languages/PHP
84 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Configuration.html
85 Requires:       %{name} = %{version}-%{release}
86
87 %description Configuration
88 A component that allows you to use configuration files in different
89 formats. The formats include the standard .ini file, and an array
90 based format.
91
92 %package ConsoleTools
93 Summary:        ConsoleTools
94 Group:          Development/Languages/PHP
95 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_ConsoleTools.html
96 Requires:       %{name} = %{version}-%{release}
97
98 %description ConsoleTools
99 A set of classes to do different actions with the console (also called
100 shell). It can render a progress bar, tables and a status bar and
101 contains a class for parsing command line options.
102
103 %package Database
104 Summary:        Database
105 Group:          Development/Languages/PHP
106 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Database.html
107 Requires:       %{name} = %{version}-%{release}
108
109 %description Database
110 A lightweight database layer on top of PHP's PDO that allows you to
111 utilize a database without having to take care of differences in SQL
112 dialects.
113
114 %package DatabaseSchema
115 Summary:        DatabaseSchema
116 Group:          Development/Languages/PHP
117 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_DatabaseSchema.html
118 Requires:       %{name} = %{version}-%{release}
119
120 %description DatabaseSchema
121 A set of classes that allow you to extract information from a database
122 schema, compare database schemas and apply a set of changes to a
123 database schema.
124
125 %package Debug
126 Summary:        Debug
127 Group:          Development/Languages/PHP
128 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Debug.html
129 Requires:       %{name} = %{version}-%{release}
130
131 %description Debug
132 This component provides a set of classes that help you to debug an
133 application. It provides timers and report generators for different
134 formats that give a summary of warnings and errors that occurred
135 within your application.
136
137 %package Document
138 Summary:        Document
139 Group:          Development/Languages/PHP
140 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Document.html
141 Requires:       %{name} = %{version}-%{release}
142
143 %description Document
144 The Document components provides a general conversion framework for
145 different semantic document markup languages like XHTML, Docbook, RST
146 and similar.
147
148 %package EventLog
149 Summary:        EventLog
150 Group:          Development/Languages/PHP
151 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_EventLog.html
152 Requires:       %{name} = %{version}-%{release}
153
154 %description EventLog
155 Allows you to log events or audit trails into files or other storage
156 spaces in different formats.
157
158 %package EventLogDatabaseTiein
159 Summary:        EventLogDatabaseTiein
160 Group:          Development/Languages/PHP
161 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_EventLogDatabaseTiein.html
162 Requires:       %{name} = %{version}-%{release}
163
164 %description EventLogDatabaseTiein
165 Contains the database writer backend for the EventLog component.
166
167 %package Execution
168 Summary:        Execution
169 Group:          Development/Languages/PHP
170 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Execution.html
171 Requires:       %{name} = %{version}-%{release}
172
173 %description Execution
174 Provides functionality to give feedback to your application's users
175 when a fatal error happened or an uncaught exception was thrown.
176
177 %package Feed
178 Summary:        Feed
179 Group:          Development/Languages/PHP
180 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Feed.html
181 Requires:       %{name} = %{version}-%{release}
182
183 %description Feed
184 This component handles parsing and creating RSS1, RSS2 and ATOM feeds,
185 with support for different feed modules (dc, content, creativeCommons,
186 geo, iTunes).
187
188 %package File
189 Summary:        File
190 Group:          Development/Languages/PHP
191 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_File.html
192 Requires:       %{name} = %{version}-%{release}
193
194 %description File
195 Provides support for file operations which are not covered by PHP or
196 are just missing.
197
198 %package Graph
199 Summary:        Graph
200 Group:          Development/Languages/PHP
201 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Graph.html
202 Requires:       %{name} = %{version}-%{release}
203
204 %description Graph
205 A component for creating pie charts, line graphs and other kinds of
206 diagrams.
207
208 %package GraphDatabaseTiein
209 Summary:        GraphDatabaseTiein
210 Group:          Development/Languages/PHP
211 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_GraphDatabaseTiein.html
212 Requires:       %{name} = %{version}-%{release}
213
214 %description GraphDatabaseTiein
215 The GraphDatabaseTiein provides functionality to directly use PDO
216 statements as basis for ezcGraph Datasets.
217
218 %package ImageAnalysis
219 Summary:        ImageAnalysis
220 Group:          Development/Languages/PHP
221 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_ImageAnalysis.html
222 Requires:       %{name} = %{version}-%{release}
223
224 %description ImageAnalysis
225 This class allows you to analyse image files in different ways. At
226 least the MIME type of the file is returned. In some cases (JPEG, TIFF
227 and GIF) additional information is gathered as well.
228
229 %package ImageConversion
230 Summary:        ImageConversion
231 Group:          Development/Languages/PHP
232 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_ImageConversion.html
233 Requires:       %{name} = %{version}-%{release}
234
235 %description ImageConversion
236 A set of classes to apply different filters on images, such as colour
237 changes, resizing and special effects.
238
239 %package Mail
240 Summary:        Mail
241 Group:          Development/Languages/PHP
242 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Mail.html
243 Requires:       %{name} = %{version}-%{release}
244
245 %description Mail
246 The component allows you construct and/or parse Mail messages
247 conforming to the mail standard. It has support for attachments,
248 multipart messages and HTML mail. It also interfaces with SMTP to send
249 mail or IMAP, POP3 or mbox to retrieve e-mail.
250
251 %package MvcMailTiein
252 Summary:        MvcMailTiein
253 Group:          Development/Languages/PHP
254 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_MvcMailTiein.html
255 Requires:       %{name} = %{version}-%{release}
256
257 %description MvcMailTiein
258 This component provides a request parser that extracts request data
259 from e-mail messages.
260
261 %package MvcTemplateTiein
262 Summary:        MvcTemplateTiein
263 Group:          Development/Languages/PHP
264 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_MvcTemplateTiein.html
265 Requires:       %{name} = %{version}-%{release}
266
267 %description MvcTemplateTiein
268 This component provides a view handler that renders result data with
269 the Template component.
270
271 %package MvcTools
272 Summary:        MvcTools
273 Group:          Development/Languages/PHP
274 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_MvcTools.html
275 Requires:       %{name} = %{version}-%{release}
276
277 %description MvcTools
278 The MvcTools component provides functionality for request parsing,
279 routing, dispatching, views and response writing. With the tools in
280 this component you can very easily build an MVC framework.
281
282 %package PersistentObject
283 Summary:        PersistentObject
284 Group:          Development/Languages/PHP
285 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_PersistentObject.html
286 Requires:       %{name} = %{version}-%{release}
287
288 %description PersistentObject
289 This component allows you to store an arbitrary data structures to a
290 fixed database table. The component provides all the functionality
291 needed to fetch, list, delete etc these datastructures.
292
293 %package PersistentObjectDatabaseSchemaTiein
294 Summary:        PersistentObjectDatabaseSchemaTiein
295 Group:          Development/Languages/PHP
296 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_PersistentObjectDatabaseSchemaTiein.html
297 Requires:       %{name} = %{version}-%{release}
298
299 %description PersistentObjectDatabaseSchemaTiein
300 This component allows the automatic generation of PersistentObject
301 definition files from DatabaseSchema definitions.
302
303 %package PhpGenerator
304 Summary:        PhpGenerator
305 Group:          Development/Languages/PHP
306 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_PhpGenerator.html
307 Requires:       %{name} = %{version}-%{release}
308
309 %description PhpGenerator
310 Provides a simple interface for creating PHP files and executing PHP
311 code.
312
313 %package Search
314 Summary:        Search
315 Group:          Development/Languages/PHP
316 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Search.html
317 Requires:       %{name} = %{version}-%{release}
318
319 %description Search
320 The Search component provides an interface to index and query
321 documents with different search engine backends.
322
323 %package SignalSlot
324 Summary:        SignalSlot
325 Group:          Development/Languages/PHP
326 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_SignalSlot.html
327 Requires:       %{name} = %{version}-%{release}
328
329 %description SignalSlot
330 The SignalSlot component implements a mechanism for inter and intra
331 object communication through the use of signals and slots.
332
333 %package SystemInformation
334 Summary:        SystemInformation
335 Group:          Development/Languages/PHP
336 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_SystemInformation.html
337 Requires:       %{name} = %{version}-%{release}
338
339 %description SystemInformation
340 Provides access to common system variables, such as CPU type and
341 speed, and the available amount of memory.
342
343 %package Template
344 Summary:        Template
345 Group:          Development/Languages/PHP
346 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Template.html
347 Requires:       %{name} = %{version}-%{release}
348
349 %description Template
350 A fully functional Templating system, supporting template compilation
351 in different levels, user defined functions and operators, an
352 optimizer, output escaping for different output handlers to prevent
353 XSS and other security problems and a plug in system for extra
354 functionality (such as a Translation system).
355
356 %package TemplateTranslationTiein
357 Summary:        TemplateTranslationTiein
358 Group:          Development/Languages/PHP
359 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_TemplateTranslationTiein.html
360 Requires:       %{name} = %{version}-%{release}
361
362 %description TemplateTranslationTiein
363 Provides functionality to use translations inside templates.
364
365 %package Translation
366 Summary:        Translation
367 Group:          Development/Languages/PHP
368 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Translation.html
369 Requires:       %{name} = %{version}-%{release}
370
371 %description Translation
372 A component that reads XML translation definitions (the Qt Linguist
373 format), supports caching of translation contexts and presents you
374 with a class to apply translations to strings. A filter system allows
375 you to transform translation definitions for special use.
376
377 %package TranslationCacheTiein
378 Summary:        TranslationCacheTiein
379 Group:          Development/Languages/PHP
380 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_TranslationCacheTiein.html
381 Requires:       %{name} = %{version}-%{release}
382
383 %description TranslationCacheTiein
384 This component adds the TranslationCache backend to the Translation
385 component and allows cached translations.
386
387 %package Tree
388 Summary:        Tree
389 Group:          Development/Languages/PHP
390 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Tree.html
391 Requires:       %{name} = %{version}-%{release}
392
393 %description Tree
394 The Tree component handles the creating, manipulating and querying of
395 tree structures. The component supports different storage algorithms
396 for optimal performance.
397
398 %package TreeDatabaseTiein
399 Summary:        TreeDatabaseTiein
400 Group:          Development/Languages/PHP
401 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_TreeDatabaseTiein.html
402 Requires:       %{name} = %{version}-%{release}
403
404 %description TreeDatabaseTiein
405 The Tree component handles the creating, manipulating and querying of
406 tree structures. This component implements the database related
407 backends and data stores.
408
409 %package TreePersistentObjectTiein
410 Summary:        TreePersistentObjectTiein
411 Group:          Development/Languages/PHP
412 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_TreePersistentObjectTiein.html
413 Requires:       %{name} = %{version}-%{release}
414
415 %description TreePersistentObjectTiein
416 The Tree component handles the creating, manipulating and querying of
417 tree structures. This component uses persistent objects as data
418 storage for the data elements of the tree nodes.
419
420 %package Url
421 Summary:        Url
422 Group:          Development/Languages/PHP
423 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Url.html
424 Requires:       %{name} = %{version}-%{release}
425
426 %description Url
427 The Url package provides basic operations to handle urls (parse,
428 build, get/set path, get/set query).
429
430 %package UserInput
431 Summary:        UserInput
432 Group:          Development/Languages/PHP
433 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_UserInput.html
434 Requires:       %{name} = %{version}-%{release}
435
436 %description UserInput
437 A component that assists you to safely user input variables coming
438 into your application. It builds on top of PHP's filter extension and
439 extends it by providing a more inituitive API.
440
441 %package Webdav
442 Summary:        Webdav
443 Group:          Development/Languages/PHP
444 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Webdav.html
445 Requires:       %{name} = %{version}-%{release}
446
447 %description Webdav
448 This component allows you to set up and run your own WebDAV (RFC 2518)
449 server, to enable online content editing for the users of your system
450 through the WebDAV HTTP extension.
451
452 %package Workflow
453 Summary:        Workflow
454 Group:          Development/Languages/PHP
455 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_Workflow.html
456 Requires:       %{name} = %{version}-%{release}
457
458 %description Workflow
459 The purpose of the Workflow component is to provide the core
460 functionality of an activity-based workflow system including the
461 definition and execution of workflow specifications.
462
463 %package WorkflowDatabaseTiein
464 Summary:        WorkflowDatabaseTiein
465 Group:          Development/Languages/PHP
466 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_WorkflowDatabaseTiein.html
467 Requires:       %{name} = %{version}-%{release}
468
469 %description WorkflowDatabaseTiein
470 Contains the database backend for the Workflow component.
471
472 %package WorkflowEventLogTiein
473 Summary:        WorkflowEventLogTiein
474 Group:          Development/Languages/PHP
475 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_WorkflowEventLogTiein.html
476 Requires:       %{name} = %{version}-%{release}
477
478 %description WorkflowEventLogTiein
479 Contains the EventLog listener for the Workflow component.
480
481 %package WorkflowSignalSlotTiein
482 Summary:        WorkflowSignalSlotTiein
483 Group:          Development/Languages/PHP
484 URL:            http://www.ezcomponents.org/docs/api/%{docver}/classtrees_WorkflowSignalSlotTiein.html
485 Requires:       %{name} = %{version}-%{release}
486
487 %description WorkflowSignalSlotTiein
488 Contains the SignalSlot links for the Workflow component.
489
490 %prep
491 %setup -q
492
493 %install
494 rm -rf $RPM_BUILD_ROOT
495 install -d $RPM_BUILD_ROOT%{_appdir}
496
497 cp -a autoload $RPM_BUILD_ROOT%{_appdir}
498
499 for a in [A-Z]*/; do
500         a=${a%/}
501         cp -a $a/src $RPM_BUILD_ROOT%{_appdir}/$a
502
503         # produce spec template
504         cat > $a-desc.spec <<-EOF
505                 %%package $a
506                 Summary:        $a
507                 Group:          Development/Languages/PHP
508                 URL:            http://www.ezcomponents.org/docs/api/%%{version}/classtrees_$a.html
509                 Requires:       %%{name} = %%{version}-%%{release}
510
511                 %%description $a
512                 $(cat $a/DESCRIPTION)
513
514         EOF
515
516         cat > $a-files.spec <<-EOF
517                 %%files $a
518                 %%defattr(644,root,root,755)
519                 %%doc $a/{ChangeLog,CREDITS}$(
520                 if [ "$(ls $a/*.txt 2>/dev/null)" ]; then
521                         echo ""
522                         echo "%%doc $a/*.txt"
523                 fi
524                 )
525                 %%{_appdir}/$a
526
527         EOF
528 done
529 cat *-desc.spec *-files.spec > ez.spec
530 rm -f *-desc.spec *-files.spec
531
532 %clean
533 rm -rf $RPM_BUILD_ROOT
534
535 %files
536 %defattr(644,root,root,755)
537 %dir %{_appdir}
538 %{_appdir}/autoload
539
540 %files Archive
541 %defattr(644,root,root,755)
542 %doc Archive/{ChangeLog,CREDITS}
543 %{_appdir}/Archive
544
545 %files Authentication
546 %defattr(644,root,root,755)
547 %doc Authentication/{ChangeLog,CREDITS}
548 %doc Authentication/*.txt
549 %{_appdir}/Authentication
550
551 %files AuthenticationDatabaseTiein
552 %defattr(644,root,root,755)
553 %doc AuthenticationDatabaseTiein/{ChangeLog,CREDITS}
554 %{_appdir}/AuthenticationDatabaseTiein
555
556 %files Base
557 %defattr(644,root,root,755)
558 %doc Base/{ChangeLog,CREDITS}
559 %doc Base/*.txt
560 %{_appdir}/Base
561
562 %files Cache
563 %defattr(644,root,root,755)
564 %doc Cache/{ChangeLog,CREDITS}
565 %doc Cache/*.txt
566 %{_appdir}/Cache
567
568 %files Configuration
569 %defattr(644,root,root,755)
570 %doc Configuration/{ChangeLog,CREDITS}
571 %{_appdir}/Configuration
572
573 %files ConsoleTools
574 %defattr(644,root,root,755)
575 %doc ConsoleTools/{ChangeLog,CREDITS}
576 %doc ConsoleTools/*.txt
577 %{_appdir}/ConsoleTools
578
579 %files Database
580 %defattr(644,root,root,755)
581 %doc Database/{ChangeLog,CREDITS}
582 %{_appdir}/Database
583
584 %files DatabaseSchema
585 %defattr(644,root,root,755)
586 %doc DatabaseSchema/{ChangeLog,CREDITS}
587 %doc DatabaseSchema/*.txt
588 %{_appdir}/DatabaseSchema
589
590 %files Debug
591 %defattr(644,root,root,755)
592 %doc Debug/{ChangeLog,CREDITS}
593 %doc Debug/*.txt
594 %{_appdir}/Debug
595
596 %files Document
597 %defattr(644,root,root,755)
598 %doc Document/{ChangeLog,CREDITS}
599 %doc Document/*.txt
600 %{_appdir}/Document
601
602 %files EventLog
603 %defattr(644,root,root,755)
604 %doc EventLog/{ChangeLog,CREDITS}
605 %{_appdir}/EventLog
606
607 %files EventLogDatabaseTiein
608 %defattr(644,root,root,755)
609 %doc EventLogDatabaseTiein/{ChangeLog,CREDITS}
610 %{_appdir}/EventLogDatabaseTiein
611
612 %files Execution
613 %defattr(644,root,root,755)
614 %doc Execution/{ChangeLog,CREDITS}
615 %{_appdir}/Execution
616
617 %files Feed
618 %defattr(644,root,root,755)
619 %doc Feed/{ChangeLog,CREDITS}
620 %doc Feed/*.txt
621 %{_appdir}/Feed
622
623 %files File
624 %defattr(644,root,root,755)
625 %doc File/{ChangeLog,CREDITS}
626 %{_appdir}/File
627
628 %files Graph
629 %defattr(644,root,root,755)
630 %doc Graph/{ChangeLog,CREDITS}
631 %{_appdir}/Graph
632
633 %files GraphDatabaseTiein
634 %defattr(644,root,root,755)
635 %doc GraphDatabaseTiein/{ChangeLog,CREDITS}
636 %{_appdir}/GraphDatabaseTiein
637
638 %files ImageAnalysis
639 %defattr(644,root,root,755)
640 %doc ImageAnalysis/{ChangeLog,CREDITS}
641 %{_appdir}/ImageAnalysis
642
643 %files ImageConversion
644 %defattr(644,root,root,755)
645 %doc ImageConversion/{ChangeLog,CREDITS}
646 %doc ImageConversion/*.txt
647 %{_appdir}/ImageConversion
648
649 %files Mail
650 %defattr(644,root,root,755)
651 %doc Mail/{ChangeLog,CREDITS}
652 %doc Mail/*.txt
653 %{_appdir}/Mail
654
655 %files MvcMailTiein
656 %defattr(644,root,root,755)
657 %doc MvcMailTiein/{ChangeLog,CREDITS}
658 %{_appdir}/MvcMailTiein
659
660 %files MvcTemplateTiein
661 %defattr(644,root,root,755)
662 %doc MvcTemplateTiein/{ChangeLog,CREDITS}
663 %{_appdir}/MvcTemplateTiein
664
665 %files MvcTools
666 %defattr(644,root,root,755)
667 %doc MvcTools/{ChangeLog,CREDITS}
668 %doc MvcTools/*.txt
669 %{_appdir}/MvcTools
670
671 %files PersistentObject
672 %defattr(644,root,root,755)
673 %doc PersistentObject/{ChangeLog,CREDITS}
674 %doc PersistentObject/*.txt
675 %{_appdir}/PersistentObject
676
677 %files PersistentObjectDatabaseSchemaTiein
678 %defattr(644,root,root,755)
679 %doc PersistentObjectDatabaseSchemaTiein/{ChangeLog,CREDITS}
680 %{_appdir}/PersistentObjectDatabaseSchemaTiein
681
682 %files PhpGenerator
683 %defattr(644,root,root,755)
684 %doc PhpGenerator/{ChangeLog,CREDITS}
685 %{_appdir}/PhpGenerator
686
687 %files Search
688 %defattr(644,root,root,755)
689 %doc Search/{ChangeLog,CREDITS}
690 %doc Search/*.txt
691 %{_appdir}/Search
692
693 %files SignalSlot
694 %defattr(644,root,root,755)
695 %doc SignalSlot/{ChangeLog,CREDITS}
696 %{_appdir}/SignalSlot
697
698 %files SystemInformation
699 %defattr(644,root,root,755)
700 %doc SystemInformation/{ChangeLog,CREDITS}
701 %{_appdir}/SystemInformation
702
703 %files Template
704 %defattr(644,root,root,755)
705 %doc Template/{ChangeLog,CREDITS}
706 %doc Template/*.txt
707 %{_appdir}/Template
708
709 %files TemplateTranslationTiein
710 %defattr(644,root,root,755)
711 %doc TemplateTranslationTiein/{ChangeLog,CREDITS}
712 %{_appdir}/TemplateTranslationTiein
713
714 %files Translation
715 %defattr(644,root,root,755)
716 %doc Translation/{ChangeLog,CREDITS}
717 %doc Translation/*.txt
718 %{_appdir}/Translation
719
720 %files TranslationCacheTiein
721 %defattr(644,root,root,755)
722 %doc TranslationCacheTiein/{ChangeLog,CREDITS}
723 %{_appdir}/TranslationCacheTiein
724
725 %files Tree
726 %defattr(644,root,root,755)
727 %doc Tree/{ChangeLog,CREDITS}
728 %{_appdir}/Tree
729
730 %files TreeDatabaseTiein
731 %defattr(644,root,root,755)
732 %doc TreeDatabaseTiein/{ChangeLog,CREDITS}
733 %{_appdir}/TreeDatabaseTiein
734
735 %files TreePersistentObjectTiein
736 %defattr(644,root,root,755)
737 %doc TreePersistentObjectTiein/{ChangeLog,CREDITS}
738 %{_appdir}/TreePersistentObjectTiein
739
740 %files Url
741 %defattr(644,root,root,755)
742 %doc Url/{ChangeLog,CREDITS}
743 %doc Url/*.txt
744 %{_appdir}/Url
745
746 %files UserInput
747 %defattr(644,root,root,755)
748 %doc UserInput/{ChangeLog,CREDITS}
749 %{_appdir}/UserInput
750
751 %files Webdav
752 %defattr(644,root,root,755)
753 %doc Webdav/{ChangeLog,CREDITS}
754 %doc Webdav/*.txt
755 %{_appdir}/Webdav
756
757 %files Workflow
758 %defattr(644,root,root,755)
759 %doc Workflow/{ChangeLog,CREDITS}
760 %doc Workflow/*.txt
761 %{_appdir}/Workflow
762
763 %files WorkflowDatabaseTiein
764 %defattr(644,root,root,755)
765 %doc WorkflowDatabaseTiein/{ChangeLog,CREDITS}
766 %{_appdir}/WorkflowDatabaseTiein
767
768 %files WorkflowEventLogTiein
769 %defattr(644,root,root,755)
770 %doc WorkflowEventLogTiein/{ChangeLog,CREDITS}
771 %{_appdir}/WorkflowEventLogTiein
772
773 %files WorkflowSignalSlotTiein
774 %defattr(644,root,root,755)
775 %doc WorkflowSignalSlotTiein/{ChangeLog,CREDITS}
776 %{_appdir}/WorkflowSignalSlotTiein
This page took 0.122394 seconds and 4 git commands to generate.