]> git.pld-linux.org Git - packages/ext2ed.git/commitdiff
- missing patches/sources
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 20 Jul 1999 10:57:18 +0000 (10:57 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    ext2ed-FHS2.0.patch -> 1.1
    ext2ed-config.patch -> 1.1
    ext2ed-glibc.patch -> 1.1
    ext2ed-inode.patch -> 1.1
    ext2ed-opt.patch -> 1.1

ext2ed-FHS2.0.patch [new file with mode: 0644]
ext2ed-config.patch [new file with mode: 0644]
ext2ed-glibc.patch [new file with mode: 0644]
ext2ed-inode.patch [new file with mode: 0644]
ext2ed-opt.patch [new file with mode: 0644]

diff --git a/ext2ed-FHS2.0.patch b/ext2ed-FHS2.0.patch
new file mode 100644 (file)
index 0000000..29144a7
--- /dev/null
@@ -0,0 +1,16 @@
+diff -ur ext2ed.orig/Makefile ext2ed-0.1/Makefile
+--- ext2ed.orig/Makefile       Sun Jul 18 02:57:24 1999
++++ ext2ed-0.1/Makefile        Sun Jul 18 02:57:57 1999
+@@ -39,9 +39,9 @@
+ # The EXT2ED documentation will go into DOC_DIR.
+ BIN_DIR               =       /usr/bin
+-VAR_DIR               =       /var/lib/ext2ed
+-MAN_DIR               =       /usr/man/man8
+-DOC_DIR               =       /usr/doc/ext2ed
++VAR_DIR               =       /var/state/ext2ed
++MAN_DIR               =       /usr/share/man/man8
++DOC_DIR               =       /usr/share/doc/ext2ed
+ # ------------------------------------------------------------------------
diff --git a/ext2ed-config.patch b/ext2ed-config.patch
new file mode 100644 (file)
index 0000000..3a1a11f
--- /dev/null
@@ -0,0 +1,29 @@
+--- Makefile.orig      Wed Aug 30 16:23:04 1995
++++ Makefile   Wed Aug 30 17:14:23 1995
+@@ -24,9 +24,9 @@
+ # required ncurses and readline include files / libraries. Be sure that you
+ # don't mix two two versions of ncurses.
+-# NCURSES_INCLUDE     =       -I/usr/local/include -I/usr/local/include/ncurses
+-# NCURSES_LIB         =       -L/usr/local/lib
+-# READLINE_INCLUDE    =       -I/usr/include -I/usr/include/readline
++NCURSES_INCLUDE       =       -I/usr/include/ncurses
++# NCURSES_LIB         =       -L/usr//lib
++READLINE_INCLUDE      =       -I/usr/include/readline
+ # READLINE_LIB                =       -L/usr/lib
+ # ------------------------------------------------------------------------
+@@ -65,11 +65,12 @@
+ install: ext2ed
+       install -d $(VAR_DIR)
+-      install -d $(DOC_DIR)
+       install -m 755 ext2ed $(BIN_DIR)
+       install -m 644 ext2.descriptors $(VAR_DIR)
+       install -m 644 ext2ed.conf $(VAR_DIR)
+       install -m 644 doc/ext2ed.8 $(MAN_DIR)
++
++install.doc: 
+       install -m 644 doc/user-guide-0.1.sgml $(DOC_DIR)
+       install -m 644 doc/user-guide-0.1.ps $(DOC_DIR)
+       install -m 644 doc/Ext2fs-overview-0.1.sgml $(DOC_DIR)
diff --git a/ext2ed-glibc.patch b/ext2ed-glibc.patch
new file mode 100644 (file)
index 0000000..8764b89
--- /dev/null
@@ -0,0 +1,33 @@
+--- ext2ed-0.1/init.c.glibc    Thu Aug 24 17:26:39 1995
++++ ext2ed-0.1/init.c  Wed Apr 15 18:47:41 1998
+@@ -427,9 +427,9 @@
+ void init_signals (void)
+ {
+-      signal (SIGWINCH,(SignalHandler) signal_SIGWINCH_handler);      /* Catch SIGWINCH */
+-      signal (SIGTERM,(SignalHandler) signal_SIGTERM_handler);
+-      signal (SIGSEGV,(SignalHandler) signal_SIGSEGV_handler);
++      signal (SIGWINCH,(void *) signal_SIGWINCH_handler);     /* Catch SIGWINCH */
++      signal (SIGTERM,(void *) signal_SIGTERM_handler);
++      signal (SIGSEGV,(void *) signal_SIGSEGV_handler);
+       
+ }
+--- ext2ed-0.1/ext2ed.h.compat21       Tue Dec 22 12:37:16 1998
++++ ext2ed-0.1/ext2ed.h        Tue Dec 22 12:37:50 1998
+@@ -35,7 +35,7 @@
+ #define DEBUG                                         /* Activate self-sanity checks */
+ #include <linux/ext2_fs.h>                            /* Main kernel ext2 include file */
+-#include <linux/stat.h>
++#include <sys/stat.h>
+ #ifdef OLD_NCURSES                                    /* The ncurses interface */
+       #include <ncurses/ncurses.h>
+@@ -435,4 +435,4 @@
+ extern void redraw_all (void);
+ extern void close_windows (void);
+-#endif /* EXT2ED_EDITOR_H */
+\ No newline at end of file
++#endif /* EXT2ED_EDITOR_H */
diff --git a/ext2ed-inode.patch b/ext2ed-inode.patch
new file mode 100644 (file)
index 0000000..963dc55
--- /dev/null
@@ -0,0 +1,11 @@
+--- ext2ed-0.1/inode_com.c.ewt Thu Jul  4 12:05:29 1996
++++ ext2ed-0.1/inode_com.c     Thu Jul  4 12:06:11 1996
+@@ -214,7 +214,7 @@
+       
+       wprintw (show_win,"Inode type: ");
+-      if (inode_num < EXT2_FIRST_INO) {
++      if (inode_num < EXT2_GOOD_OLD_FIRST_INO) {
+               switch (inode_num) {
+                       case EXT2_BAD_INO:
+                               wprintw (show_win,"Bad blocks inode - ");
diff --git a/ext2ed-opt.patch b/ext2ed-opt.patch
new file mode 100644 (file)
index 0000000..5f49109
--- /dev/null
@@ -0,0 +1,12 @@
+diff -Nru ext2ed-0.1/Makefile ext2ed-0.1.new/Makefile
+--- ext2ed-0.1/Makefile        Mon Oct 12 10:14:44 1998
++++ ext2ed-0.1.new/Makefile    Mon Oct 12 10:16:06 1998
+@@ -46,7 +46,7 @@
+ # ------------------------------------------------------------------------
+ CC            =       gcc
+-CCFLAGS               =       -O $(FLAGS) -DVAR_DIR=\"$(VAR_DIR)\" $(NCURSES_INCLUDE) $(READLINE_INCLUDE)
++CCFLAGS               =       $(RPM_OPT_FLAGS) $(FLAGS) -DVAR_DIR=\"$(VAR_DIR)\" $(NCURSES_INCLUDE) $(READLINE_INCLUDE)
+ LINKFLAGS     =       $(NCURSES_LIB) $(READLINE_LIB)
+ LIBS          =       -lreadline -lncurses
This page took 0.102374 seconds and 4 git commands to generate.