]> git.pld-linux.org Git - packages/expect.git/commitdiff
- added alpha patch remainder (for mistake probably harmless, but...)
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 7 Aug 2003 22:04:42 +0000 (22:04 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    expect-alpha.patch -> 1.2
    expect.spec -> 1.51

expect-alpha.patch
expect.spec

index 542c51d08dec8d56f1da8ee80aa69ff96e1c5b0a..622ca63d0bdc818bd30bc9da966fe27e1b8e97b5 100644 (file)
@@ -1,23 +1,11 @@
---- expect5.31/exp_command.c.alpha     Tue Aug 17 15:51:00 1999
-+++ expect5.31/exp_command.c   Fri Mar 17 08:43:39 2000
-@@ -795,14 +795,18 @@
-           return TCL_ERROR;
-       }
-       if (mode & TCL_READABLE) {
--          if (TCL_ERROR == Tcl_GetChannelHandle(channel, TCL_READABLE, (ClientData) &rfd)) {
-+          ClientData rfd_data;
-+          if (TCL_ERROR == Tcl_GetChannelHandle(channel, TCL_READABLE, &rfd_data)) {
-               return TCL_ERROR;
-           }
-+          rfd = (int)rfd_data;
+--- expect-5.39/exp_command.c.orig     2003-07-31 20:21:42.000000000 +0200
++++ expect-5.39/exp_command.c  2003-08-07 22:11:03.000000000 +0200
+@@ -801,7 +801,7 @@
+           rfd = (int) rfdc;
        }
        if (mode & TCL_WRITABLE) {
--          if (TCL_ERROR == Tcl_GetChannelHandle(channel, TCL_WRITABLE, (ClientData) &wfd)) {
-+          ClientData wfd_data;
-+          if (TCL_ERROR == Tcl_GetChannelHandle(channel, TCL_WRITABLE, &wfd_data)) {
+-          if (TCL_ERROR == Tcl_GetChannelHandle(channel, TCL_WRITABLE, (ClientData) &wfdc)) {
++          if (TCL_ERROR == Tcl_GetChannelHandle(channel, TCL_WRITABLE, (ClientData *) &wfdc)) {
                return TCL_ERROR;
-           }    
-+          wfd = (int)wfd_data;
-       }
-       master = ((mode & TCL_READABLE)?rfd:wfd);
+           }
+           wfd = (int) wfdc;
index 6ef9704f70e6d3a9eec985da386a3179c687c5cd..ec6a44748ada44bc59bdc55a8a9034996dc72ec8 100644 (file)
@@ -14,7 +14,7 @@ Group:                Development/Languages/Tcl
 Source0:       http://expect.nist.gov/src/%{name}-%{version}.tar.gz
 # Source0-md5: 38a39787ef888f4fa009a8384d5c7c0a
 Patch0:                %{name}-pty.patch
-#Patch1:               %{name}-alpha.patch
+Patch1:                %{name}-alpha.patch
 Patch2:                %{name}-bug7869.patch
 Patch3:                %{name}-fixcat.patch
 Patch4:                %{name}-jbj.patch
@@ -106,7 +106,7 @@ Biblioteka statyczna rozszerzenia j
 %prep
 %setup -q -n %{name}-%{major}
 %patch0 -p1
-##%patch1 -p1
+%patch1 -p1
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
This page took 0.034072 seconds and 4 git commands to generate.