]> git.pld-linux.org Git - packages/expect.git/blob - expect.spec
- more fixes s/striping/stripping/.
[packages/expect.git] / expect.spec
1 Summary:     tcl extension to allow interaction between programs and scripts
2 Summary(de): tcl-Erweiterung zur Ermöglichung der Interaktion zwischen  Programmen und Skripts 
3 Summary(fr): Extension tcl permettant l'intéraction entre programmes et scripts"
4 Summary(pl): rozszerzenie tcl pozwalaj±ce na interakcjê miêdzy programami i skryptami
5 Summary(tr): Programlar arasý etkileþimi mümkün kýlan tcl geniþletmesi
6 Name:        expect
7 Version:     5.26
8 Release:     21
9 Copyright:   BSD
10 Group:       Development/Languages/Tcl
11 Source:      ftp://ftp.cme.nist.gov/pub/expect/expect.tar.gz
12 Icon:        %{name}.gif
13 Patch:       expect.patch
14 Buildroot:   /tmp/%{name}-%{version}-root
15
16 %description
17 Expect is a tool for automating interactive applications such as
18 telnet, ftp, passwd, fsck, rlogin, tip, etc. It makes it easy for a
19 script to control another program and interact with it.
20
21 %description -l pl
22 Expect to narzêdzie do automatyzacji interakcji z aplikacjami 
23 takimi jak telnet, ftp, passwd, fsck, rlogin, tip itp. Expect
24 pozwala w ³atwy sposób przy pomocy skryptu kontrolowaæ inny program.
25
26 %description -l de
27 Expect ist ein Tool zur Automatisierung interaktiver Applikationen 
28 wie telnet, ftp, passwd, fsck, rlogin, tip usw. Mit seiner Hilfe 
29 kann ein Skript ein anderes Programm sehr leicht steuern oder 
30 damit interagieren. 
31
32 %description -l fr
33 expect est un un outil pour automatiser les applications interactives
34 comme telnet, ftp, passwd, fsck, rlogin, tip, etc. Il est alors facile
35 pour un script de contrôler un autre programme et d'interagir avec lui.
36
37 %description -l tr
38 Expect telnet, ftp, passwd, fsck, rlogin, tip gibi etkileþimli uygulamalarý
39 otomatize etmeye yarayan bir araçtýr. Bir uygulamanýn bir diðer uygulamayý
40 denetlemesini kolaylaþtýrýr.
41
42 %package devel
43 Summary:     tcl extension header files and development documentation
44 Summary(pl): Pliki nag³ówkowe i dokumentacja developerska do rozszerzenia tcl
45 Group:       Development/Languages/Tcl
46 Requires:    %{name} = %{version}
47
48 %description devel
49 Tcl extension language header files and develppment documentation.
50
51 %description -l pl devel
52 Pliki nag³ówkowe i dokumentacja developersja do rozszerzenie jêzyka tcl.
53
54 %package static
55 Summary:     tcl extension static library
56 Summary(pl): Statyczna biblioteka rozszerzenia jêzyka tcl
57 Group:       Development/Languages/Tcl
58 Requires:    %{name}-devel = %{version}
59
60 %description static
61 Tcl extension language static library.
62
63 %description -l pl static
64 Statyczna biblioteka rozszerzenia jêzyka tcl.
65
66 %prep
67 %setup -q
68 %patch -p1
69
70 %build
71 # make the libraries reentrant
72 #RPM_OPT_FLAGS="$RPM_OPT_FLAGS -D_REENTRANT"
73
74 TCL_BIN_DIR=/usr/bin \
75 TCL_LIBRARY=/usr/lib \
76 CFLAGS="$RPM_OPT_FLAGS" \
77 ./configure     --enable-gcc \
78                 --enable-shared \
79                 --prefix=/usr \
80                 --with-tclconfig=/usr/lib
81 make
82 cd ..
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 #install -d $RPM_BUILD_ROOT/usr
87
88 LD_LIBRARY_PATH=$RPM_BUILD_ROOT/usr/lib \
89 make prefix=$RPM_BUILD_ROOT/usr install
90
91 for n in $RPM_BUILD_ROOT/usr/bin/* ; do
92         if head -1 $n | grep '#!'; then
93                 cp -a $n $n.in
94                 sed "s|$RPM_BUILD_ROOT||" < $n.in > $n
95                 rm -f $n.in
96         fi
97 done
98
99 strip $RPM_BUILD_ROOT/usr/{bin/*,lib/libe*.so} || :
100
101 %post   -p /sbin/ldconfig
102 %postun -p /sbin/ldconfig
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %files
108 %attr(755, root, root) /usr/bin/*
109 %attr(755, root, root) %dir /usr/lib/expect*
110 %attr(755, root, root) /usr/lib/expect*/pkgIndex.tcl
111 %attr(755, root, root) /usr/lib/libe*.so
112 %attr(644, root,  man) /usr/man/man1/*
113
114 %files devel
115 %attr(644, root, root) /usr/include/*
116 %attr(644, root,  man) /usr/man/man3/*
117
118 %files static
119 %attr(644, root, root) /usr/lib/lib*.a
120
121 %changelog
122 * Sat Sep 26 1998 Arkadiusz Mi¶kiewicz <misiek@misiek.eu.org>
123   [5.26-2]
124 - added pl translation.
125
126 * Thu Sep  8 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
127   [5.26-1]
128 - expect is now in separated source package from orher tcl/tk stuff,
129 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
130 - added using %%{name} and %%{version} in Source,
131 - fixed using $RPM_OPT_FLAGS during compile (curren expect configure script
132   don't accept passing CFLAGS in enviroment variable),
133 - added stripping shared libraries and othet binary,
134 - added devel and static subpackage,
135 - added package icon,
136 - added %attr and %defattr macros in %files (allow build package from
137   non-root account).
138
139 * Thu May 07 1998 Prospector System <bugs@redhat.com>
140 - translations modified for de, fr, tr
141
142 * Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
143 - fixed expect binaries exec permissions
144
145 * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
146 - updated to Tix 4.1.0.006
147 - updated version numbers of tcl/tk to relflect includsion of p2
148
149 * Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
150 - updated tcl/tk to patch level 2
151 - updated tclX to 8.0.2
152
153 * Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
154 - fixed filelist for tix... replacing path to the expect binary in scripts
155   was leaving junk files around.
156
157 * Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
158 - added patch to remove libieee test in configure.in for tcl and tk.
159   Shoudln't be needed anymore for glibc systems, but this isn't the "proper" 
160   solution for all systems
161 - fixed src urls
162
163 * Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
164 - removed version numbers from descriptions
165
166 * Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
167 - updated to tcl/tk 8.0 and related versions of packages
168
169 * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
170 - built against glibc
171 - fixed dangling tclx/tkx symlinks
This page took 0.836557 seconds and 4 git commands to generate.