]> git.pld-linux.org Git - packages/expect.git/blob - expect.spec
- tcl rebuild
[packages/expect.git] / expect.spec
1 #
2 # BIG FAT WARNING:
3 #       - expect requires mounted /dev/pts to avoid `spawn failed' errors.
4 #
5 %bcond_without  tests
6 Summary:        Tcl expect extension
7 Summary(de.UTF-8):      Tcl-Erweiterung
8 Summary(fr.UTF-8):      Extension Tcl
9 Summary(pl.UTF-8):      Rozszerzenie Tcl expect
10 Summary(ru.UTF-8):      Расширение Tcl для управления программами из скриптов
11 Summary(tr.UTF-8):      Programlar arası etkileşimi mümkün kılan Tcl genişletmesi
12 Summary(uk.UTF-8):      Розширення Tcl для керування програмами зі скриптів
13 Name:           expect
14 Version:        5.45
15 Release:        2
16 License:        BSD
17 Group:          Development/Languages/Tcl
18 Source0:        http://downloads.sourceforge.net/expect/%{name}%{version}.tar.gz
19 # Source0-md5:  44e1a4f4c877e9ddc5a542dfa7ecc92b
20 Patch0:         %{name}-pty.patch
21 Patch1:         %{name}-bug7869.patch
22 Patch2:         %{name}-soname.patch
23 URL:            http://expect.nist.gov/
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  tcl-devel >= 8.5.0
27 BuildRequires:  tk-devel >= 8.5.0
28 BuildRequires:  xorg-lib-libX11-devel
29 BuildRequires:  xorg-lib-libXext-devel
30 BuildRequires:  xorg-lib-libXScrnSaver-devel
31 Requires:       tcl >= 8.5.0
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _ulibdir        /usr/lib
35
36 %description
37 Expect is a tool for automating interactive applications such as
38 telnet, ftp, passwd, fsck, rlogin, tip, etc. It makes it easy for a
39 script to control another program and interact with it.
40
41 %description -l pl.UTF-8
42 Expect to narzędzie do automatyzacji interakcji z aplikacjami takimi
43 jak telnet, ftp, passwd, fsck, rlogin, tip itp. Expect pozwala w łatwy
44 sposób przy pomocy skryptu kontrolować inny program.
45
46 %description -l de.UTF-8
47 Expect ist ein Tool zur Automatisierung interaktiver Applikationen wie
48 telnet, ftp, passwd, fsck, rlogin, tip usw. Mit seiner Hilfe kann ein
49 Skript ein anderes Programm sehr leicht steuern oder damit
50 interagieren.
51
52 %description -l fr.UTF-8
53 expect est un un outil pour automatiser les applications interactives
54 comme telnet, ftp, passwd, fsck, rlogin, tip, etc. Il est alors facile
55 pour un script de contrôler un autre programme et d'interagir avec
56 lui.
57
58 %description -l tr.UTF-8
59 Expect telnet, ftp, passwd, fsck, rlogin, tip gibi etkileşimli
60 uygulamaları otomatize etmeye yarayan bir araçtır. Bir uygulamanın bir
61 diğer uygulamayı denetlemesini kolaylaştırır.
62
63 %description -l ru.UTF-8
64 Expect - это инструмент для автоматизации интерактивных программ,
65 таких как telnet, ftp, passwd, fsck, rlogin, tip, и т.п. Позволяет
66 управлять программами и взаимодействовать с ними из скриптов.
67
68 %description -l uk.UTF-8
69 Expect - це інструмент для автоматизації інтерактивних програм, таких
70 як telnet, ftp, passwd, fsck, rlogin, tip, і т.і. Дозволяє керувати
71 програмами та взаємодіяти з ними зі скриптів.
72
73 %package X11
74 Summary:        Tk extension
75 Summary(pl.UTF-8):      Rozszerzenie Tk
76 Group:          Development/Languages/Tcl
77 Requires:       %{name} = %{version}-%{release}
78
79 %description X11
80 This package contains expectk, which is an Tk extension, just as
81 expect Tcl extension.
82
83 %description X11 -l pl.UTF-8
84 Ten pakiet zawiera expectk, który jest rozszerzeniem dla Tk takim jak
85 expect jest dla Tcl.
86
87 %package devel
88 Summary:        Tcl expect extension header files and development documentation
89 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do rozszerzenia expect języka Tcl
90 Group:          Development/Languages/Tcl
91 Requires:       %{name} = %{version}-%{release}
92 Requires:       tcl-devel >= 8.5.0
93 Obsoletes:      expect-static
94
95 %description devel
96 Tcl expect extension language header files and development
97 documentation.
98
99 %description devel -l pl.UTF-8
100 Pliki nagłówkowe i dokumentacja do rozszerzenia expect języka Tcl.
101
102 %prep
103 %setup -q -n %{name}%{version}
104 %patch0 -p1
105 %patch1 -p1
106 %patch2 -p1
107
108 chmod +w {.,testsuite}/configure
109
110 %build
111 install /usr/share/automake/config.* .
112 # only local macros, don't call aclocal
113 %{__autoconf}
114 cd testsuite
115 %{__autoconf} -I ..
116 cd ..
117 CFLAGS="%{rpmcflags} -I%{_includedir}/tcl-private/unix"
118 %configure \
119 %if "%{_lib}" == "lib64"
120         --enable-64bit \
121 %endif
122         --enable-gcc \
123         --enable-shared \
124         --with-tclconfig=%{_ulibdir} \
125         --with-tkconfig=%{_ulibdir} \
126         --with-tclinclude=%{_includedir} \
127         --with-tkinclude=%{_includedir}
128
129 %{__make}
130
131 %{?with_tests:%{__make} test TCLSH_PROG=tclsh}
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135
136 LD_LIBRARY_PATH=$RPM_BUILD_ROOT%{_libdir} \
137 %{__make} install \
138         DESTDIR=$RPM_BUILD_ROOT \
139         TCLSH_PROG=tclsh
140
141 mv -f $RPM_BUILD_ROOT%{_bindir}/{rftp,rftp-expect}
142
143 mv -f $RPM_BUILD_ROOT%{_libdir}/expect%{version}/libexpect%{version}.so $RPM_BUILD_ROOT%{_libdir}
144 ln -sf ../libexpect%{version}.so $RPM_BUILD_ROOT%{_libdir}/expect%{version}/libexpect%{version}.so
145 ln -sf libexpect%{version}.so $RPM_BUILD_ROOT%{_libdir}/libexpect.so
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post   -p /sbin/ldconfig
151 %postun -p /sbin/ldconfig
152
153 %files
154 %defattr(644,root,root,755)
155 %doc ChangeLog FAQ HISTORY NEWS README
156 %attr(755,root,root) %{_bindir}/autoexpect
157 %attr(755,root,root) %{_bindir}/autopasswd
158 %attr(755,root,root) %{_bindir}/cryptdir
159 %attr(755,root,root) %{_bindir}/decryptdir
160 %attr(755,root,root) %{_bindir}/dislocate
161 %attr(755,root,root) %{_bindir}/expect
162 %attr(755,root,root) %{_bindir}/ftp-rfc
163 %attr(755,root,root) %{_bindir}/kibitz
164 %attr(755,root,root) %{_bindir}/lpunlock
165 %attr(755,root,root) %{_bindir}/mkpasswd
166 %attr(755,root,root) %{_bindir}/passmass
167 %attr(755,root,root) %{_bindir}/rftp-expect
168 %attr(755,root,root) %{_bindir}/rlogin-cwd
169 %attr(755,root,root) %{_bindir}/timed-read
170 %attr(755,root,root) %{_bindir}/timed-run
171 %attr(755,root,root) %{_bindir}/unbuffer
172 %attr(755,root,root) %{_bindir}/weather
173 %attr(755,root,root) %{_libdir}/libexpect%{version}.so
174 %dir %{_libdir}/expect%{version}
175 %attr(755,root,root) %{_libdir}/expect%{version}/pkgIndex.tcl
176 %attr(755,root,root) %{_libdir}/expect%{version}/libexpect%{version}.so
177 %{_mandir}/man1/autoexpect.1*
178 %{_mandir}/man1/cryptdir.1*
179 %{_mandir}/man1/decryptdir.1*
180 %{_mandir}/man1/dislocate.1*
181 %{_mandir}/man1/expect.1*
182 %{_mandir}/man1/kibitz.1*
183 %{_mandir}/man1/mkpasswd.1*
184 %{_mandir}/man1/passmass.1*
185 %{_mandir}/man1/unbuffer.1*
186
187 %files X11
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{_bindir}/multixterm
190 %attr(755,root,root) %{_bindir}/tknewsbiff
191 %attr(755,root,root) %{_bindir}/tkpasswd
192 %attr(755,root,root) %{_bindir}/xkibitz
193 %attr(755,root,root) %{_bindir}/xpstat
194 %{_mandir}/man1/multixterm.1*
195 %{_mandir}/man1/tknewsbiff.1*
196 %{_mandir}/man1/xkibitz.1*
197
198 %files devel
199 %defattr(644,root,root,755)
200 %attr(755,root,root) %{_libdir}/libexpect.so
201 %{_includedir}/expect*.h
202 %{_includedir}/tcldbg.h
203 %{_mandir}/man3/libexpect.3*
This page took 0.092111 seconds and 3 git commands to generate.