]> git.pld-linux.org Git - packages/expect.git/blob - expect.spec
plomby
[packages/expect.git] / expect.spec
1 Summary:        tcl extension 
2 Summary(de):    tcl-Erweiterung 
3 Summary(fr):    Extension tcl 
4 Summary(pl):    Rozszerzenie TCL 
5 Summary(tr):    Programlar arasý etkileþimi mümkün kýlan tcl geniþletmesi
6 Name:           expect
7 Version:        5.28
8 Release:        3
9 Copyright:      BSD
10 Group:          Development/Languages/Tcl
11 Group(pl):      Programowanie/Jêzyki/Tcl
12 Source:         ftp://ftp.cme.nist.gov/pub/%{name}/%{name}.tar.gz
13 Icon:           tcl.gif
14 Patch0:         %{name}.patch
15 Patch1:         %{name}-mkpasswd.patch
16 Patch2:         %{name}-pty.patch
17 Patch3:         %{name}-strf.patch
18 Buildroot:      /tmp/%{name}-%{version}-root
19
20 %description
21 Expect is a tool for automating interactive applications such as
22 telnet, ftp, passwd, fsck, rlogin, tip, etc. It makes it easy for a
23 script to control another program and interact with it.
24
25 %description -l pl
26 Expect to narzêdzie do automatyzacji interakcji z aplikacjami 
27 takimi jak telnet, ftp, passwd, fsck, rlogin, tip itp. Expect
28 pozwala w ³atwy sposób przy pomocy skryptu kontrolowaæ inny program.
29
30 %description -l de
31 Expect ist ein Tool zur Automatisierung interaktiver Applikationen 
32 wie telnet, ftp, passwd, fsck, rlogin, tip usw. Mit seiner Hilfe 
33 kann ein Skript ein anderes Programm sehr leicht steuern oder 
34 damit interagieren. 
35
36 %description -l fr
37 expect est un un outil pour automatiser les applications interactives
38 comme telnet, ftp, passwd, fsck, rlogin, tip, etc. Il est alors facile
39 pour un script de contrôler un autre programme et d'interagir avec lui.
40
41 %description -l tr
42 Expect telnet, ftp, passwd, fsck, rlogin, tip gibi etkileþimli uygulamalarý
43 otomatize etmeye yarayan bir araçtýr. Bir uygulamanýn bir diðer uygulamayý
44 denetlemesini kolaylaþtýrýr.
45
46 %package        devel
47 Summary:        tcl extension header files and development documentation
48 Summary(pl):    Pliki nag³ówkowe i dokumentacja do rozszerzenia jêzyka TCL
49 Group:          Development/Languages/Tcl
50 Group(pl):      Programowanie/Jêzyki/Tcl
51 Requires:       %{name} = %{version}
52
53 %description devel
54 Tcl extension language header files and develppment documentation.
55
56 %description -l pl devel
57 Pliki nag³ówkowe i dokumentacja do rozszerzenie jêzyka TCL.
58
59 %package        static
60 Summary:        tcl extension static library
61 Summary(pl):    Biblioteka statyczna rozszerzenia jêzyka TCL
62 Group:          Development/Languages/Tcl
63 Group(pl):      Programowanie/Jêzyki/Tcl
64 Requires:       %{name}-devel = %{version}
65
66 %description static
67 Tcl extension language static library.
68
69 %description -l pl static
70 Biblioteka statyczna rozszerzenia jêzyka TCL.
71
72 %prep
73 %setup  -q
74 %patch0 -p1
75 %patch1 -p2
76 %patch2 -p1
77 %patch3 -p1
78
79 %build
80 autoconf
81 CFLAGS="$RPM_OPT_FLAGS -w" \
82 ./configure     --enable-gcc \
83                 --enable-shared \
84                 --prefix=/usr \
85                 --with-tclconfig=../tcl8.0.5/unix \
86                 --with-tkconfig=../tk8.0.5/unix \
87                 --with-tclinclude=../tcl8.0.5/generic \
88                 --with-tkinclude=../tk8.0.5/generic \
89                 --mandir=%{_mandir} %{_target_platform}
90 make 
91 cd ..
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95
96 LD_LIBRARY_PATH=$RPM_BUILD_ROOT%{_libdir} \
97 make \
98     prefix=$RPM_BUILD_ROOT%{_prefix} \
99     mandir=$RPM_BUILD_ROOT%{_mandir} \
100     install
101
102 for n in $RPM_BUILD_ROOT/usr/bin/* ; do
103         if head -1 $n | grep '#!'; then
104                 cp -a $n $n.in
105                 sed "s|$RPM_BUILD_ROOT||" < $n.in > $n
106                 rm -f $n.in
107         fi
108 done
109
110 strip $RPM_BUILD_ROOT%{_bindir}/{expect,expectk}
111 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/*.so
112
113 ( cd $RPM_BUILD_ROOT%{_bindir}; mv -f rftp rftp-expect )
114
115 gzip -9fn $RPM_BUILD_ROOT%{_mandir}/man[13]/* FAQ README ChangeLog
116
117 %post   -p /sbin/ldconfig
118 %postun -p /sbin/ldconfig
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %files
124 %defattr(644,root,root,755)
125 %doc {FAQ,README,ChangeLog}.gz
126
127 %attr(755,root,root) %{_bindir}/*
128
129 %dir %{_libdir}/expect*
130 %attr(755,root,root) %{_libdir}/expect*/pkgIndex.tcl
131 %attr(755,root,root) %{_libdir}/libe*.so
132
133 %{_mandir}/man1/*
134
135 %files devel
136 %defattr(644,root,root,755)
137
138 %{_includedir}/*
139 %{_mandir}/man3/*
140
141 %files static
142 %defattr(644,root,root,755)
143
144 %{_libdir}/*.a
145
146 %changelog
147 * Sun Jan 31 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
148   [5.28-1d]
149 - updated to 5.28,
150 - added Group(pl),
151 - compressed man pages && documentaction,
152
153   by Maciej Ró¿ycki <macro@ds2.amg.gad.pl>
154   
155 - added expect-mkpasswd.patch.  
156
157 * Thu Oct 08 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
158   [5.26-2d]
159 - build against PLD Tornado,
160 - fixed pl translation,
161 - added %doc
162 - minor changes of the spec file.
163
164 * Sat Sep 26 1998 Arkadiusz Mi¶kiewicz <misiek@misiek.eu.org>
165   [5.26-2]
166 - added pl translation.
167
168 * Thu Sep  8 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
169   [5.26-1]
170 - expect is now in separated source package from orher tcl/tk stuff,
171 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
172 - added using %%{name} and %%{version} in Source,
173 - fixed using $RPM_OPT_FLAGS during compile (curren expect configure script
174   don't accept passing CFLAGS in enviroment variable),
175 - added striping shared libraries and othet binary,
176 - added devel and static subpackage,
177 - added package icon,
178 - added %attr and %defattr macros in %files (allow build package from
179   non-root account).
180
181 * Thu May 07 1998 Prospector System <bugs@redhat.com>
182 - translations modified for de, fr, tr
183
184 * Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
185 - fixed expect binaries exec permissions
186
187 * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
188 - updated to Tix 4.1.0.006
189 - updated version numbers of tcl/tk to relflect includsion of p2
190
191 * Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
192 - updated tcl/tk to patch level 2
193 - updated tclX to 8.0.2
194
195 * Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
196 - fixed filelist for tix... replacing path to the expect binary in scripts
197   was leaving junk files around.
198
199 * Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
200 - added patch to remove libieee test in configure.in for tcl and tk.
201   Shoudln't be needed anymore for glibc systems, but this isn't the "proper" 
202   solution for all systems
203 - fixed src urls
204
205 * Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
206 - removed version numbers from descriptions
207
208 * Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
209 - updated to tcl/tk 8.0 and related versions of packages
210
211 * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
212 - built against glibc
213 - fixed dangling tclx/tkx symlinks
This page took 0.052933 seconds and 3 git commands to generate.