]> git.pld-linux.org Git - packages/expect.git/blob - expect.spec
42513467619e7610d35705586519d7701e11a961
[packages/expect.git] / expect.spec
1 Summary:        tcl extension
2 Summary(de):    tcl-Erweiterung
3 Summary(fr):    Extension tcl
4 Summary(pl):    Rozszerzenie TCL
5 Summary(tr):    Programlar arasý etkileþimi mümkün kýlan tcl geniþletmesi
6 Name:           expect
7 Version:        5.32.2
8 Release:        52
9 License:        BSD
10 Group:          Development/Languages/Tcl
11 Source0:        ftp://ftp.scriptics.com/pub/tcl/expect/%{name}.%{version}.tar.gz
12 Patch0:         %{name}-pty.patch
13 Patch1:         %{name}-alpha.patch
14 Patch2:         %{name}-bug7869.patch
15 Patch3:         %{name}-fixcat.patch
16 Patch4:         %{name}-jbj.patch
17 Icon:           tcl.gif
18 URL:            http://expect.nist.gov/
19 BuildRequires:  glibc-static
20 BuildRequires:  tcl-devel >= 8.3.2
21 BuildRequires:  tk-devel >= 8.3.2
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Expect is a tool for automating interactive applications such as
26 telnet, ftp, passwd, fsck, rlogin, tip, etc. It makes it easy for a
27 script to control another program and interact with it.
28
29 %description -l pl
30 Expect to narzêdzie do automatyzacji interakcji z aplikacjami takimi
31 jak telnet, ftp, passwd, fsck, rlogin, tip itp. Expect pozwala w ³atwy
32 sposób przy pomocy skryptu kontrolowaæ inny program.
33
34 %description -l de
35 Expect ist ein Tool zur Automatisierung interaktiver Applikationen wie
36 telnet, ftp, passwd, fsck, rlogin, tip usw. Mit seiner Hilfe kann ein
37 Skript ein anderes Programm sehr leicht steuern oder damit
38 interagieren.
39
40 %description -l fr
41 expect est un un outil pour automatiser les applications interactives
42 comme telnet, ftp, passwd, fsck, rlogin, tip, etc. Il est alors facile
43 pour un script de contrôler un autre programme et d'interagir avec
44 lui.
45
46 %description -l tr
47 Expect telnet, ftp, passwd, fsck, rlogin, tip gibi etkileþimli
48 uygulamalarý otomatize etmeye yarayan bir araçtýr. Bir uygulamanýn bir
49 diðer uygulamayý denetlemesini kolaylaþtýrýr.
50
51 %package X11
52 Summary:        tk extension
53 Summary(pl):    rozszerzenie tk
54 Group:          Development/Languages/Tcl
55 Requires:       %{name} = %{version}
56
57 %description X11
58 This package contains expectk, which is an Tk extension, just as
59 expect Tcl extension.
60
61 %description X11 -l pl
62 Ten pakiet zawiera expectk, który jest rozszerzeniem dla Tk takim jak
63 expect jest dla Tcl.
64
65 %package devel
66 Summary:        tcl extension header files and development documentation
67 Summary(pl):    Pliki nag³ówkowe i dokumentacja do rozszerzenia jêzyka TCL
68 Group:          Development/Languages/Tcl
69 Requires:       %{name} = %{version}
70 Requires:       tcl-devel
71
72 %description devel
73 Tcl extension language header files and develppment documentation.
74
75 %description devel -l pl
76 Pliki nag³ówkowe i dokumentacja do rozszerzenie jêzyka TCL.
77
78 %package        static
79 Summary:        tcl extension static library
80 Summary(pl):    Biblioteka statyczna rozszerzenia jêzyka TCL
81 Group:          Development/Languages/Tcl
82 Requires:       %{name}-devel = %{version}
83
84 %description static
85 Tcl extension language static library.
86
87 %description static -l pl
88 Biblioteka statyczna rozszerzenia jêzyka TCL.
89
90 %prep
91 %setup  -q -n %{name}5.32
92 %patch0 -p1
93 %patch1 -p1
94 %patch2 -p1
95 %patch3 -p1
96 %patch4 -p1
97
98 chmod +w configure
99
100 %build
101 %configure2_13 \
102         --enable-gcc \
103         --enable-shared \
104         --with-tclconfig=%{_libdir} \
105         --with-tkconfig=/%{_libdir} \
106         --with-tclinclude=%{_includedir} \
107         --with-tkinclude=%{_includedir}
108 %{__make}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112
113 LD_LIBRARY_PATH=$RPM_BUILD_ROOT%{_libdir} \
114 %{__make} install \
115         INSTALL_ROOT=$RPM_BUILD_ROOT
116
117 ( cd $RPM_BUILD_ROOT%{_bindir}; mv -f rftp rftp-expect )
118
119 gzip -9nf FAQ README ChangeLog
120
121 %post   -p /sbin/ldconfig
122 %postun -p /sbin/ldconfig
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %files
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_bindir}/autoexpect
130 %attr(755,root,root) %{_bindir}/autopasswd
131 %attr(755,root,root) %{_bindir}/cryptdir
132 %attr(755,root,root) %{_bindir}/decryptdir
133 %attr(755,root,root) %{_bindir}/dislocate
134 %attr(755,root,root) %{_bindir}/expect
135 %attr(755,root,root) %{_bindir}/ftp-rfc
136 %attr(755,root,root) %{_bindir}/kibitz
137 %attr(755,root,root) %{_bindir}/lpunlock
138 %attr(755,root,root) %{_bindir}/mkpasswd
139 %attr(755,root,root) %{_bindir}/passmass
140 %attr(755,root,root) %{_bindir}/rftp-expect
141 %attr(755,root,root) %{_bindir}/rlogin-cwd
142 %attr(755,root,root) %{_bindir}/timed-read
143 %attr(755,root,root) %{_bindir}/timed-run
144 %attr(755,root,root) %{_bindir}/unbuffer
145 %attr(755,root,root) %{_bindir}/weather
146 %dir %{_libdir}/expect*
147 %attr(755,root,root) %{_libdir}/expect*/pkgIndex.tcl
148 %attr(755,root,root) %{_libdir}/libe*.so
149 %{_mandir}/man1/autoexpect.*
150 %{_mandir}/man1/cryptdir.*
151 %{_mandir}/man1/decryptdir.*
152 %{_mandir}/man1/dislocate.*
153 %{_mandir}/man1/expect.*
154 %{_mandir}/man1/kibitz.*
155 %{_mandir}/man1/mkpasswd.*
156 %{_mandir}/man1/passmass.*
157 %{_mandir}/man1/unbuffer.*
158
159 %files X11
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_bindir}/expectk
162 %attr(755,root,root) %{_bindir}/tknewsbiff
163 %attr(755,root,root) %{_bindir}/tkpasswd
164 %attr(755,root,root) %{_bindir}/xkibitz
165 %attr(755,root,root) %{_bindir}/xpstat
166 %{_mandir}/man1/expectk.*
167 %{_mandir}/man1/tknewsbiff.*
168 %{_mandir}/man1/xkibitz.*
169
170 %files devel
171 %defattr(644,root,root,755)
172 %doc *.gz
173 %{_includedir}/*
174 %{_mandir}/man3/*
175
176 %files static
177 %defattr(644,root,root,755)
178 %{_libdir}/*.a
This page took 0.98483 seconds and 3 git commands to generate.