]> git.pld-linux.org Git - packages/expect.git/blob - expect.spec
17183ba3daea7f7a94798e4ce057656aa3ddd5e4
[packages/expect.git] / expect.spec
1 Summary:        Tcl extension
2 Summary(de.UTF-8):      Tcl-Erweiterung
3 Summary(fr.UTF-8):      Extension Tcl
4 Summary(pl.UTF-8):      Rozszerzenie Tcl
5 Summary(ru.UTF-8):      Расширение Tcl для управления программами из скриптов
6 Summary(tr.UTF-8):      Programlar arası etkileşimi mümkün kılan Tcl genişletmesi
7 Summary(uk.UTF-8):      Розширення Tcl для керування програмами зі скриптів
8 Name:           expect
9 %define major   5.43
10 Version:        %{major}.0
11 Release:        1
12 License:        BSD
13 Group:          Development/Languages/Tcl
14 Source0:        http://expect.nist.gov/src/%{name}-%{version}.tar.gz
15 # Source0-md5:  230400129630335b3060a42f66fec11d
16 Patch0:         %{name}-pty.patch
17 Patch1:         %{name}-alpha.patch
18 Patch2:         %{name}-bug7869.patch
19 Patch3:         %{name}-fixcat.patch
20 Patch4:         %{name}-soname.patch
21 Patch5:         %{name}-lib64.patch
22 Patch6:         %{name}-build.patch
23 URL:            http://expect.nist.gov/
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  tcl-devel >= 8.4.6
27 BuildRequires:  tk-devel >= 8.4.6
28 Requires:       tcl >= 8.4.6
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _ulibdir        /usr/lib
32
33 %description
34 Expect is a tool for automating interactive applications such as
35 telnet, ftp, passwd, fsck, rlogin, tip, etc. It makes it easy for a
36 script to control another program and interact with it.
37
38 %description -l pl.UTF-8
39 Expect to narzędzie do automatyzacji interakcji z aplikacjami takimi
40 jak telnet, ftp, passwd, fsck, rlogin, tip itp. Expect pozwala w łatwy
41 sposób przy pomocy skryptu kontrolować inny program.
42
43 %description -l de.UTF-8
44 Expect ist ein Tool zur Automatisierung interaktiver Applikationen wie
45 telnet, ftp, passwd, fsck, rlogin, tip usw. Mit seiner Hilfe kann ein
46 Skript ein anderes Programm sehr leicht steuern oder damit
47 interagieren.
48
49 %description -l fr.UTF-8
50 expect est un un outil pour automatiser les applications interactives
51 comme telnet, ftp, passwd, fsck, rlogin, tip, etc. Il est alors facile
52 pour un script de contrôler un autre programme et d'interagir avec
53 lui.
54
55 %description -l tr.UTF-8
56 Expect telnet, ftp, passwd, fsck, rlogin, tip gibi etkileşimli
57 uygulamaları otomatize etmeye yarayan bir araçtır. Bir uygulamanın bir
58 diğer uygulamayı denetlemesini kolaylaştırır.
59
60 %description -l ru.UTF-8
61 Expect - это инструмент для автоматизации интерактивных программ,
62 таких как telnet, ftp, passwd, fsck, rlogin, tip, и т.п. Позволяет
63 управлять программами и взаимодействовать с ними из скриптов.
64
65 %description -l uk.UTF-8
66 Expect - це інструмент для автоматизації інтерактивних програм, таких
67 як telnet, ftp, passwd, fsck, rlogin, tip, і т.і. Дозволяє керувати
68 програмами та взаємодіяти з ними зі скриптів.
69
70 %package X11
71 Summary:        Tk extension
72 Summary(pl.UTF-8):      Rozszerzenie Tk
73 Group:          Development/Languages/Tcl
74 Requires:       %{name} = %{version}-%{release}
75
76 %description X11
77 This package contains expectk, which is an Tk extension, just as
78 expect Tcl extension.
79
80 %description X11 -l pl.UTF-8
81 Ten pakiet zawiera expectk, który jest rozszerzeniem dla Tk takim jak
82 expect jest dla Tcl.
83
84 %package devel
85 Summary:        Tcl extension header files and development documentation
86 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do rozszerzenia języka Tcl
87 Group:          Development/Languages/Tcl
88 Requires:       %{name} = %{version}-%{release}
89 Requires:       tcl-devel >= 8.4.6
90
91 %description devel
92 Tcl extension language header files and develppment documentation.
93
94 %description devel -l pl.UTF-8
95 Pliki nagłówkowe i dokumentacja do rozszerzenie języka Tcl.
96
97 %package static
98 Summary:        Tcl extension static library
99 Summary(pl.UTF-8):      Biblioteka statyczna rozszerzenia języka Tcl
100 Group:          Development/Languages/Tcl
101 Requires:       %{name}-devel = %{version}-%{release}
102
103 %description static
104 Tcl extension language static library.
105
106 %description static -l pl.UTF-8
107 Biblioteka statyczna rozszerzenia języka Tcl.
108
109 %prep
110 %setup -q -n %{name}-%{major}
111 %patch0 -p1
112 %patch1 -p1
113 %patch2 -p1
114 %patch3 -p1
115 %patch4 -p1
116 %if "%{_lib}" == "lib64"
117 %patch5 -p1
118 %endif
119 %patch6 -p1
120
121 chmod +w {.,testsuite}/configure
122
123 %build
124 install /usr/share/automake/config.* .
125 # only local macros, don't call aclocal
126 %{__autoconf}
127 cd testsuite
128 cp ../aclocal.m4 .
129 %{__autoconf}
130 cd -
131 CFLAGS="%{rpmcflags} -I%{_includedir}/tcl-private/unix"
132 %configure \
133         --enable-gcc \
134         --enable-shared \
135         --with-tclconfig=%{_ulibdir} \
136         --with-tkconfig=%{_ulibdir} \
137         --with-tclinclude=%{_includedir}/tcl-private \
138         --with-tkinclude=%{_includedir}
139
140 cat expect_cf.h | sed "s|.*SETPGRP_VOID.*|\#define SETPGRP_VOID 1|" > expect_cf.h.new
141 mv -f expect_cf.h{.new,}
142
143 %{__make}
144
145 %install
146 rm -rf $RPM_BUILD_ROOT
147
148 LD_LIBRARY_PATH=$RPM_BUILD_ROOT%{_libdir} \
149 %{__make} install \
150         INSTALL_ROOT=$RPM_BUILD_ROOT
151
152 mv -f $RPM_BUILD_ROOT%{_bindir}/{rftp,rftp-expect}
153
154 ln -sf $(cd $RPM_BUILD_ROOT%{_libdir} ; echo libexpect%{major}.so.*.*) \
155         $RPM_BUILD_ROOT%{_libdir}/libexpect%{major}.so
156 ln -sf $(cd $RPM_BUILD_ROOT%{_libdir} ; echo libexpect%{major}.so.*.*) \
157         $RPM_BUILD_ROOT%{_libdir}/libexpect.so
158
159 %clean
160 rm -rf $RPM_BUILD_ROOT
161
162 %post   -p /sbin/ldconfig
163 %postun -p /sbin/ldconfig
164
165 %files
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_bindir}/autoexpect
168 %attr(755,root,root) %{_bindir}/autopasswd
169 %attr(755,root,root) %{_bindir}/cryptdir
170 %attr(755,root,root) %{_bindir}/decryptdir
171 %attr(755,root,root) %{_bindir}/dislocate
172 %attr(755,root,root) %{_bindir}/expect
173 %attr(755,root,root) %{_bindir}/ftp-rfc
174 %attr(755,root,root) %{_bindir}/kibitz
175 %attr(755,root,root) %{_bindir}/lpunlock
176 %attr(755,root,root) %{_bindir}/mkpasswd
177 %attr(755,root,root) %{_bindir}/passmass
178 %attr(755,root,root) %{_bindir}/rftp-expect
179 %attr(755,root,root) %{_bindir}/rlogin-cwd
180 %attr(755,root,root) %{_bindir}/timed-read
181 %attr(755,root,root) %{_bindir}/timed-run
182 %attr(755,root,root) %{_bindir}/unbuffer
183 %attr(755,root,root) %{_bindir}/weather
184 %dir %{_libdir}/expect*
185 %attr(755,root,root) %{_libdir}/expect*/pkgIndex.tcl
186 %attr(755,root,root) %{_libdir}/libexpect*.so.*.*
187 %{_mandir}/man1/autoexpect.*
188 %{_mandir}/man1/cryptdir.*
189 %{_mandir}/man1/decryptdir.*
190 %{_mandir}/man1/dislocate.*
191 %{_mandir}/man1/expect.*
192 %{_mandir}/man1/kibitz.*
193 %{_mandir}/man1/mkpasswd.*
194 %{_mandir}/man1/passmass.*
195 %{_mandir}/man1/unbuffer.*
196
197 %files X11
198 %defattr(644,root,root,755)
199 %attr(755,root,root) %{_bindir}/expectk
200 %attr(755,root,root) %{_bindir}/multixterm
201 %attr(755,root,root) %{_bindir}/tknewsbiff
202 %attr(755,root,root) %{_bindir}/tkpasswd
203 %attr(755,root,root) %{_bindir}/xkibitz
204 %attr(755,root,root) %{_bindir}/xpstat
205 %{_mandir}/man1/expectk.*
206 %{_mandir}/man1/multixterm.*
207 %{_mandir}/man1/tknewsbiff.*
208 %{_mandir}/man1/xkibitz.*
209
210 %files devel
211 %defattr(644,root,root,755)
212 %doc ChangeLog FAQ HISTORY NEWS README
213 %attr(755,root,root) %{_libdir}/libexpect*.so
214 %{_includedir}/*.h
215 %{_mandir}/man3/*
216
217 %files static
218 %defattr(644,root,root,755)
219 %{_libdir}/libexpect*.a
This page took 0.052918 seconds and 2 git commands to generate.