]> git.pld-linux.org Git - packages/exo.git/blob - exo.spec
- modular xorg deps
[packages/exo.git] / exo.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Extension library to Xfce developed by os-cillation
6 Summary(pl):    Biblioteka rozszerzeñ do Xfce opracowana przez os-cillation
7 Name:           libexo
8 Version:        0.3.0
9 Release:        1
10 License:        GPL v2
11 Group:          Libraries
12 Source0:        http://download.berlios.de/xfce-goodies/exo-%{version}.tar.bz2
13 # Source0-md5:  ffcd73ec6b34f19c81afdc3f1a97377b
14 URL:            http://www.os-cillation.com/
15 BuildRequires:  gettext-devel
16 BuildRequires:  gtk-doc >= 1.0
17 BuildRequires:  gtk+2-devel >= 2:2.4.0
18 BuildRequires:  libxfcegui4-devel >= 4.2.0
19 BuildRequires:  pkgconfig
20 BuildRequires:  python
21 BuildRequires:  python-pygtk-devel >= 2:2.4.0
22 BuildRequires:  rpmbuild(macros) >= 1.219
23 BuildRequires:  xorg-lib-libXt-devel
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Extension library to Xfce developed by os-cillation.
28
29 %description -l pl
30 Biblioteka rozszerzeñ do Xfce opracowana przez os-cillation.
31
32 %package devel
33 Summary:        Header files for libexo library
34 Summary(pl):    Pliki nag³ówkowe biblioteki libexo
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37 Requires:       libxfcegui4-devel >= 4.2.0
38
39 %description devel
40 Header files for libexo library.
41
42 %description devel -l pl
43 Pliki nag³ówkowe biblioteki libexo.
44
45 %package static
46 Summary:        Static libexo library
47 Summary(pl):    Statyczna biblioteka libexo
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static libexo library.
53
54 %description static -l pl
55 Statyczna biblioteka libexo.
56
57 %package -n python-exo
58 Summary:        Python binding for libexo library
59 Summary(pl):    Wi±zania Pythona do biblioteki libexo
60 Group:          Libraries/Python
61 Requires:       %{name} = %{version}-%{release}
62 %pyrequires_eq  python-libs
63
64 %description -n python-exo
65 Python binding for libexo library.
66
67 %description -n python-exo -l pl
68 Wi±zania Pythona do biblioteki libexo.
69
70 %package -n python-exo-devel
71 Summary:        Development files for libexo Python bindings
72 Summary(pl):    Pliki programistyczne wi±zañ Pythona do libexo
73 Group:          Libraries/Python
74 Requires:       python-exo = %{version}-%{release}
75
76 %description -n python-exo-devel
77 Development files for libexo Python bindings.
78
79 %description -n python-exo-devel -l pl
80 Pliki programistyczne wi±zañ Pythona do libexo.
81
82 %prep
83 %setup -q -n exo-%{version}
84
85 %build
86 %configure \
87         --with-html-dir=%{_gtkdocdir} \
88         %{!?with_static_libs:--disable-static}
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %{__make} install \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 rm -f $RPM_BUILD_ROOT%{py_sitedir}/exo-0.3/*.{la,a}
98
99 %py_postclean
100
101 %find_lang %{name}-0.3
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -p /sbin/ldconfig
107 %postun -p /sbin/ldconfig
108
109 %files -f %{name}-0.3.lang
110 %defattr(644,root,root,755)
111 %doc AUTHORS ChangeLog HACKING NEWS README TODO
112 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
113
114 %files devel
115 %defattr(644,root,root,755)
116 %attr(755,root,root) %{_libdir}/lib*.so
117 %{_libdir}/lib*.la
118 %{_includedir}/exo-0.3
119 %{_pkgconfigdir}/*.pc
120 %{_gtkdocdir}/exo
121
122 %if %{with static_libs}
123 %files static
124 %defattr(644,root,root,755)
125 %{_libdir}/lib*.a
126 %endif
127
128 %files -n python-exo
129 %defattr(644,root,root,755)
130 %dir %{py_sitedir}/exo-0.3
131 %attr(755,root,root) %{py_sitedir}/exo-0.3/_exo.so
132 %dir %{py_sitedir}/exo-0.3/exo
133 %{py_sitedir}/exo-0.3/exo/*.py[co]
134 %{py_sitescriptdir}/*.py[co]
135
136 %files -n python-exo-devel
137 %defattr(644,root,root,755)
138 %{_datadir}/pygtk/2.0/defs/exo-0.3
This page took 0.042208 seconds and 4 git commands to generate.