]> git.pld-linux.org Git - packages/exo.git/blob - exo.spec
- fix python module install
[packages/exo.git] / exo.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_with     static_libs     # don't build static library
5 #
6 %define         xfce_version    4.10.0
7 #
8 Summary:        Extension library to Xfce developed by os-cillation
9 Summary(pl.UTF-8):      Biblioteka rozszerzeń do Xfce opracowana przez os-cillation
10 Name:           exo
11 Version:        0.8.0
12 Release:        1
13 License:        GPL v2
14 Group:          X11/Libraries
15 Source0:        http://archive.xfce.org/xfce/4.10/src/%{name}-%{version}.tar.bz2
16 # Source0-md5:  189bd19210e1d7d8601be1cdf27bf259
17 URL:            http://www.os-cillation.com/
18 BuildRequires:  autoconf >= 2.50
19 BuildRequires:  automake
20 BuildRequires:  docbook-dtd412-xml
21 BuildRequires:  gettext-devel
22 BuildRequires:  glib2-devel >= 1:2.27.0
23 BuildRequires:  gtk+2-devel >= 2:2.14.0
24 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.9}
25 BuildRequires:  gtk-doc-automake
26 BuildRequires:  intltool >= 0.35.0
27 BuildRequires:  libtool
28 BuildRequires:  libxfce4ui-devel >= %{xfce_version}
29 BuildRequires:  libxfce4util-devel >= %{xfce_version}
30 BuildRequires:  perl-URI
31 BuildRequires:  pkgconfig
32 BuildRequires:  python-pygtk-devel >= 2:2.10.3
33 BuildRequires:  rpm-pythonprov
34 BuildRequires:  rpmbuild(macros) >= 1.601
35 BuildRequires:  xfce4-dev-tools >= 4.10.0
36 Requires:       glib2 >= 1:2.27.0
37 Requires:       xfce4-dirs >= 4.6
38 Provides:       libexo
39 Obsoletes:      libexo
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 Extension library to Xfce developed by os-cillation.
44
45 %description -l pl.UTF-8
46 Biblioteka rozszerzeń do Xfce opracowana przez os-cillation.
47
48 %package -n xfce-preferred-applications
49 Summary:        The Xfce Preferred Applications framework
50 Summary(pl.UTF-8):      Struktura Preferowanych Aplikacji Xfce
51 Group:          X11/Applications
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       gtk-update-icon-cache
54 Requires:       hicolor-icon-theme
55
56 %description -n xfce-preferred-applications
57 The Xfce Preferred Applications framework.
58
59 %description -n xfce-preferred-applications -l pl.UTF-8
60 Struktura Preferowanych Aplikacji Xfce.
61
62 %package apidocs
63 Summary:        libexo API documentation
64 Summary(pl.UTF-8):      Dokumentacja API libexo
65 Group:          Documentation
66 Requires:       gtk-doc-common
67 Provides:       libexo-apidocs
68 Obsoletes:      libexo-apidocs
69
70 %description apidocs
71 libexo API documentation.
72
73 %description apidocs -l pl.UTF-8
74 Dokumentacja API libexo.
75
76 %package devel
77 Summary:        Header files for libexo library
78 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libexo
79 Group:          X11/Development/Libraries
80 Requires:       %{name} = %{version}-%{release}
81 Requires:       gtk+2-devel >= 2:2.14.0
82 Requires:       libxfce4util-devel >= %{xfce_version}
83 Provides:       libexo-devel
84 Obsoletes:      libexo-devel
85
86 %description devel
87 Header files for libexo library.
88
89 %description devel -l pl.UTF-8
90 Pliki nagłówkowe biblioteki libexo.
91
92 %package static
93 Summary:        Static libexo library
94 Summary(pl.UTF-8):      Statyczna biblioteka libexo
95 Group:          X11/Development/Libraries
96 Requires:       %{name}-devel = %{version}-%{release}
97 Provides:       libexo-static
98 Obsoletes:      libexo-static
99
100 %description static
101 Static libexo library.
102
103 %description static -l pl.UTF-8
104 Statyczna biblioteka libexo.
105
106 %package -n python-exo
107 Summary:        Python binding for libexo library
108 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki libexo
109 Group:          Libraries/Python
110 Requires:       %{name} = %{version}-%{release}
111 %pyrequires_eq  python-libs
112
113 %description -n python-exo
114 Python binding for libexo library.
115
116 %description -n python-exo -l pl.UTF-8
117 Wiązania Pythona do biblioteki libexo.
118
119 %package -n python-exo-devel
120 Summary:        Development files for libexo Python bindings
121 Summary(pl.UTF-8):      Pliki programistyczne wiązań Pythona do libexo
122 Group:          Libraries/Python
123 Requires:       python-exo = %{version}-%{release}
124
125 %description -n python-exo-devel
126 Development files for libexo Python bindings.
127
128 %description -n python-exo-devel -l pl.UTF-8
129 Pliki programistyczne wiązań Pythona do libexo.
130
131 %prep
132 %setup -q
133
134 %build
135 %{?with_apidocs:%{__gtkdocize}}
136 %{__intltoolize}
137 %{__libtoolize}
138 %{__aclocal}
139 %{__autoheader}
140 %{__automake}
141 %{__autoconf}
142 %configure \
143         --%{?with_apidocs:en}%{!?with_apidocs:dis}able-gtk-doc \
144         --enable-notifications \
145         --enable-python \
146         --with-html-dir=%{_gtkdocdir} \
147         %{!?with_static_libs:--disable-static} \
148         --disable-silent-rules
149
150 %{__make}
151
152 %install
153 rm -rf $RPM_BUILD_ROOT
154
155 %{__make} install \
156         DESTDIR=$RPM_BUILD_ROOT
157
158 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
159
160 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{tl_PH,tl}
161 # already exists as ur
162 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/ur_PK
163
164 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/exo}
165
166 %py_postclean
167
168 %find_lang exo-1
169
170 %clean
171 rm -rf $RPM_BUILD_ROOT
172
173 %post   -p /sbin/ldconfig
174 %postun -p /sbin/ldconfig
175
176 %post   -n xfce-preferred-applications
177 %update_icon_cache hicolor
178
179 %postun -n xfce-preferred-applications
180 %update_icon_cache hicolor
181
182 %files -f exo-1.lang
183 %defattr(644,root,root,755)
184 %doc AUTHORS ChangeLog HACKING NEWS README TODO
185 %attr(755,root,root) %{_libdir}/libexo-1.so.*.*.*
186 %attr(755,root,root) %ghost %{_libdir}/libexo-1.so.0
187 %{_pixmapsdir}/exo-1
188
189 %files -n xfce-preferred-applications
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_bindir}/*
192 %dir %{_libdir}/xfce4/exo-1
193 %attr(755,root,root) %{_libdir}/xfce4/exo-1/exo-compose-mail-1
194 %attr(755,root,root) %{_libdir}/xfce4/exo-1/exo-helper-1
195 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/xfce4/*.rc
196 %dir %{_datadir}/doc/exo
197 %dir %{_datadir}/doc/exo/html
198 %{_datadir}/doc/exo/html/exo-preferred-applications.css
199 %{_datadir}/doc/exo/html/C
200 %lang(bn) %{_datadir}/doc/exo/html/bn
201 %lang(ca) %{_datadir}/doc/exo/html/ca
202 %lang(da) %{_datadir}/doc/exo/html/da
203 %lang(de) %{_datadir}/doc/exo/html/de
204 %lang(el) %{_datadir}/doc/exo/html/el
205 %lang(es) %{_datadir}/doc/exo/html/es
206 %lang(fr) %{_datadir}/doc/exo/html/fr
207 %lang(gl) %{_datadir}/doc/exo/html/gl
208 %lang(id) %{_datadir}/doc/exo/html/id
209 %lang(it) %{_datadir}/doc/exo/html/it
210 %lang(ja) %{_datadir}/doc/exo/html/ja
211 %lang(pt) %{_datadir}/doc/exo/html/pt
212 %lang(pt_BR) %{_datadir}/doc/exo/html/pt_BR
213 %lang(ru) %{_datadir}/doc/exo/html/ru
214 %lang(sv) %{_datadir}/doc/exo/html/sv
215 %lang(tr) %{_datadir}/doc/exo/html/tr
216 %lang(ug) %{_datadir}/doc/exo/html/ug
217 %lang(zh_CN) %{_datadir}/doc/exo/html/zh_CN
218 %dir %{_datadir}/xfce4/helpers
219 %{_datadir}/xfce4/helpers/*.desktop
220 %{_desktopdir}/*.desktop
221 %{_iconsdir}/hicolor/*/apps/preferences-desktop-default-applications.png
222 %{_iconsdir}/hicolor/*/apps/applications-internet.png
223 %{_iconsdir}/hicolor/*/apps/applications-other.png
224 %{_mandir}/man1/*.1*
225
226 %if %{with apidocs}
227 %files apidocs
228 %defattr(644,root,root,755)
229 %{_gtkdocdir}/exo-1
230 %endif
231
232 %files devel
233 %defattr(644,root,root,755)
234 %attr(755,root,root) %{_libdir}/libexo-1.so
235 %{_includedir}/exo-1
236 %{_pkgconfigdir}/exo-1.pc
237
238 %if %{with static_libs}
239 %files static
240 %defattr(644,root,root,755)
241 %{_libdir}/libexo-1.a
242 %endif
243
244 %files -n python-exo
245 %defattr(644,root,root,755)
246 %dir %{py_sitedir}/exo-0.6
247 %attr(755,root,root) %{py_sitedir}/exo-0.6/_exo.so
248 %dir %{py_sitedir}/exo-0.6/exo
249 %{py_sitedir}/exo-0.6/exo/*.py[co]
250 %{py_sitescriptdir}/*.py[co]
251
252 %files -n python-exo-devel
253 %defattr(644,root,root,755)
254 %{_datadir}/pygtk/2.0/defs/exo-0.6
This page took 0.237052 seconds and 3 git commands to generate.