]> git.pld-linux.org Git - packages/exo.git/blob - exo.spec
- up to 4.16.4
[packages/exo.git] / exo.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # gtk-doc documentation
4 %bcond_with     static_libs     # static libraries
5
6 %define         xfce_version    4.16.0
7 Summary:        Extension library to Xfce developed by os-cillation
8 Summary(pl.UTF-8):      Biblioteka rozszerzeń do Xfce opracowana przez os-cillation
9 Name:           exo
10 Version:        4.16.4
11 Release:        1
12 License:        GPL v2
13 Group:          X11/Libraries
14 Source0:        https://archive.xfce.org/src/xfce/exo/4.16/%{name}-%{version}.tar.bz2
15 # Source0-md5:  f85fe6ad7fbd989c622f4d4ebef86881
16 URL:            http://www.os-cillation.com/
17 BuildRequires:  autoconf >= 2.60
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  docbook-dtd412-xml
20 BuildRequires:  gettext-tools
21 BuildRequires:  glib2-devel >= 1:2.42.0
22 BuildRequires:  gtk+3-devel >= 3.22.0
23 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.9}
24 BuildRequires:  gtk-doc-automake
25 BuildRequires:  intltool >= 0.35.0
26 BuildRequires:  libtool >= 2:2.4
27 BuildRequires:  libxfce4ui-devel >= %{xfce_version}
28 BuildRequires:  libxfce4util-devel >= %{xfce_version}
29 BuildRequires:  perl-URI
30 BuildRequires:  pkgconfig
31 BuildRequires:  rpmbuild(macros) >= 1.601
32 BuildRequires:  xfce4-dev-tools >= 4.16.0
33 Requires:       glib2 >= 1:2.42.0
34 Requires:       gtk+3 >= 3.22.0
35 Requires:       xfce4-dirs >= 4.6
36 Provides:       libexo
37 Obsoletes:      libexo
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Extension library to Xfce developed by os-cillation.
42
43 %description -l pl.UTF-8
44 Biblioteka rozszerzeń do Xfce opracowana przez os-cillation.
45
46 %package -n xfce-preferred-applications
47 Summary:        The Xfce Preferred Applications framework
48 Summary(pl.UTF-8):      Struktura Preferowanych Aplikacji Xfce
49 Group:          X11/Applications
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       gtk-update-icon-cache
52 Requires:       hicolor-icon-theme
53
54 %description -n xfce-preferred-applications
55 The Xfce Preferred Applications framework.
56
57 %description -n xfce-preferred-applications -l pl.UTF-8
58 Struktura Preferowanych Aplikacji Xfce.
59
60 %package devel
61 Summary:        Header files for libexo library
62 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libexo
63 Group:          X11/Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65 Requires:       gtk+3-devel >= 3.22.0
66 Requires:       libxfce4util-devel >= %{xfce_version}
67 Provides:       libexo-devel
68 Obsoletes:      libexo-devel
69
70 %description devel
71 Header files for libexo library.
72
73 %description devel -l pl.UTF-8
74 Pliki nagłówkowe biblioteki libexo.
75
76 %package static
77 Summary:        Static libexo library
78 Summary(pl.UTF-8):      Statyczna biblioteka libexo
79 Group:          X11/Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81 Provides:       libexo-static
82 Obsoletes:      libexo-static
83
84 %description static
85 Static libexo library.
86
87 %description static -l pl.UTF-8
88 Statyczna biblioteka libexo.
89
90 %package apidocs
91 Summary:        libexo API documentation
92 Summary(pl.UTF-8):      Dokumentacja API libexo
93 Group:          Documentation
94 Requires:       gtk-doc-common
95 Provides:       libexo-apidocs
96 Obsoletes:      libexo-apidocs
97 BuildArch:      noarch
98
99 %description apidocs
100 libexo API documentation.
101
102 %description apidocs -l pl.UTF-8
103 Dokumentacja API libexo.
104
105 %prep
106 %setup -q
107
108 mkdir -p m4
109
110 %build
111 %{?with_apidocs:%{__gtkdocize}}
112 %{__intltoolize}
113 %{__libtoolize}
114 %{__aclocal}
115 %{__autoheader}
116 %{__automake}
117 %{__autoconf}
118 %configure \
119         --enable-gtk-doc%{!?with_apidocs:=no} \
120         --disable-silent-rules \
121         %{?with_static_libs:--enable-static} \
122         --with-html-dir=%{_gtkdocdir}
123
124 %{__make}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128
129 %{__make} install \
130         DESTDIR=$RPM_BUILD_ROOT
131
132 # obsoleted by pkg-config
133 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libexo*.la
134
135 # duplicates of hy,ur
136 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{hy_AM,ur_PK}
137 # not supported by glibc (as of 2.32)
138 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{fa_IR,hye,ie}
139
140 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/exo-2}
141
142 %find_lang exo-2
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post   -p /sbin/ldconfig
148 %postun -p /sbin/ldconfig
149
150 %post   -n xfce-preferred-applications
151 %update_icon_cache hicolor
152
153 %postun -n xfce-preferred-applications
154 %update_icon_cache hicolor
155
156 %files -f exo-2.lang
157 %defattr(644,root,root,755)
158 %doc AUTHORS ChangeLog HACKING NEWS
159 %attr(755,root,root) %{_libdir}/libexo-2.so.*.*.*
160 %attr(755,root,root) %ghost %{_libdir}/libexo-2.so.0
161 %{_pixmapsdir}/exo
162
163 %files -n xfce-preferred-applications
164 %defattr(644,root,root,755)
165 %attr(755,root,root) %{_bindir}/exo-desktop-item-edit
166 %attr(755,root,root) %{_bindir}/exo-open
167 %{_iconsdir}/hicolor/*/apps/preferences-desktop-default-applications.png
168 %{_mandir}/man1/exo-open.1*
169
170 %files devel
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libdir}/libexo-2.so
173 %{_includedir}/exo-2
174 %{_pkgconfigdir}/exo-2.pc
175
176 %if %{with static_libs}
177 %files static
178 %defattr(644,root,root,755)
179 %{_libdir}/libexo-2.a
180 %endif
181
182 %if %{with apidocs}
183 %files apidocs
184 %defattr(644,root,root,755)
185 %{_gtkdocdir}/exo-2
186 %endif
This page took 0.068424 seconds and 3 git commands to generate.