]> git.pld-linux.org Git - packages/exo.git/blob - exo.spec
- BR: perl-URI, rel.3
[packages/exo.git] / exo.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         _pre            beta2
6 %define         xfce_version    4.3.90.2
7 #
8 Summary:        Extension library to Xfce developed by os-cillation
9 Summary(pl):    Biblioteka rozszerzeñ do Xfce opracowana przez os-cillation
10 Name:           libexo
11 Version:        0.3.1.8
12 Release:        0.%{_pre}.3
13 License:        GPL v2
14 Group:          Libraries
15 Source0:        http://www.xfce.org/archive/xfce-%{xfce_version}/src/exo-%{version}%{_pre}.tar.bz2
16 # Source0-md5:  b8465faab19e233d5edda12bdd4940b4
17 URL:            http://www.os-cillation.com/
18 BuildRequires:  autoconf >= 2.50
19 BuildRequires:  automake
20 BuildRequires:  gettext-devel
21 BuildRequires:  gtk+2-devel >= 2:2.10.1
22 BuildRequires:  gtk-doc >= 1.0
23 BuildRequires:  libtool
24 BuildRequires:  libxfce4util-devel >= %{xfce_version}
25 BuildRequires:  perl-URI
26 BuildRequires:  pkgconfig
27 BuildRequires:  python-pygtk-devel >= 2:2.9.3
28 BuildRequires:  rpmbuild(macros) >= 1.219
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  xfce4-dev-tools >= %{xfce_version}
31 BuildRequires:  xfce-mcs-manager-devel >= %{xfce_version}
32 BuildRequires:  xorg-lib-libXt-devel
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Extension library to Xfce developed by os-cillation.
37
38 %description -l pl
39 Biblioteka rozszerzeñ do Xfce opracowana przez os-cillation.
40
41 %package -n xfce-preferred-applications
42 Summary:        The Xfce Preferred Applications framework
43 Summary(pl):    Struktura Preferowanych Aplikacji Xfce
44 Group:          Applications
45 Requires(post,postun):  gtk+2 >= 2:2.10.0
46 Requires:       xfce-mcs-plugins >= %{xfce_version}
47
48 %description -n xfce-preferred-applications
49 The Xfce Preferred Applications framework.
50
51 %description -n xfce-preferred-applications -l pl
52 Struktura Preferowanych Aplikacji Xfce.
53
54 %package devel
55 Summary:        Header files for libexo library
56 Summary(pl):    Pliki nag³ówkowe biblioteki libexo
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       libxfce4util-devel >= %{xfce_version}
60
61 %description devel
62 Header files for libexo library.
63
64 %description devel -l pl
65 Pliki nag³ówkowe biblioteki libexo.
66
67 %package static
68 Summary:        Static libexo library
69 Summary(pl):    Statyczna biblioteka libexo
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{version}-%{release}
72
73 %description static
74 Static libexo library.
75
76 %description static -l pl
77 Statyczna biblioteka libexo.
78
79 %package -n python-exo
80 Summary:        Python binding for libexo library
81 Summary(pl):    Wi±zania Pythona do biblioteki libexo
82 Group:          Libraries/Python
83 Requires:       %{name} = %{version}-%{release}
84 %pyrequires_eq  python-libs
85
86 %description -n python-exo
87 Python binding for libexo library.
88
89 %description -n python-exo -l pl
90 Wi±zania Pythona do biblioteki libexo.
91
92 %package -n python-exo-devel
93 Summary:        Development files for libexo Python bindings
94 Summary(pl):    Pliki programistyczne wi±zañ Pythona do libexo
95 Group:          Libraries/Python
96 Requires:       python-exo = %{version}-%{release}
97
98 %description -n python-exo-devel
99 Development files for libexo Python bindings.
100
101 %description -n python-exo-devel -l pl
102 Pliki programistyczne wi±zañ Pythona do libexo.
103
104 %prep
105 %setup -q -n exo-%{version}%{_pre}
106
107 %build
108 %{__libtoolize}
109 %{__aclocal}
110 %{__autoheader}
111 %{__automake}
112 %{__autoconf}
113 %configure \
114         --with-html-dir=%{_gtkdocdir} \
115         %{!?with_static_libs:--disable-static} \
116         --enable-xfce-mcs-manager
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 rm -f $RPM_BUILD_ROOT%{_libdir}/xfce4/mcs-plugins/*.{la,a}
126 rm -f $RPM_BUILD_ROOT%{py_sitedir}/exo-0.3/*.{la,a}
127
128 %py_postclean
129
130 %find_lang %{name}-0.3
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %post   -p /sbin/ldconfig
136 %postun -p /sbin/ldconfig
137
138 %post   -n xfce-preferred-applications
139 gtk-update-icon-cache -qf %{_datadir}/icons/hicolor
140
141 %postun -n xfce-preferred-applications
142 gtk-update-icon-cache -qf %{_datadir}/icons/hicolor
143
144 %files -f %{name}-0.3.lang
145 %defattr(644,root,root,755)
146 %doc AUTHORS ChangeLog HACKING NEWS README TODO
147 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
148
149 %files -n xfce-preferred-applications
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_bindir}/*
152 %attr(755,root,root) %{_libdir}/exo-compose-mail-0.3
153 %attr(755,root,root) %{_libdir}/exo-helper-0.3
154 %attr(755,root,root) %{_libdir}/xfce4/mcs-plugins/exo-preferred-applications-settings.so
155 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/xfce4/*.rc
156 %{_datadir}/xfce4/doc/C
157 %lang(ja) %{_datadir}/xfce4/doc/ja
158 %dir %{_datadir}/xfce4/helpers
159 %{_datadir}/xfce4/helpers/*.desktop
160 %{_desktopdir}/*.desktop
161 %{_iconsdir}/hicolor/*/apps/preferences-desktop-default-applications.png
162 %{_iconsdir}/hicolor/*/apps/applications-internet.png
163 %{_iconsdir}/hicolor/*/apps/applications-other.png
164 %{_mandir}/man1/*.1*
165
166 %files devel
167 %defattr(644,root,root,755)
168 %attr(755,root,root) %{_libdir}/lib*.so
169 %{_libdir}/lib*.la
170 %{_includedir}/exo-0.3
171 %{_pkgconfigdir}/*.pc
172 # not present in beta ?
173 #%{_gtkdocdir}/exo
174
175 %if %{with static_libs}
176 %files static
177 %defattr(644,root,root,755)
178 %{_libdir}/lib*.a
179 %endif
180
181 %files -n python-exo
182 %defattr(644,root,root,755)
183 %dir %{py_sitedir}/exo-0.3
184 %attr(755,root,root) %{py_sitedir}/exo-0.3/_exo.so
185 %dir %{py_sitedir}/exo-0.3/exo
186 %{py_sitedir}/exo-0.3/exo/*.py[co]
187 %{py_sitescriptdir}/*.py[co]
188
189 %files -n python-exo-devel
190 %defattr(644,root,root,755)
191 %{_datadir}/pygtk/2.0/defs/exo-0.3
This page took 0.082149 seconds and 3 git commands to generate.