]> git.pld-linux.org Git - packages/exo.git/blob - exo.spec
- updated to 0.3.1.10rc1
[packages/exo.git] / exo.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         _pre            rc1
6 %define         xfce_version    4.3.99.1
7 #
8 Summary:        Extension library to Xfce developed by os-cillation
9 Summary(pl):    Biblioteka rozszerzeñ do Xfce opracowana przez os-cillation
10 Name:           libexo
11 Version:        0.3.1.10
12 Release:        0.%{_pre}.1
13 License:        GPL v2
14 Group:          Libraries
15 Source0:        http://www.xfce.org/archive/xfce-%{xfce_version}/src/exo-%{version}%{_pre}.tar.bz2
16 # Source0-md5:  98d5493c898ab54b82b0835fc0e6df87
17 URL:            http://www.os-cillation.com/
18 BuildRequires:  autoconf >= 2.50
19 BuildRequires:  automake
20 BuildRequires:  gettext-devel
21 BuildRequires:  gtk+2-devel >= 2:2.10.1
22 BuildRequires:  gtk-doc >= 1.0
23 BuildRequires:  intltool >= 0.35.0
24 BuildRequires:  libtool
25 BuildRequires:  libxfce4util-devel >= %{xfce_version}
26 BuildRequires:  perl-URI
27 BuildRequires:  pkgconfig
28 BuildRequires:  python-pygtk-devel >= 2:2.9.3
29 BuildRequires:  rpmbuild(macros) >= 1.311
30 BuildRequires:  rpm-pythonprov
31 BuildRequires:  xfce4-dev-tools >= %{xfce_version}
32 BuildRequires:  xfce-mcs-manager-devel >= %{xfce_version}
33 BuildRequires:  xorg-lib-libXt-devel
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Extension library to Xfce developed by os-cillation.
38
39 %description -l pl
40 Biblioteka rozszerzeñ do Xfce opracowana przez os-cillation.
41
42 %package -n xfce-preferred-applications
43 Summary:        The Xfce Preferred Applications framework
44 Summary(pl):    Struktura Preferowanych Aplikacji Xfce
45 Group:          Applications
46 Requires(post,postun):  gtk+2 >= 2:2.10.0
47 Requires(post,postun):  hicolor-icon-theme
48 Requires:       xfce-mcs-plugins >= %{xfce_version}
49
50 %description -n xfce-preferred-applications
51 The Xfce Preferred Applications framework.
52
53 %description -n xfce-preferred-applications -l pl
54 Struktura Preferowanych Aplikacji Xfce.
55
56 %package devel
57 Summary:        Header files for libexo library
58 Summary(pl):    Pliki nag³ówkowe biblioteki libexo
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       libxfce4util-devel >= %{xfce_version}
62
63 %description devel
64 Header files for libexo library.
65
66 %description devel -l pl
67 Pliki nag³ówkowe biblioteki libexo.
68
69 %package static
70 Summary:        Static libexo library
71 Summary(pl):    Statyczna biblioteka libexo
72 Group:          Development/Libraries
73 Requires:       %{name}-devel = %{version}-%{release}
74
75 %description static
76 Static libexo library.
77
78 %description static -l pl
79 Statyczna biblioteka libexo.
80
81 %package -n python-exo
82 Summary:        Python binding for libexo library
83 Summary(pl):    Wi±zania Pythona do biblioteki libexo
84 Group:          Libraries/Python
85 Requires:       %{name} = %{version}-%{release}
86 %pyrequires_eq  python-libs
87
88 %description -n python-exo
89 Python binding for libexo library.
90
91 %description -n python-exo -l pl
92 Wi±zania Pythona do biblioteki libexo.
93
94 %package -n python-exo-devel
95 Summary:        Development files for libexo Python bindings
96 Summary(pl):    Pliki programistyczne wi±zañ Pythona do libexo
97 Group:          Libraries/Python
98 Requires:       python-exo = %{version}-%{release}
99
100 %description -n python-exo-devel
101 Development files for libexo Python bindings.
102
103 %description -n python-exo-devel -l pl
104 Pliki programistyczne wi±zañ Pythona do libexo.
105
106 %prep
107 %setup -q -n exo-%{version}%{_pre}
108
109 %build
110 %{__intltoolize}
111 %{__libtoolize}
112 %{__aclocal}
113 %{__autoheader}
114 %{__automake}
115 %{__autoconf}
116 %configure \
117         --with-html-dir=%{_gtkdocdir} \
118         %{!?with_static_libs:--disable-static} \
119         --enable-xfce-mcs-manager
120 %{__make}
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 rm -f $RPM_BUILD_ROOT%{_libdir}/xfce4/mcs-plugins/*.{la,a}
129 rm -f $RPM_BUILD_ROOT%{py_sitedir}/exo-0.3/*.{la,a}
130
131 %py_postclean
132
133 %find_lang %{name}-0.3
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %post   -p /sbin/ldconfig
139 %postun -p /sbin/ldconfig
140
141 %post   -n xfce-preferred-applications
142 %update_icon_cache hicolor
143
144 %postun -n xfce-preferred-applications
145 %update_icon_cache hicolor
146
147 %files -f %{name}-0.3.lang
148 %defattr(644,root,root,755)
149 %doc AUTHORS ChangeLog HACKING NEWS README TODO
150 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
151 %{_pixmapsdir}/exo-0.3/
152
153 %files -n xfce-preferred-applications
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_bindir}/*
156 %attr(755,root,root) %{_libdir}/exo-compose-mail-0.3
157 %attr(755,root,root) %{_libdir}/exo-helper-0.3
158 %attr(755,root,root) %{_libdir}/xfce4/mcs-plugins/exo-preferred-applications-settings.so
159 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/xfce4/*.rc
160 %{_datadir}/xfce4/doc/C
161 %lang(ja) %{_datadir}/xfce4/doc/ja
162 %dir %{_datadir}/xfce4/helpers
163 %{_datadir}/xfce4/helpers/*.desktop
164 %{_desktopdir}/*.desktop
165 %{_iconsdir}/hicolor/*/apps/preferences-desktop-default-applications.png
166 %{_iconsdir}/hicolor/*/apps/applications-internet.png
167 %{_iconsdir}/hicolor/*/apps/applications-other.png
168 %{_mandir}/man1/*.1*
169
170 %files devel
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libdir}/lib*.so
173 %{_libdir}/lib*.la
174 %{_includedir}/exo-0.3
175 %{_pkgconfigdir}/*.pc
176 # not present in beta ?
177 #%{_gtkdocdir}/exo
178
179 %if %{with static_libs}
180 %files static
181 %defattr(644,root,root,755)
182 %{_libdir}/lib*.a
183 %endif
184
185 %files -n python-exo
186 %defattr(644,root,root,755)
187 %dir %{py_sitedir}/exo-0.3
188 %attr(755,root,root) %{py_sitedir}/exo-0.3/_exo.so
189 %dir %{py_sitedir}/exo-0.3/exo
190 %{py_sitedir}/exo-0.3/exo/*.py[co]
191 %{py_sitescriptdir}/*.py[co]
192
193 %files -n python-exo-devel
194 %defattr(644,root,root,755)
195 %{_datadir}/pygtk/2.0/defs/exo-0.3
This page took 0.048044 seconds and 3 git commands to generate.