]> git.pld-linux.org Git - packages/exo.git/blob - exo.spec
- updated to 0.3.2, merged from HEAD
[packages/exo.git] / exo.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         xfce_version    4.4.0
6 #
7 Summary:        Extension library to Xfce developed by os-cillation
8 Summary(pl):    Biblioteka rozszerzeñ do Xfce opracowana przez os-cillation
9 Name:           libexo
10 Version:        0.3.2
11 Release:        1
12 License:        GPL v2
13 Group:          Libraries
14 Source0:        http://www.xfce.org/archive/xfce-%{xfce_version}/src/exo-%{version}.tar.bz2
15 # Source0-md5:  8b73acc98d0938d1193b31316823b6db
16 URL:            http://www.os-cillation.com/
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake
19 BuildRequires:  gettext-devel
20 BuildRequires:  gtk+2-devel >= 2:2.8.20
21 BuildRequires:  gtk-doc >= 1.6
22 BuildRequires:  hal-devel >= 0.5.0
23 BuildRequires:  intltool >= 0.35.0
24 BuildRequires:  libtool
25 BuildRequires:  libnotify-devel >= 0.4.0
26 BuildRequires:  libxfce4util-devel >= %{xfce_version}
27 BuildRequires:  perl-URI
28 BuildRequires:  pkgconfig
29 BuildRequires:  python-pygtk-devel >= 2:2.8.6
30 BuildRequires:  rpm-pythonprov
31 BuildRequires:  rpmbuild(macros) >= 1.311
32 BuildRequires:  xfce-mcs-manager-devel >= %{xfce_version}
33 BuildRequires:  xfce4-dev-tools >= %{xfce_version}
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Extension library to Xfce developed by os-cillation.
38
39 %description -l pl
40 Biblioteka rozszerzeñ do Xfce opracowana przez os-cillation.
41
42 %package -n xfce-preferred-applications
43 Summary:        The Xfce Preferred Applications framework
44 Summary(pl):    Struktura Preferowanych Aplikacji Xfce
45 Group:          Applications
46 Requires(post,postun):  gtk+2
47 Requires(post,postun):  hicolor-icon-theme
48 Requires:       xfce-mcs-plugins >= %{xfce_version}
49
50 %description -n xfce-preferred-applications
51 The Xfce Preferred Applications framework.
52
53 %description -n xfce-preferred-applications -l pl
54 Struktura Preferowanych Aplikacji Xfce.
55
56 %package apidocs
57 Summary:        libexo API documentation
58 Summary(pl):    Dokumentacja API libexo
59 Group:          Documentation
60 Requires:       gtk-doc-common
61
62 %description apidocs
63 libexo API documentation.
64
65 %description apidocs -l pl
66 Dokumentacja API libexo.
67
68 %package devel
69 Summary:        Header files for libexo library
70 Summary(pl):    Pliki nag³ówkowe biblioteki libexo
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73 Requires:       libxfce4util-devel >= %{xfce_version}
74
75 %description devel
76 Header files for libexo library.
77
78 %description devel -l pl
79 Pliki nag³ówkowe biblioteki libexo.
80
81 %package static
82 Summary:        Static libexo library
83 Summary(pl):    Statyczna biblioteka libexo
84 Group:          Development/Libraries
85 Requires:       %{name}-devel = %{version}-%{release}
86
87 %description static
88 Static libexo library.
89
90 %description static -l pl
91 Statyczna biblioteka libexo.
92
93 %package -n python-exo
94 Summary:        Python binding for libexo library
95 Summary(pl):    Wi±zania Pythona do biblioteki libexo
96 Group:          Libraries/Python
97 Requires:       %{name} = %{version}-%{release}
98 %pyrequires_eq  python-libs
99
100 %description -n python-exo
101 Python binding for libexo library.
102
103 %description -n python-exo -l pl
104 Wi±zania Pythona do biblioteki libexo.
105
106 %package -n python-exo-devel
107 Summary:        Development files for libexo Python bindings
108 Summary(pl):    Pliki programistyczne wi±zañ Pythona do libexo
109 Group:          Libraries/Python
110 Requires:       python-exo = %{version}-%{release}
111
112 %description -n python-exo-devel
113 Development files for libexo Python bindings.
114
115 %description -n python-exo-devel -l pl
116 Pliki programistyczne wi±zañ Pythona do libexo.
117
118 %prep
119 %setup -q -n exo-%{version}
120
121 %build
122 %{__intltoolize}
123 %{__libtoolize}
124 %{__aclocal}
125 %{__autoheader}
126 %{__automake}
127 %{__autoconf}
128 %configure \
129         --enable-hal \
130         --enable-gtk-doc \
131         --enable-notifications \
132         --with-html-dir=%{_gtkdocdir} \
133         %{!?with_static_libs:--disable-static} \
134         --enable-python \
135         --enable-mcs-plugin
136 %{__make}
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140
141 %{__make} install \
142         DESTDIR=$RPM_BUILD_ROOT
143
144 rm -f $RPM_BUILD_ROOT%{_libdir}/xfce4/mcs-plugins/*.{la,a}
145 rm -f $RPM_BUILD_ROOT%{py_sitedir}/exo-0.3/*.{la,a}
146
147 %py_postclean
148
149 %find_lang %{name}-0.3
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %post   -p /sbin/ldconfig
155 %postun -p /sbin/ldconfig
156
157 %post   -n xfce-preferred-applications
158 %update_icon_cache hicolor
159
160 %postun -n xfce-preferred-applications
161 %update_icon_cache hicolor
162
163 %files -f %{name}-0.3.lang
164 %defattr(644,root,root,755)
165 %doc AUTHORS ChangeLog HACKING NEWS README TODO
166 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
167 %{_pixmapsdir}/exo-0.3/
168
169 %files -n xfce-preferred-applications
170 %defattr(644,root,root,755)
171 %attr(755,root,root) %{_bindir}/*
172 %attr(755,root,root) %{_libdir}/exo-compose-mail-0.3
173 %attr(755,root,root) %{_libdir}/exo-helper-0.3
174 %attr(755,root,root) %{_libdir}/exo-mount-notify-0.3
175 %attr(755,root,root) %{_libdir}/xfce4/mcs-plugins/exo-preferred-applications-settings.so
176 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/xfce4/*.rc
177 %{_datadir}/xfce4/doc/C
178 %lang(fr) %{_datadir}/xfce4/doc/fr
179 %lang(ja) %{_datadir}/xfce4/doc/ja
180 %dir %{_datadir}/xfce4/helpers
181 %{_datadir}/xfce4/helpers/*.desktop
182 %{_desktopdir}/*.desktop
183 %{_iconsdir}/hicolor/*/apps/preferences-desktop-default-applications.png
184 %{_iconsdir}/hicolor/*/apps/applications-internet.png
185 %{_iconsdir}/hicolor/*/apps/applications-other.png
186 %{_mandir}/man1/*.1*
187
188 %files apidocs
189 %defattr(644,root,root,755)
190 %{_gtkdocdir}/exo
191
192 %files devel
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_libdir}/lib*.so
195 %{_libdir}/lib*.la
196 %{_includedir}/exo-0.3
197 %{_pkgconfigdir}/*.pc
198
199 %if %{with static_libs}
200 %files static
201 %defattr(644,root,root,755)
202 %{_libdir}/lib*.a
203 %endif
204
205 %files -n python-exo
206 %defattr(644,root,root,755)
207 %dir %{py_sitedir}/exo-0.3
208 %attr(755,root,root) %{py_sitedir}/exo-0.3/_exo.so
209 %dir %{py_sitedir}/exo-0.3/exo
210 %{py_sitedir}/exo-0.3/exo/*.py[co]
211 %{py_sitescriptdir}/*.py[co]
212
213 %files -n python-exo-devel
214 %defattr(644,root,root,755)
215 %{_datadir}/pygtk/2.0/defs/exo-0.3
This page took 0.122096 seconds and 3 git commands to generate.