]> git.pld-linux.org Git - packages/exim.git/commitdiff
- up to 4.90
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 20 Dec 2017 11:42:09 +0000 (12:42 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 20 Dec 2017 11:42:09 +0000 (12:42 +0100)
branch.sh
exim-commandline_checks_require_admin.patch [deleted file]
exim-spam-timeout.patch
exim.spec

index d5c1f97f2065754d50213201eed08f0c8f4efcd0..1e0283430a350743176f8cc991d79ebe27b20087 100755 (executable)
--- a/branch.sh
+++ b/branch.sh
@@ -2,8 +2,8 @@
 set -e
 url=git://git.exim.org/exim.git
 package=exim
-tag=exim-4_89_1
-branch=exim-4_89+fixes
+tag=exim-4_90
+branch=exim-4_90+fixes
 out=$package-git.patch
 repo=$package.git
 
diff --git a/exim-commandline_checks_require_admin.patch b/exim-commandline_checks_require_admin.patch
deleted file mode 100644 (file)
index c0d5f73..0000000
+++ /dev/null
@@ -1,64 +0,0 @@
-commit f33875c3a0a0ef03a2e53cfcd339791b793151f0
-Author: Phil Pennock <pdp@exim.org>
-Date:   Tue May 9 16:00:58 2017 -0400
-
-    Add option commandline_checks_require_admin
-    
-    May help with scenarios already so broken that bug report 2118 is
-    actually an issue (Wordpress vuln).
-
-diff --git a/src/src/exim.c b/src/src/exim.c
-index dcc84e3d..67583e58 100644
---- a/src/src/exim.c
-+++ b/src/src/exim.c
-@@ -3868,6 +3868,14 @@ else
-           trusted_caller = TRUE;
-   }
-+/* At this point, we know if the user is privileged and some command-line
-+options become possibly imperssible, depending upon the configuration file. */
-+
-+if (checking && commandline_checks_require_admin && !admin_user) {
-+  fprintf(stderr, "exim: those command-line flags are set to require admin\n");
-+  exit(EXIT_FAILURE);
-+}
-+
- /* Handle the decoding of logging options. */
- decode_bits(log_selector, log_selector_size, log_notall,
-diff --git a/src/src/globals.c b/src/src/globals.c
-index 46db4f37..9b455c9d 100644
---- a/src/src/globals.c
-+++ b/src/src/globals.c
-@@ -511,6 +511,7 @@ uschar *client_authenticated_id = NULL;
- uschar *client_authenticated_sender = NULL;
- int     clmacro_count          = 0;
- uschar *clmacros[MAX_CLMACROS];
-+BOOL    commandline_checks_require_admin = FALSE;
- BOOL    config_changed         = FALSE;
- FILE   *config_file            = NULL;
- const uschar *config_filename  = NULL;
-diff --git a/src/src/globals.h b/src/src/globals.h
-index 63c9c29c..056f1c21 100644
---- a/src/src/globals.h
-+++ b/src/src/globals.h
-@@ -282,6 +282,7 @@ extern uschar *client_authenticated_id;     /* "login" name used for SMTP AUTH *
- extern uschar *client_authenticated_sender; /* AUTH option to SMTP MAIL FROM (not yet used) */
- extern int     clmacro_count;          /* Number of command line macros */
- extern uschar *clmacros[];             /* Copy of them, for re-exec */
-+extern BOOL    commandline_checks_require_admin; /* belt and braces for insecure setups */
- extern int     connection_max_messages;/* Max down one SMTP connection */
- extern BOOL    config_changed;         /* True if -C used */
- extern FILE   *config_file;            /* Configuration file */
-diff --git a/src/src/readconf.c b/src/src/readconf.c
-index f43a3d16..95abaf5b 100644
---- a/src/src/readconf.c
-+++ b/src/src/readconf.c
-@@ -217,6 +217,7 @@ static optionlist optionlist_config[] = {
-   { "check_spool_inodes",       opt_int,         &check_spool_inodes },
-   { "check_spool_space",        opt_Kint,        &check_spool_space },
-   { "chunking_advertise_hosts", opt_stringptr,         &chunking_advertise_hosts },
-+  { "commandline_checks_require_admin", opt_bool,&commandline_checks_require_admin },
-   { "daemon_smtp_port",         opt_stringptr|opt_hidden, &daemon_smtp_port },
-   { "daemon_smtp_ports",        opt_stringptr,   &daemon_smtp_port },
-   { "daemon_startup_retries",   opt_int,         &daemon_startup_retries },
index b1dfe12fe67fd95874868a3fa6bcdcead36ca789..0c6c0fa870095271bfd1e7c730f6f23a5fc00093 100644 (file)
@@ -1,11 +1,12 @@
 --- exim-4.86/src/spam.c~      2015-07-23 23:20:37.000000000 +0200
 +++ exim-4.86/src/spam.c       2015-07-29 10:41:57.918864020 +0200
 @@ -344,7 +344,7 @@ start = time(NULL);
      for (;;)
        {
+       /*XXX could potentially use TFO early-data here */
 -      if (  (spamd_sock = ip_streamsocket(sd->hostspec, &errstr, 5)) >= 0
 +      if (  (spamd_sock = ip_streamsocket(sd->hostspec, &errstr, 15)) >= 0
           || sd->retry <= 0
         )
        break;
+
index 4488296a7f7dbe1fb021f3bc5792496e32b94aeb..984c226ea0bb4a8e9f782d4803fe149689008738 100644 (file)
--- a/exim.spec
+++ b/exim.spec
@@ -23,15 +23,15 @@ Summary:    University of Cambridge Mail Transfer Agent
 Summary(pl.UTF-8):     Agent Transferu Poczty Uniwersytetu w Cambridge
 Summary(pt_BR.UTF-8):  Servidor de correio eletrônico exim
 Name:          exim
-Version:       4.89.1
-Release:       2
+Version:       4.90
+Release:       1
 Epoch:         2
 License:       GPL
 Group:         Networking/Daemons/SMTP
 Source0:       ftp://ftp.exim.org/pub/exim/exim4/%{name}-%{version}.tar.bz2
-# Source0-md5: 6e65d9fc17449dcde6254bd312c64822
+# Source0-md5: 29a14c4bd29b553c0dfc13036225ebdd
 Source1:       ftp://ftp.exim.org/pub/exim/exim4/%{name}-html-%{version}.tar.bz2
-# Source1-md5: e633e855fa08855b4c0cae28eb7888bc
+# Source1-md5: a728618fb641f4b9eb56deeefdb0cf67
 Source2:       %{name}.init
 Source3:       %{name}.cron.db
 Source4:       %{name}4.conf
@@ -58,7 +58,6 @@ Patch3:               exim-defs.patch
 Patch4:                %{name}4-Makefile-Default.patch
 # http://marc.merlins.org/linux/exim/files/sa-exim-cvs/localscan_dlopen_exim_4.20_or_better.patch
 Patch5:                localscan_dlopen_%{name}_4.20_or_better.patch
-Patch6:                exim-commandline_checks_require_admin.patch
 
 Patch8:                %{name}-spam-timeout.patch
 
@@ -177,7 +176,7 @@ Pliki nagłówkowe dla Exima.
 
 %prep
 %setup -q -a1 -a7
-%patch100 -p2
+#%patch100 -p2
 
 %patch0 -p1
 %patch1 -p1
@@ -185,7 +184,6 @@ Pliki nagłówkowe dla Exima.
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-%patch6 -p2
 
 %patch8 -p1
 
This page took 0.327432 seconds and 4 git commands to generate.