]> git.pld-linux.org Git - packages/exim.git/commitdiff
- fix bug 461 auto/th/exim-4_66-2
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 6 Feb 2007 14:36:36 +0000 (14:36 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    exim-bug-461.patch -> 1.1
    exim.spec -> 1.276

exim-bug-461.patch [new file with mode: 0644]
exim.spec

diff --git a/exim-bug-461.patch b/exim-bug-461.patch
new file mode 100644 (file)
index 0000000..0ac5cff
--- /dev/null
@@ -0,0 +1,65 @@
+*** exim-4.66/src/deliver.c Mon Jan  8 14:25:36 2007
+--- exim/src/deliver.c Tue Feb  6 14:19:00 2007
+***************
+*** 5639,5650 ****
+          string_sprintf("R:%s", addr->domain), 0);
+  
+      /* Otherwise, if there is an existing retry record in the database, add
+!     retry items to delete both forms. Since the domain might have been
+!     rewritten (expanded to fully qualified) as a result of routing, ensure
+!     that the rewritten form is also deleted. */
+  
+      else if (testflag(addr, af_dr_retry_exists))
+        {
+        retry_add_item(addr, addr->address_retry_key, rf_delete);
+        retry_add_item(addr, addr->domain_retry_key, rf_delete);
+        if (Ustrcmp(addr->domain, old_domain) != 0)
+--- 5637,5652 ----
+          string_sprintf("R:%s", addr->domain), 0);
+  
+      /* Otherwise, if there is an existing retry record in the database, add
+!     retry items to delete both forms. We must also allow for the possibility
+!     of a routing retry that includes the sender address. Since the domain might
+!     have been rewritten (expanded to fully qualified) as a result of routing,
+!     ensure that the rewritten form is also deleted. */
+  
+      else if (testflag(addr, af_dr_retry_exists))
+        {
++       uschar *altkey = string_sprintf("%s:<%s>", addr->address_retry_key,
++         sender_address);
++       retry_add_item(addr, altkey, rf_delete);
+        retry_add_item(addr, addr->address_retry_key, rf_delete);
+        retry_add_item(addr, addr->domain_retry_key, rf_delete);
+        if (Ustrcmp(addr->domain, old_domain) != 0)
+          wmf_text = next_emf(wmf, US"header");
+*** exim-4.66/src/transports/smtp.c Mon Jan  8 14:25:37 2007
+--- exim/src/transports/smtp.c Tue Feb  6 14:19:00 2007
+***************
+*** 643,652 ****
+      addr->transport_return = PENDING_OK;
+  
+      /* If af_dr_retry_exists is set, there was a routing delay on this address;
+!     ensure that any address-specific retry record is expunged. */
+  
+      if (testflag(addr, af_dr_retry_exists))
+        retry_add_item(addr, addr->address_retry_key, rf_delete);
+      }
+  
+    /* Timeout while reading the response */
+--- 654,669 ----
+      addr->transport_return = PENDING_OK;
+  
+      /* If af_dr_retry_exists is set, there was a routing delay on this address;
+!     ensure that any address-specific retry record is expunged. We do this both
+!     for the basic key and for the version that also includes the sender. */
+  
+      if (testflag(addr, af_dr_retry_exists))
++       {
++       uschar *altkey = string_sprintf("%s:<%s>", addr->address_retry_key,
++         sender_address);
++       retry_add_item(addr, altkey, rf_delete);
+        retry_add_item(addr, addr->address_retry_key, rf_delete);
++       }
+      }
+  
+    /* Timeout while reading the response */
index 4d6c32860dcb0d7719477c0d80a3ded882465c69..b571cb500e98ec0035a565d96d3a6431abd1d3cc 100644 (file)
--- a/exim.spec
+++ b/exim.spec
@@ -15,7 +15,7 @@ Summary(pl):  Agent Transferu Poczty Uniwersytetu w Cambridge
 Summary(pt_BR):        Servidor de correio eletrônico exim
 Name:          exim
 Version:       4.66
-Release:       1
+Release:       2
 Epoch:         2
 License:       GPL
 Group:         Networking/Daemons
@@ -52,6 +52,7 @@ Patch6:               %{name}-noloadbalance.patch
 # http://sourceforge.net/projects/eximdsn/
 Patch7:                %{name}_463_dsn_1_3.patch
 Patch8:                %{name}-spam-timeout.patch
+Patch9:                %{name}-bug-461.patch
 URL:           http://www.exim.org/
 %{?with_sasl:BuildRequires:    cyrus-sasl-devel >= 2.1.0}
 BuildRequires: db-devel
@@ -172,6 +173,7 @@ Pliki nag
 %patch6 -p1
 %patch7 -p1
 %patch8 -p1
+%patch9 -p1
 
 install %{SOURCE13} doc/FAQ.txt.bz2
 install %{SOURCE14} doc/config.samples.tar.bz2
This page took 0.037577 seconds and 4 git commands to generate.