]> git.pld-linux.org Git - packages/exim.git/commitdiff
rel 2; fixes from master auto/th/exim-4.97-2
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 13 Dec 2023 15:18:57 +0000 (16:18 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 13 Dec 2023 15:18:57 +0000 (16:18 +0100)
90_localscan_dlopen.dpatch
branch.sh
exim.spec

index 36c63d670bcdceea6e842e4a630d490216c80a56..83d5f823a8792e8e3eff593e08d92247c45a8e43 100644 (file)
@@ -6,11 +6,11 @@ Description: Allow one to use and switch between different local_scan functions
 Author: David Woodhouse, Derrick 'dman' Hudson, Marc MERLIN
 Origin: other, http://marc.merlins.org/linux/exim/files/sa-exim-current/
 Forwarded: https://bugs.exim.org/show_bug.cgi?id=2671
-Last-Update: 2022-12-19
+Last-Update: 2023-09-09
 
 --- a/src/EDITME
 +++ b/src/EDITME
-@@ -874,10 +874,25 @@ HEADERS_CHARSET="ISO-8859-1"
+@@ -902,10 +902,25 @@ HEADERS_CHARSET="ISO-8859-1"
  # as the traditional crypt() function.
  # *** WARNING *** WARNING *** WARNING *** WARNING *** WARNING ***
  
@@ -53,7 +53,7 @@ Last-Update: 2022-12-19
  #define CONFIGURE_FILE_USE_NODE
 --- a/src/globals.c
 +++ b/src/globals.c
-@@ -115,10 +115,14 @@ tls_support tls_out = {
+@@ -116,10 +116,14 @@ tls_support tls_out = {
  uschar *dsn_envid              = NULL;
  int     dsn_ret                = 0;
  const pcre2_code  *regex_DSN         = NULL;
@@ -70,7 +70,7 @@ Last-Update: 2022-12-19
  uschar *openssl_options        = NULL;
 --- a/src/globals.h
 +++ b/src/globals.h
-@@ -153,10 +153,14 @@ extern uschar *tls_advertise_hosts;    /
+@@ -155,10 +155,14 @@ extern uschar *tls_advertise_hosts;    /
  extern uschar  *dsn_envid;             /* DSN envid string */
  extern int      dsn_ret;               /* DSN ret type*/
  extern const pcre2_code  *regex_DSN;         /* For recognizing DSN settings */
@@ -87,7 +87,7 @@ Last-Update: 2022-12-19
  extern uschar * (*lwr_receive_getbuf)(unsigned *);
 --- a/src/local_scan.c
 +++ b/src/local_scan.c
-@@ -5,60 +5,136 @@
+@@ -6,60 +6,136 @@
  /* Copyright (c) The Exim Maintainers 2021 */
  /* See the file NOTICE for conditions of use and distribution. */
  /* SPDX-License-Identifier: GPL-2.0-or-later */
@@ -268,7 +268,7 @@ Last-Update: 2022-12-19
  /* End of local_scan.c */
 --- a/src/local_scan.h
 +++ b/src/local_scan.h
-@@ -25,10 +25,11 @@ store.c
+@@ -26,10 +26,11 @@ store.c
  /* Some basic types that make some things easier, the Exim configuration
  settings, and the store functions. */
  
@@ -280,7 +280,7 @@ Last-Update: 2022-12-19
  #include "store.h"
  
  
-@@ -164,10 +165,13 @@ extern const uschar *headers_charset;  /
+@@ -175,10 +176,13 @@ extern const uschar *headers_charset;  /
  extern header_line *header_last;       /* Final header */
  extern header_line *header_list;       /* First header */
  extern BOOL    host_checking;          /* Set when checking a host */
@@ -293,8 +293,8 @@ Last-Update: 2022-12-19
  extern uschar *received_protocol;      /* Name of incoming protocol */
  extern int     recipients_count;       /* Number of recipients */
  extern recipient_item *recipients_list;/* List of recipient addresses */
- extern unsigned char *sender_address;  /* Sender address */
-@@ -234,6 +238,8 @@ extern uschar * string_copy_taint_functi
+ extern const unsigned char *sender_address;   /* Sender address */
+@@ -245,6 +249,8 @@ extern uschar * string_copy_taint_functi
  extern pid_t    child_open_exim_function(int *, const uschar *);
  extern pid_t    child_open_exim2_function(int *, uschar *, uschar *, const uschar *);
  extern pid_t    child_open_function(uschar **, uschar **, int, int *, int *, BOOL, const uschar *);
@@ -305,7 +305,7 @@ Last-Update: 2022-12-19
  /* End of local_scan.h */
 --- a/src/readconf.c
 +++ b/src/readconf.c
-@@ -210,10 +210,13 @@ static optionlist optionlist_config[] =
+@@ -214,10 +214,13 @@ static optionlist optionlist_config[] =
  #endif
    { "local_from_check",         opt_bool,        {&local_from_check} },
    { "local_from_prefix",        opt_stringptr,   {&local_from_prefix} },
@@ -321,7 +321,7 @@ Last-Update: 2022-12-19
    { "localhost_number",         opt_stringptr,   {&host_number_string} },
 --- a/src/string.c
 +++ b/src/string.c
-@@ -416,10 +416,11 @@ return ss;
+@@ -435,10 +435,11 @@ return ss;
  
  
  
@@ -333,7 +333,7 @@ Last-Update: 2022-12-19
  *************************************************/
  
  /*
-@@ -461,10 +462,11 @@ Returns:    copy of string in new store
+@@ -480,10 +481,11 @@ Returns:    copy of string in new store
  uschar *
  string_copyn_function(const uschar * s, int n)
  {
index 0e981f807260532eb9fee431e35c8d8b5f4e9e7e..974805253e60660365f94473b8b7abdd57786653 100755 (executable)
--- a/branch.sh
+++ b/branch.sh
@@ -3,7 +3,8 @@ set -e
 url=git://git.exim.org/exim.git
 package=exim
 tag=exim-4.97
-branch=exim-4.97+fixes
+#branch=exim-4.97+fixes
+branch=master
 out=$package-git.patch
 repo=$package.git
 
index 8b175315d6050b495c08f99ca209c8ca97fb28c1..01caaf5edefd499818fc4ecb435c6ec1ebaa9416 100644 (file)
--- a/exim.spec
+++ b/exim.spec
@@ -23,7 +23,7 @@ Summary(pl.UTF-8):    Agent Transferu Poczty Uniwersytetu w Cambridge
 Summary(pt_BR.UTF-8):  Servidor de correio eletrônico exim
 Name:          exim
 Version:       4.97
-Release:       1
+Release:       2
 Epoch:         2
 License:       GPL v2+
 Group:         Networking/Daemons/SMTP
@@ -49,7 +49,7 @@ Source15:     %{name}4-smtp.pamd
 Source16:      %{name}on.png
 # sh branch.sh
 Patch100:      %{name}-git.patch
-# Patch100-md5:        f36d745a58ec727a6b55c967020dc4c3
+# Patch100-md5:        84f450d2caead32eb5b3dfc4bfc6b063
 Patch0:                %{name}4-EDITME.patch
 Patch1:                %{name}4-monitor-EDITME.patch
 Patch2:                %{name}4-cflags.patch
@@ -176,7 +176,7 @@ Pliki nagłówkowe dla Exima.
 
 %prep
 %setup -q -a1 -a7
-#%patch100 -p2
+%patch100 -p2
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
This page took 0.076028 seconds and 4 git commands to generate.