]> git.pld-linux.org Git - packages/exim.git/blobdiff - exim.spec
- rel 9; fixes pipe transport bug (#2257)
[packages/exim.git] / exim.spec
index a115a178d185e1dc1ae6b47cea6286cc2eb9c436..c9c2046ab68518fda624f84d7132d6fc94f212d6 100644 (file)
--- a/exim.spec
+++ b/exim.spec
 %bcond_without srs     # without srs support
 %bcond_without dynamic # dynamic modules
 %bcond_without hiredis # without redis
+# opendmarc.spec not ready, so off by default
+%bcond_with    dmarc   # DMARC support
+%bcond_without lmdb    # LMDB support
 
 %if "%{pld_release}" == "ac"
 # hiredis build segfaults on ac-alpha
 %undefine      with_hiredis
 %endif
 
+%include       /usr/lib/rpm/macros.perl
 Summary:       University of Cambridge Mail Transfer Agent
 Summary(pl.UTF-8):     Agent Transferu Poczty Uniwersytetu w Cambridge
 Summary(pt_BR.UTF-8):  Servidor de correio eletrônico exim
 Name:          exim
-Version:       4.86
-Release:       10
+Version:       4.90.1
+Release:       9
 Epoch:         2
 License:       GPL
 Group:         Networking/Daemons/SMTP
 Source0:       ftp://ftp.exim.org/pub/exim/exim4/%{name}-%{version}.tar.bz2
-# Source0-md5: 797f248ef3e0c0e2f178e915f88fc4e9
+# Source0-md5: 4b909bf15acfd59ef65ded43d7f38820
 Source1:       ftp://ftp.exim.org/pub/exim/exim4/%{name}-html-%{version}.tar.bz2
-# Source1-md5: 64eae24e1f268fa843a9de77e1c4009a
+# Source1-md5: 4337888fc994f878c904f3e4a2defa68
 Source2:       %{name}.init
 Source3:       %{name}.cron.db
 Source4:       %{name}4.conf
@@ -45,8 +49,9 @@ Source14:     ftp://ftp.exim.org/pub/exim/exim4/old/config.samples.tar.bz2
 # Source14-md5:        4b93321938a800caa6127c48ad60a42b
 Source15:      %{name}4-smtp.pamd
 Source16:      %{name}on.png
-# git log -p exim-4_86..exim-4_86+fixes --reverse -- . ":(exclude)doc/doc-*" ":(exclude)test" ":(exclude).*" > exim-git.patch
+# sh branch.sh
 Patch100:      %{name}-git.patch
+# Patch100-md5:        c0744dfe374125111df6b039a210b9fc
 Patch0:                %{name}4-EDITME.patch
 Patch1:                %{name}4-monitor-EDITME.patch
 Patch2:                %{name}4-cflags.patch
@@ -54,18 +59,22 @@ Patch3:             exim-defs.patch
 Patch4:                %{name}4-Makefile-Default.patch
 # http://marc.merlins.org/linux/exim/files/sa-exim-cvs/localscan_dlopen_exim_4.20_or_better.patch
 Patch5:                localscan_dlopen_%{name}_4.20_or_better.patch
-Patch6:                exim-dkim.patch
+
 Patch8:                %{name}-spam-timeout.patch
-Patch9:                %{name}-callout-address.patch
+
 Patch10:       %{name}-force-sigalrm.patch
 
 Patch20:       %{name}4-disableSSLv3.patch
 URL:           http://www.exim.org/
 %{?with_sasl:BuildRequires:    cyrus-sasl-devel >= 2.1.0}
 BuildRequires: db-devel
+%{?with_dmarc:BuildRequires:   opendmarc-devel}
 %{?with_hiredis:BuildRequires: hiredis-devel}
+BuildRequires: libidn-devel
+BuildRequires: libidn2-devel
 %{?with_spf:BuildRequires:     libspf2-devel >= 1.2.5-2}
 %{?with_srs:BuildRequires:     libsrs_alt-devel >= 1.0}
+%{?with_lmdb:BuildRequires:    lmdb-devel}
 %{?with_mysql:BuildRequires:   mysql-devel}
 %{?with_ldap:BuildRequires:    openldap-devel >= 2.3.0}
 BuildRequires: openssl-devel >= 0.9.7d
@@ -75,6 +84,7 @@ BuildRequires:        perl-devel >= 1:5.6.0
 %{?with_pgsql:BuildRequires:   postgresql-devel}
 BuildRequires: readline-devel
 BuildRequires: rpm >= 4.4.9-56
+BuildRequires: rpm-perlprov >= 4.1-13
 BuildRequires: rpmbuild(macros) >= 1.268
 %{?with_sqlite:BuildRequires:  sqlite3-devel}
 %{?with_whoson:BuildRequires:  whoson-devel}
@@ -176,10 +186,9 @@ Pliki nagłówkowe dla Exima.
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-%patch6 -p2
 
 %patch8 -p1
-%patch9 -p2
+
 %patch10 -p1
 
 install %{SOURCE4} exim4.conf
@@ -197,8 +206,16 @@ X11_LD_LIB=%{_prefix}/X11R6/%{_lib}
 EXPERIMENTAL_DANE=yes
 EXPERIMENTAL_DCC=yes
 EXPERIMENTAL_PRDR=yes
-EXPERIMENTAL_EVENT=yes
-EXPERIMENTAL_PROXY=yes
+EXPERIMENTAL_DSN_INFO=yes
+EXPERIMENTAL_QUEUEFILE=yes
+SUPPORT_I18N=yes
+SUPPORT_I18N_2008=yes
+LDFLAGS+= -lidn -lidn2
+SUPPORT_PROXY=yes
+%if %{with dmarc}
+EXPERIMENTAL_DMARC=yes
+LOOKUP_LIBS+=-lopendmarc
+%endif
 %if %{with spf}
 EXPERIMENTAL_SPF=yes
 LOOKUP_LIBS+=-lspf2
@@ -208,7 +225,7 @@ EXPERIMENTAL_SRS=yes
 LOOKUP_LIBS+=-lsrs_alt
 %endif
 %if %{with hiredis}
-EXPERIMENTAL_REDIS=yes
+LOOKUP_REDIS=yes
 LOOKUP_LIBS+=-lhiredis
 %endif
 %if %{with mysql}
@@ -255,6 +272,10 @@ LOOKUP_LDAP_LIBS=-lldap -llber
 # for static
 LOOKUP_LIBS+=-lldap -llber
 %endif
+%if %{with lmdb}
+EXPERIMENTAL_LMDB=yes
+LOOKUP_LIBS+=-llmdb
+%endif
 EOF
 
 # have to be after Local/Makefile-Linux creation
This page took 0.075383 seconds and 4 git commands to generate.