]> git.pld-linux.org Git - packages/exim.git/blobdiff - exim.spec
Rel 14; fix segfault in srs
[packages/exim.git] / exim.spec
index eb756185fe1245e675cdc2c73f975f93807d6dc5..e3554c7d5f96516e50aec246e0918086fc52a58d 100644 (file)
--- a/exim.spec
+++ b/exim.spec
@@ -7,8 +7,7 @@
 %bcond_without sasl    # without SASL
 %bcond_without ldap    # without LDAP support
 %bcond_without spf     # without spf support
-%bcond_without srs     # without srs support
-%bcond_without dynamic # dynamic modules
+%bcond_with    dynamic # dynamic modules
 %bcond_without hiredis # without redis
 # opendmarc.spec not ready, so off by default
 %bcond_with    dmarc   # DMARC support
 %undefine      with_hiredis
 %endif
 
-%include       /usr/lib/rpm/macros.perl
 Summary:       University of Cambridge Mail Transfer Agent
 Summary(pl.UTF-8):     Agent Transferu Poczty Uniwersytetu w Cambridge
 Summary(pt_BR.UTF-8):  Servidor de correio eletrônico exim
 Name:          exim
-Version:       4.93
-Release:       4
+Version:       4.97
+Release:       14
 Epoch:         2
-License:       GPL
+License:       GPL v2+
 Group:         Networking/Daemons/SMTP
 Source0:       ftp://ftp.exim.org/pub/exim/exim4/%{name}-%{version}.tar.bz2
-# Source0-md5: d8a9342b2c0f2275717ba1f9fafbc3aa
+# Source0-md5: c970646b913b3a414d5c7a3725da7018
 Source1:       ftp://ftp.exim.org/pub/exim/exim4/%{name}-html-%{version}.tar.bz2
-# Source1-md5: 1985746cb7fbe8141c9f4b7fc6adece3
+# Source1-md5: e1ba08655a1c045384244ecd9129f14d
 Source2:       %{name}.init
 Source3:       %{name}.cron.db
 Source4:       %{name}4.conf
@@ -51,33 +49,35 @@ Source15:   %{name}4-smtp.pamd
 Source16:      %{name}on.png
 # sh branch.sh
 Patch100:      %{name}-git.patch
-# Patch100-md5:        5abc56d6820abeb3c6de426a6cbd0616
+# Patch100-md5:        eef923600fc1e8d56d0d6fa23ca28887
 Patch0:                %{name}4-EDITME.patch
 Patch1:                %{name}4-monitor-EDITME.patch
 Patch2:                %{name}4-cflags.patch
-Patch3:                exim-defs.patch
+Patch3:                %{name}-defs.patch
 Patch4:                %{name}4-Makefile-Default.patch
-# http://marc.merlins.org/linux/exim/files/sa-exim-cvs/localscan_dlopen_exim_4.20_or_better.patch
-Patch5:                localscan_dlopen_%{name}_4.20_or_better.patch
-
+# dlopen patch from debian
+Patch5:                90_localscan_dlopen.dpatch
+# local fixes for debian patch
+Patch6:                90_localscan_dlopen-fixes.dpatch
+Patch7:                linelength-show.patch
 Patch8:                %{name}-spam-timeout.patch
-
-Patch20:       %{name}4-disableSSLv3.patch
+Patch9:                autoreply-return-path.patch
+Patch10:        unofficial-hotfix.patch
 URL:           http://www.exim.org/
 %{?with_sasl:BuildRequires:    cyrus-sasl-devel >= 2.1.0}
 BuildRequires: db-devel
-%{?with_dmarc:BuildRequires:   opendmarc-devel}
 %{?with_hiredis:BuildRequires: hiredis-devel}
 BuildRequires: libidn-devel
 BuildRequires: libidn2-devel
 %{?with_spf:BuildRequires:     libspf2-devel >= 1.2.5-2}
-%{?with_srs:BuildRequires:     libsrs_alt-devel >= 1.0}
 %{?with_lmdb:BuildRequires:    lmdb-devel}
 %{?with_mysql:BuildRequires:   mysql-devel}
+%{?with_dmarc:BuildRequires:   opendmarc-devel}
 %{?with_ldap:BuildRequires:    openldap-devel >= 2.3.0}
 BuildRequires: openssl-devel >= 0.9.7d
 BuildRequires: pam-devel
-BuildRequires: pcre-devel
+BuildRequires: pcre2-8-devel
+BuildRequires: perl-File-FcntlLock
 BuildRequires: perl-devel >= 1:5.6.0
 %{?with_pgsql:BuildRequires:   postgresql-devel}
 BuildRequires: readline-devel
@@ -183,12 +183,14 @@ Pliki nagłówkowe dla Exima.
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-
+%patch6 -p1
+%patch7 -p1
 %patch8 -p1
+%patch9 -p2
+%patch10 -p2
 
 install %{SOURCE4} exim4.conf
 install %{SOURCE14} doc/config.samples.tar.bz2
-%patch20 -p1
 install -d Local
 cat << 'EOF' >> Local/Makefile-Linux
 CC=%{__cc}
@@ -203,9 +205,11 @@ EXPERIMENTAL_DCC=yes
 EXPERIMENTAL_PRDR=yes
 EXPERIMENTAL_DSN_INFO=yes
 EXPERIMENTAL_QUEUEFILE=yes
+EXPERIMENTAL_XCLIENT=yes
 SUPPORT_DANE=yes
 SUPPORT_I18N=yes
 SUPPORT_I18N_2008=yes
+SUPPORT_MOVE_FROZEN_MESSAGES=yes
 LDFLAGS+= -lidn -lidn2
 SUPPORT_PROXY=yes
 %if %{with dmarc}
@@ -216,10 +220,6 @@ LOOKUP_LIBS+=-lopendmarc
 SUPPORT_SPF=yes
 LOOKUP_LIBS+=-lspf2
 %endif
-%if %{with srs}
-EXPERIMENTAL_SRS=yes
-LOOKUP_LIBS+=-lsrs_alt
-%endif
 %if %{with hiredis}
 LOOKUP_REDIS=yes
 LOOKUP_LIBS+=-lhiredis
@@ -280,7 +280,7 @@ cp -f src/EDITME Local/Makefile
 cp -f exim_monitor/EDITME Local/eximon.conf
 
 %build
-%{__make} -e -j1 \
+%{__make} -e \
        FULLECHO=''
 
 %install
@@ -294,7 +294,7 @@ install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
 
 install build-Linux-*/exim{,_fixdb,_tidydb,_dbmbuild,on.bin,_dumpdb,_lock} \
        build-Linux-*/exi{cyclog,next,what} %{SOURCE10} \
-       build-Linux-*/{exigrep,exiqgrep,exipick,eximstats,exiqsumm,convert4r4} \
+       build-Linux-*/{exigrep,exiqgrep,exipick,eximstats,exim_msgdate,exiqsumm,convert4r4} \
        util/unknownuser.sh \
        $RPM_BUILD_ROOT%{_bindir}
 install build-Linux-*/eximon.bin $RPM_BUILD_ROOT%{_bindir}
@@ -365,14 +365,13 @@ fi
 %dir %{_sysconfdir}/mail
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/exim.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/aliases
-%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/exim
+%attr(754,root,root) /etc/cron.daily/exim.cron.db
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/exim
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/smtp
 %attr(754,root,root) /etc/rc.d/init.d/exim
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.smtp
+%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/exim
 %attr(4755,root,root) %{_bindir}/exim
-%attr(770,root,exim) %dir %{_var}/spool/exim
-%attr(750,exim,exim) %dir %{_var}/spool/exim/db
-%attr(700,exim,root) %dir %{_var}/spool/exim/input
-%attr(750,exim,root) %dir %{_var}/spool/exim/msglog
 %attr(755,root,root) %{_bindir}/exim_*
 %attr(755,root,root) %{_bindir}/exinext
 %attr(755,root,root) %{_bindir}/exiwhat
@@ -391,12 +390,13 @@ fi
 %attr(755,root,root) %{_sbindir}/runq
 %attr(755,root,root) %{_sbindir}/sendmail
 %attr(755,root,root) /usr/lib/sendmail
-%attr(754,root,root) /etc/cron.daily/exim.cron.db
 %attr(750,exim,root) %dir %{_var}/log/exim
 %attr(750,exim,root) %dir %{_var}/log/archive/exim
 %attr(640,exim,root) %ghost %{_var}/log/exim/*
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/smtp
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.smtp
+%attr(770,root,exim) %dir %{_var}/spool/exim
+%attr(750,exim,exim) %dir %{_var}/spool/exim/db
+%attr(700,exim,root) %dir %{_var}/spool/exim/input
+%attr(750,exim,root) %dir %{_var}/spool/exim/msglog
 %if %{with dynamic}
 %dir %{_libdir}/%{name}
 %dir %{_libdir}/%{name}/modules
@@ -405,7 +405,14 @@ fi
 %{?with_sqlite:%attr(755,root,root) %{_libdir}/%{name}/modules/sqlite.so}
 %{?with_whoson:%attr(755,root,root) %{_libdir}/%{name}/modules/whoson.so}
 %endif
-%{_mandir}/man8/*
+%{_mandir}/man8/exicyclog.8*
+%{_mandir}/man8/exigrep.8*
+%{_mandir}/man8/exim.8*
+%{_mandir}/man8/exim_*.8*
+%{_mandir}/man8/eximstats.8*
+%{_mandir}/man8/exinext.8*
+%{_mandir}/man8/exiqsumm.8*
+%{_mandir}/man8/exiwhat.8*
 
 %files X11
 %defattr(644,root,root,755)
@@ -413,6 +420,7 @@ fi
 %attr(755,root,root) %{_bindir}/eximon.bin
 %{_desktopdir}/eximon.desktop
 %{_pixmapsdir}/eximon.png
+%{_mandir}/man8/eximon.8*
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.11878 seconds and 4 git commands to generate.