]> git.pld-linux.org Git - packages/exact-image.git/commitdiff
- up to 1.0.1 auto/th/exact-image-1.0.1-1
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 3 Sep 2018 11:50:45 +0000 (13:50 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 3 Sep 2018 11:50:45 +0000 (13:50 +0200)
exact-image-ub.patch
exact-image.spec
swig.patch [deleted file]

index 82bc6470097a1c212728f42f8a961ecf15a64299..1a6ba3e5cac0d15c7224b966d64e6dabb6878995 100644 (file)
@@ -28,7 +28,7 @@
 +      if (table[i].maximum) maximum = table[i].maximum;
        if (table[i].trans[0]) {
        for (raw_color = j=0; j < 12; j++)
--        cam_xyz[0][j] = table[i].trans[j] / 10000.0;
+-        ((double *)cam_xyz)[j] = table[i].trans[j] / 10000.0;
 +        cam_xyz[j / 3][j % 3] = table[i].trans[j] / 10000.0;
        cam_xyz_coeff (rgb_cam, cam_xyz);
        }
index b064e484dc98ce89a1e6ea3fbbf7f07df70f5a63..f438e0d00ac8e08ae74334bf59ad54444072aa3a 100644 (file)
@@ -5,7 +5,7 @@
 %bcond_without gif     # GIF support
 %bcond_without lua     # Lua API
 %bcond_without perl    # Perl API
-%bcond_without php     # PHP API
+%bcond_with    php     # PHP API
 %bcond_without python  # Python API
 %bcond_with    ruby    # Ruby API [still not finished as of 0.9.2]
 
 Summary:       A fast, modern and generic image processing library
 Summary(pl.UTF-8):     Szybka, nowoczesna i ogólna biblioteka do przetwarzania obrazu
 Name:          exact-image
-Version:       0.9.2
-Release:       3
+Version:       1.0.1
+Release:       1
 License:       GPL v2
 Group:         Applications/Graphics
 Source0:       http://dl.exactcode.de/oss/exact-image/%{name}-%{version}.tar.bz2
-# Source0-md5: bb9c8be82a4b5126be0224529ea7c4c7
+# Source0-md5: 1f03ef559ca81cf7a1651a72fd9fe98f
 Patch0:                %{name}-libs.patch
 Patch1:                %{name}-ub.patch
 Patch2:                %{name}-make.patch
 Patch3:                %{name}-evas.patch
 Patch4:                %{name}-install.patch
-Patch5:                swig.patch
 URL:           http://www.exactcode.de/site/open_source/exactimage/
 BuildRequires: OpenEXR-devel >= 1.2.0
 BuildRequires: agg-devel >= 2.3
@@ -119,7 +118,6 @@ API ExactImage dla Pythona.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-%patch5 -p1
 
 %if %{with php}
 %if "%(php%{?php_suffix}-config --version)" >= "7.0"
diff --git a/swig.patch b/swig.patch
deleted file mode 100644 (file)
index dcf9fe6..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- exact-image-0.8.9/api/api-swig.hh~ 2009-03-19 14:00:11.000000000 +0100
-+++ exact-image-0.8.9/api/api-swig.hh  2015-12-27 13:53:37.704789844 +0100
-@@ -22,7 +22,7 @@
- %include "cstring.i"
- %include "std_string.i"
--# manually include it, otherwise SWIG will not source it
-+/* manually include it, otherwise SWIG will not source it */
- %include "config.h"
- %{
This page took 0.051294 seconds and 4 git commands to generate.