]> git.pld-linux.org Git - packages/exact-image.git/blame_incremental - exact-image.spec
- perl req/prov fix
[packages/exact-image.git] / exact-image.spec
... / ...
CommitLineData
1# TODO: ruby (when ready)
2#
3# Conditional build:
4%bcond_without evas # Edisplay support
5%bcond_without gif # GIF support
6%bcond_without lua # Lua API
7%bcond_without perl # Perl API
8%bcond_without php # PHP API
9%bcond_without python # Python API
10%bcond_with ruby # Ruby API [still not finished as of 0.9.2]
11
12%define php_name php%{?php_suffix}
13%include /usr/lib/rpm/macros.perl
14Summary: A fast, modern and generic image processing library
15Summary(pl.UTF-8): Szybka, nowoczesna i ogólna biblioteka do przetwarzania obrazu
16Name: exact-image
17Version: 0.9.2
18Release: 3
19License: GPL v2
20Group: Applications/Graphics
21Source0: http://dl.exactcode.de/oss/exact-image/%{name}-%{version}.tar.bz2
22# Source0-md5: bb9c8be82a4b5126be0224529ea7c4c7
23Patch0: %{name}-libs.patch
24Patch1: %{name}-ub.patch
25Patch2: %{name}-make.patch
26Patch3: %{name}-evas.patch
27Patch4: %{name}-install.patch
28Patch5: swig.patch
29URL: http://www.exactcode.de/site/open_source/exactimage/
30BuildRequires: OpenEXR-devel >= 1.2.0
31BuildRequires: agg-devel >= 2.3
32%{?with_evas:BuildRequires: evas-devel >= 0.9.9}
33BuildRequires: expat-devel >= 1.95
34# pkgconfig(freetype) >= 9.5.0
35BuildRequires: freetype-devel >= 2.1.6
36%{?with_gif:BuildRequires: giflib-devel >= 5.1}
37BuildRequires: jasper-devel
38BuildRequires: lcms-devel >= 1.10
39BuildRequires: libjpeg-devel
40BuildRequires: libpng-devel >= 2:1.5
41BuildRequires: libstdc++-devel
42BuildRequires: libtiff-devel
43%{?with_lua:BuildRequires: lua51-devel >= 5.1}
44BuildRequires: perl-devel >= 1:5.8.0
45%{?with_php:BuildRequires: %{php_name}-devel >= 5.2.0}
46BuildRequires: pkgconfig
47%{?with_python:BuildRequires: python-devel >= 1:2.5.0}
48BuildRequires: rpm-perlprov
49BuildRequires: rpm-pythonprov
50BuildRequires: rpmbuild(macros) >= 1.219
51%{?with_ruby:BuildRequires: ruby-devel >= 1.8.5}
52BuildRequires: sed >= 4.0
53%{?with_perl:BuildRequires: swig-perl >= 1.3.32}
54%{?with_php:BuildRequires: swig-php >= 3.0.12}
55%{?with_python:BuildRequires: swig-python >= 1.3.32}
56BuildRequires: xorg-lib-libX11-devel >= 1.3
57BuildRequires: zlib-devel
58BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60%description
61A fast, modern and generic (template based) C++ image processing
62library, alternative to ImageMagick.
63
64%description -l pl.UTF-8
65Szybka, nowoczesna i ogólna (oparta na szablonach) biblioteka C++
66do przetwarzania obrazu, będąca alternatywą dla biblioteki
67ImageMagick.
68
69%package -n lua-ExactImage
70Summary: ExactImage API for Lua language
71Summary(pl.UTF-8): API ExactImage dla języka Lua
72Group: Development/Languages
73Requires: lua51
74
75%description -n lua-ExactImage
76ExactImage API for Lua language.
77
78%description -n lua-ExactImage -l pl.UTF-8
79API ExactImage dla języka Lua.
80
81%package -n perl-ExactImage
82Summary: ExactImage API for Perl
83Summary(pl.UTF-8): API ExactImage dla Perla
84Group: Development/Languages/Perl
85
86%description -n perl-ExactImage
87ExactImage API for Perl.
88
89%description -n perl-ExactImage -l pl.UTF-8
90API ExactImage dla Perla.
91
92%package -n %{php_name}-ExactImage
93Summary: ExactImage API for PHP
94Summary(pl.UTF-8): API ExactImage dla PHP
95Group: Development/Languages/Perl
96%{?requires_php_extension}
97
98%description -n %{php_name}-ExactImage
99ExactImage API for PHP.
100
101%description -n %{php_name}-ExactImage -l pl.UTF-8
102API ExactImage dla PHP.
103
104%package -n python-ExactImage
105Summary: ExactImage API for Python
106Summary(pl.UTF-8): API ExactImage dla Pythona
107Group: Development/Languages/Python
108
109%description -n python-ExactImage
110ExactImage API for Python.
111
112%description -n python-ExactImage -l pl.UTF-8
113API ExactImage dla Pythona.
114
115%prep
116%setup -q
117%patch0 -p1
118%patch1 -p1
119%patch2 -p1
120%patch3 -p1
121%patch4 -p1
122%patch5 -p1
123
124%if %{with php}
125%if "%(php%{?php_suffix}-config --version)" >= "7.0"
126%{__sed} -i -e 's/-php5/-php7/' api/php/Makefile
127%endif
128%endif
129
130%build
131./configure \
132 --prefix=%{_prefix} \
133 %{!?with_evas:--without-evas} \
134 %{!?with_gif:--without-libungif} \
135 %{!?with_lua:--without-lua} \
136 %{!?with_perl:--without-perl} \
137 %{!?with_php:--without-php} \
138 %{!?with_python:--without-python}
139
140%{__make} \
141 CC="%{__cc}" \
142 CXX="%{__cxx}" \
143 CFLAGS="%{rpmcflags}" \
144 CXXFLAGS="%{rpmcflags} -std=gnu++98" \
145 Q=
146
147%install
148rm -rf $RPM_BUILD_ROOT
149
150%{__make} install \
151 DESTDIR=$RPM_BUILD_ROOT \
152 PERL_INSTALLDIR=%{perl_vendorarch} \
153 PHP_INSTALLDIR=%{php_extensiondir} \
154 PYTHON_LIBDIR=%{py_sitedir} \
155 api/lua/libdir=%{_libdir}/lua \
156 Q=
157
158%if %{with python}
159%py_comp $RPM_BUILD_ROOT%{py_sitedir}
160%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
161%py_postclean
162%endif
163
164%clean
165rm -rf $RPM_BUILD_ROOT
166
167%files
168%defattr(644,root,root,755)
169%doc README TODO
170%attr(755,root,root) %{_bindir}/bardecode
171%attr(755,root,root) %{_bindir}/e2mtiff
172%attr(755,root,root) %{_bindir}/econvert
173%attr(755,root,root) %{_bindir}/edentify
174%{?with_evas:%attr(755,root,root) %{_bindir}/edisplay}
175%attr(755,root,root) %{_bindir}/empty-page
176%attr(755,root,root) %{_bindir}/hocr2pdf
177%attr(755,root,root) %{_bindir}/optimize2bw
178
179%if %{with lua}
180%files -n lua-ExactImage
181%defattr(644,root,root,755)
182%attr(755,root,root) %{_libdir}/lua/ExactImage.so
183%endif
184
185%if %{with perl}
186%files -n perl-ExactImage
187%defattr(644,root,root,755)
188%attr(755,root,root) %{perl_vendorarch}/ExactImage.so
189%{perl_vendorarch}/ExactImage.pm
190%endif
191
192%if %{with php}
193%files -n %{php_name}-ExactImage
194%defattr(644,root,root,755)
195%attr(755,root,root) %{php_extensiondir}/ExactImage.so
196%{php_extensiondir}/ExactImage.php
197%endif
198
199%if %{with python}
200%files -n python-ExactImage
201%defattr(644,root,root,755)
202%attr(755,root,root) %{py_sitedir}/_ExactImage.so
203%{py_sitedir}/ExactImage.py[co]
204%endif
This page took 0.084547 seconds and 4 git commands to generate.