]> git.pld-linux.org Git - packages/ex.git/blob - ex.spec
- new
[packages/ex.git] / ex.spec
1 Summary:        OSSP ex - Exception Handling
2 Summary(pl):    OSSP ex - biblioteka obs³ugi wyj±tków
3 Name:           ex
4 Version:        1.0.4
5 Release:        0.1
6 License:        distributable (see README)
7 Group:          Libraries
8 Source0:        ftp://ftp.ossp.org/pkg/lib/%{name}/%{name}-%{version}.tar.gz
9 # Source0-md5:  9054e4325e5e182b2105566d9d02732d        
10 URL:            http://www.ossp.org/pkg/lib/%{name}/
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  libtool
14 Requires(post,postun):  /sbin/ldconfig
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 OSSP ex is a small ISO-C++ style exception handling library for use in
19 the ISO-C language. It allows you to use the paradigm of throwing and
20 catching exceptions in order to reduce the amount of error handling
21 code without making your program less robust.
22
23 This is achieved by directly transferring exceptional return codes
24 (and the program control flow) from the location where the exception
25 is raised (throw point) to the location where it is handled (catch
26 point) -- usually from a deeply nested sub-routine to a parent
27 routine. All intermediate routines no longer have to make sure that
28 the exceptional return codes from sub-routines are correctly passed
29 back to the parent.
30
31 The OSSP ex facility also provides advanced exception handling
32 features like shielded and deferred exceptions. Additionally, OSSP ex
33 allows you to choose the used underlying machine context switching
34 facility and optionally support multi-threading environments by
35 allowing you to store the exception catching stack in a thread-safe
36 way.
37
38 #%%description -l pl
39
40 %package devel
41 Summary:        OSSP sio - Exception Handling - header files and development libraries
42 Summary(pl):    OSSP sio - biblioteka obs³ugi wyj±tków - pliki nag³ówkowe i biblioteki dla deweloperów
43 Group:          Development/Libraries
44 Requires:       %{name} = %{epoch}:%{version}-%{release}
45
46 %description devel
47 OSSP ex - Exception Handling - header files and development
48 libraries.
49
50 %description devel -l pl
51 OSSP ex - biblioteka obs³ugi wyj±tków - pliki nag³ówkowe i biblioteki
52 dla deweloperów.
53
54 %package static
55 Summary:        OSSP sio - Exception Handling - static libraries
56 Summary(pl):    OSSP sio - biblioteka obs³ugi wyj±tków - biblioteki statyczne
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
59
60 %description static
61 OSSP ex - Exception Handling - static libraries.
62
63 %description static -l pl
64 OSSP ex - biblioteka obs³ugi wyj±tków - biblioteki statyczne.
65
66 %prep
67 %setup -q
68 %build
69 mv -f aclocal.m4 acinclude.m4
70 %{__libtoolize}
71 %{__aclocal}
72 %{__autoconf}
73
74 %configure
75 %{__make}
76 %{__make} check
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 %{__make} install \
82         DESTDIR=$RPM_BUILD_ROOT
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post -p /sbin/ldconfig
88
89 %postun -p /sbin/ldconfig
90
91 %files
92 %defattr(644,root,root,755)
93 %doc AUTHORS ChangeLog README THANKS
94 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
95
96 %files devel
97 %defattr(644,root,root,755)
98 %attr(755,root,root) %{_bindir}/*
99 %attr(755,root,root) %{_libdir}/lib*.so
100 %{_libdir}/lib*.la
101 %{_includedir}/*
102 %{_mandir}/man3/*
103
104 %files static
105 %defattr(644,root,root,755)
106 %attr(755,root,root) %{_libdir}/lib*.a
This page took 0.120534 seconds and 3 git commands to generate.