]> git.pld-linux.org Git - packages/ex.git/blob - ex.spec
- up to 1.0.5
[packages/ex.git] / ex.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs # don't build static libraries
4 %bcond_without  tests # don't perform "make check"
5 #
6 Summary:        OSSP ex - Exception Handling
7 Summary(pl):    OSSP ex - biblioteka obs³ugi wyj±tków
8 Name:           ex
9 Version:        1.0.5
10 Release:        0.1
11 Epoch:          0
12 License:        distributable (see README)
13 Group:          Libraries
14 Source0:        ftp://ftp.ossp.org/pkg/lib/ex/%{name}-%{version}.tar.gz
15 # Source0-md5:  419f0915cb578f9eb3bfc483bc49f066
16 Patch0:         %{name}-libs.patch
17 URL:            http://www.ossp.org/pkg/lib/ex/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  libtool
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 OSSP ex is a small ISO-C++ style exception handling library for use in
25 the ISO-C language. It allows you to use the paradigm of throwing and
26 catching exceptions in order to reduce the amount of error handling
27 code without making your program less robust.
28
29 This is achieved by directly transferring exceptional return codes
30 (and the program control flow) from the location where the exception
31 is raised (throw point) to the location where it is handled (catch
32 point) -- usually from a deeply nested sub-routine to a parent
33 routine. All intermediate routines no longer have to make sure that
34 the exceptional return codes from sub-routines are correctly passed
35 back to the parent.
36
37 The OSSP ex facility also provides advanced exception handling
38 features like shielded and deferred exceptions. Additionally, OSSP ex
39 allows you to choose the used underlying machine context switching
40 facility and optionally support multi-threading environments by
41 allowing you to store the exception catching stack in a thread-safe
42 way.
43
44 %description -l pl
45 OSSP ex to ma³a biblioteka do obs³ugi wyj±tków w stylu ISO-C++
46 przeznaczona do u¿ywania w jêzyku ISO-C. Umo¿liwia korzystanie z
47 paradygmatu rzucania i wy³apywania wyj±tków w celi ograniczenia
48 ilo¶ci kodu obs³uguj±cego b³êdy bez czynienia programu ubo¿szym.
49
50 Zosta³o to osi±gniête poprzez bezpo¶rednie przesy³anie wyj±tkowych
51 kodów powrotu (i przep³ywu sterowania programu) z miejsca gdzie
52 wyst±pi³ wyj±tek (miejsca rzucenia) do miejsca jego obs³ugi (miejsca
53 wy³apania) - zwykle z g³êboko zagnie¿d¿onej podprocedury do procedury
54 nadrzêdnej. Po¶rednie procedury nie musz± siê ju¿ upewniaæ, ¿e
55 wyj±tkowe kody powrotu z podprocedur s± poprawnie przekazywane do z
56 powrotem do rodzica.
57
58 U³atwienia OSSP ex daj± tak¿e zaawansowane mo¿liwo¶ci obs³ugi
59 wyj±tków, takie jak os³aniane i opó¼nione wyj±tki. Ponadto OSSP ex
60 umo¿liwia wybór udogodnieñ maszyny prze³±czaj±cej kontekst oraz
61 opcjonaln± obs³ugê ¶rodowisk wielow±tkowych poprzez umo¿liwienie
62 przechowywania stosu wy³apywania wyj±tków w sposób bezpieczny dla
63 w±tków.
64
65 %package devel
66 Summary:        OSSP ex - Exception Handling - header files and development libraries
67 Summary(pl):    OSSP ex - biblioteka obs³ugi wyj±tków - pliki nag³ówkowe i biblioteki dla deweloperów
68 Group:          Development/Libraries
69 Requires:       %{name} = %{epoch}:%{version}-%{release}
70
71 %description devel
72 OSSP ex - Exception Handling - header files and development
73 libraries.
74
75 %description devel -l pl
76 OSSP ex - biblioteka obs³ugi wyj±tków - pliki nag³ówkowe i biblioteki
77 dla deweloperów.
78
79 %package static
80 Summary:        OSSP ex - Exception Handling - static libraries
81 Summary(pl):    OSSP ex - biblioteka obs³ugi wyj±tków - biblioteki statyczne
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
84
85 %description static
86 OSSP ex - Exception Handling - static libraries.
87
88 %description static -l pl
89 OSSP ex - biblioteka obs³ugi wyj±tków - biblioteki statyczne.
90
91 %prep
92 %setup -q
93 %patch0 -p1
94
95 %build
96 mv -f aclocal.m4 acinclude.m4
97 %{__libtoolize}
98 %{__aclocal}
99 %{__autoconf}
100
101 %configure \
102         --enable-static=%{?with_static_libs:yes}%{!?with_static_libs:no}
103 %{__make}
104
105 %{?with_tests:%{__make} check}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post   -p /sbin/ldconfig
117 %postun -p /sbin/ldconfig
118
119 %files
120 %defattr(644,root,root,755)
121 %doc AUTHORS ChangeLog README THANKS
122 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
123
124 %files devel
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_bindir}/*
127 %attr(755,root,root) %{_libdir}/lib*.so
128 %{_libdir}/lib*.la
129 %{_includedir}/*
130 %{_mandir}/man3/*
131
132 %if %{with static_libs}
133 %files static
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{_libdir}/lib*.a
136 %endif
This page took 0.175647 seconds and 3 git commands to generate.