]> git.pld-linux.org Git - packages/ex.git/blob - ex.spec
374ca251c4126569324f886a2e619e245243e043
[packages/ex.git] / ex.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform "make check"
4 #
5 Summary:        OSSP ex - Exception Handling
6 Summary(pl):    OSSP ex - biblioteka obs³ugi wyj±tków
7 Name:           ex
8 Version:        1.0.4
9 Release:        0.2
10 Epoch:          0
11 License:        distributable (see README)
12 Group:          Libraries
13 Source0:        ftp://ftp.ossp.org/pkg/lib/ex/%{name}-%{version}.tar.gz
14 # Source0-md5:  9054e4325e5e182b2105566d9d02732d        
15 Patch0:         %{name}-libs.patch
16 URL:            http://www.ossp.org/pkg/lib/ex/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  libtool
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 OSSP ex is a small ISO-C++ style exception handling library for use in
24 the ISO-C language. It allows you to use the paradigm of throwing and
25 catching exceptions in order to reduce the amount of error handling
26 code without making your program less robust.
27
28 This is achieved by directly transferring exceptional return codes
29 (and the program control flow) from the location where the exception
30 is raised (throw point) to the location where it is handled (catch
31 point) -- usually from a deeply nested sub-routine to a parent
32 routine. All intermediate routines no longer have to make sure that
33 the exceptional return codes from sub-routines are correctly passed
34 back to the parent.
35
36 The OSSP ex facility also provides advanced exception handling
37 features like shielded and deferred exceptions. Additionally, OSSP ex
38 allows you to choose the used underlying machine context switching
39 facility and optionally support multi-threading environments by
40 allowing you to store the exception catching stack in a thread-safe
41 way.
42
43 %description -l pl
44 OSSP ex to ma³a biblioteka do obs³ugi wyj±tków w stylu ISO-C++
45 przeznaczona do u¿ywania w jêzyku ISO-C. Umo¿liwia korzystanie z
46 paradygmatu rzucania i wy³apywania wyj±tków w celi ograniczenia
47 ilo¶ci kodu obs³uguj±cego b³êdy bez czynienia programu ubo¿szym.
48
49 Zosta³o to osi±gniête poprzez bezpo¶rednie przesy³anie wyj±tkowych
50 kodów powrotu (i przep³ywu sterowania programu) z miejsca gdzie
51 wyst±pi³ wyj±tek (miejsca rzucenia) do miejsca jego obs³ugi (miejsca
52 wy³apania) - zwykle z g³êboko zagnie¿d¿onej podprocedury do procedury
53 nadrzêdnej. Po¶rednie procedury nie musz± siê ju¿ upewniaæ, ¿e
54 wyj±tkowe kody powrotu z podprocedur s± poprawnie przekazywane do z
55 powrotem do rodzica.
56
57 U³atwienia OSSP ex daj± tak¿e zaawansowane mo¿liwo¶ci obs³ugi
58 wyj±tków, takie jak os³aniane i opó¼nione wyj±tki. Ponadto OSSP ex
59 umo¿liwia wybór udogodnieñ maszyny prze³±czaj±cej kontekst oraz
60 opcjonaln± obs³ugê ¶rodowisk wielow±tkowych poprzez umo¿liwienie
61 przechowywania stosu wy³apywania wyj±tków w sposób bezpieczny dla
62 w±tków.
63
64 %package devel
65 Summary:        OSSP ex - Exception Handling - header files and development libraries
66 Summary(pl):    OSSP ex - biblioteka obs³ugi wyj±tków - pliki nag³ówkowe i biblioteki dla deweloperów
67 Group:          Development/Libraries
68 Requires:       %{name} = %{epoch}:%{version}-%{release}
69
70 %description devel
71 OSSP ex - Exception Handling - header files and development
72 libraries.
73
74 %description devel -l pl
75 OSSP ex - biblioteka obs³ugi wyj±tków - pliki nag³ówkowe i biblioteki
76 dla deweloperów.
77
78 %package static
79 Summary:        OSSP ex - Exception Handling - static libraries
80 Summary(pl):    OSSP ex - biblioteka obs³ugi wyj±tków - biblioteki statyczne
81 Group:          Development/Libraries
82 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
83
84 %description static
85 OSSP ex - Exception Handling - static libraries.
86
87 %description static -l pl
88 OSSP ex - biblioteka obs³ugi wyj±tków - biblioteki statyczne.
89
90 %prep
91 %setup -q
92 %patch0 -p1
93
94 %build
95 mv -f aclocal.m4 acinclude.m4
96 %{__libtoolize}
97 %{__aclocal}
98 %{__autoconf}
99
100 %configure
101 %{__make}
102
103 %{?with_tests:%{__make} check}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %doc AUTHORS ChangeLog README THANKS
120 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
121
122 %files devel
123 %defattr(644,root,root,755)
124 %attr(755,root,root) %{_bindir}/*
125 %attr(755,root,root) %{_libdir}/lib*.so
126 %{_libdir}/lib*.la
127 %{_includedir}/*
128 %{_mandir}/man3/*
129
130 %files static
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_libdir}/lib*.a
This page took 0.203982 seconds and 3 git commands to generate.