]> git.pld-linux.org Git - packages/ex.git/blob - ex.spec
- Epoch 0 (used in deps)
[packages/ex.git] / ex.spec
1 Summary:        OSSP ex - Exception Handling
2 Summary(pl):    OSSP ex - biblioteka obs³ugi wyj±tków
3 Name:           ex
4 Version:        1.0.4
5 Release:        0.1
6 Epoch:          0
7 License:        distributable (see README)
8 Group:          Libraries
9 Source0:        ftp://ftp.ossp.org/pkg/lib/ex/%{name}-%{version}.tar.gz
10 # Source0-md5:  9054e4325e5e182b2105566d9d02732d        
11 URL:            http://www.ossp.org/pkg/lib/ex/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  libtool
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 OSSP ex is a small ISO-C++ style exception handling library for use in
19 the ISO-C language. It allows you to use the paradigm of throwing and
20 catching exceptions in order to reduce the amount of error handling
21 code without making your program less robust.
22
23 This is achieved by directly transferring exceptional return codes
24 (and the program control flow) from the location where the exception
25 is raised (throw point) to the location where it is handled (catch
26 point) -- usually from a deeply nested sub-routine to a parent
27 routine. All intermediate routines no longer have to make sure that
28 the exceptional return codes from sub-routines are correctly passed
29 back to the parent.
30
31 The OSSP ex facility also provides advanced exception handling
32 features like shielded and deferred exceptions. Additionally, OSSP ex
33 allows you to choose the used underlying machine context switching
34 facility and optionally support multi-threading environments by
35 allowing you to store the exception catching stack in a thread-safe
36 way.
37
38 %description -l pl
39 OSSP ex to ma³a biblioteka do obs³ugi wyj±tków w stylu ISO-C++
40 przeznaczona do u¿ywania w jêzyku ISO-C. Umo¿liwia korzystanie z
41 paradygmatu rzucania i wy³apywania wyj±tków w celi ograniczenia
42 ilo¶ci kodu obs³uguj±cego b³êdy bez czynienia programu ubo¿szym.
43
44 Zosta³o to osi±gniête poprzez bezpo¶rednie przesy³anie wyj±tkowych
45 kodów powrotu (i przep³ywu sterowania programu) z miejsca gdzie
46 wyst±pi³ wyj±tek (miejsca rzucenia) do miejsca jego obs³ugi (miejsca
47 wy³apania) - zwykle z g³êboko zagnie¿d¿onej podprocedury do procedury
48 nadrzêdnej. Po¶rednie procedury nie musz± siê ju¿ upewniaæ, ¿e
49 wyj±tkowe kody powrotu z podprocedur s± poprawnie przekazywane do z
50 powrotem do rodzica.
51
52 U³atwienia OSSP ex daj± tak¿e zaawansowane mo¿liwo¶ci obs³ugi
53 wyj±tków, takie jak os³aniane i opó¼nione wyj±tki. Ponadto OSSP ex
54 umo¿liwia wybór udogodnieñ maszyny prze³±czaj±cej kontekst oraz
55 opcjonaln± obs³ugê ¶rodowisk wielow±tkowych poprzez umo¿liwienie
56 przechowywania stosu wy³apywania wyj±tków w sposób bezpieczny dla
57 w±tków.
58
59 %package devel
60 Summary:        OSSP ex - Exception Handling - header files and development libraries
61 Summary(pl):    OSSP ex - biblioteka obs³ugi wyj±tków - pliki nag³ówkowe i biblioteki dla deweloperów
62 Group:          Development/Libraries
63 Requires:       %{name} = %{epoch}:%{version}-%{release}
64
65 %description devel
66 OSSP ex - Exception Handling - header files and development
67 libraries.
68
69 %description devel -l pl
70 OSSP ex - biblioteka obs³ugi wyj±tków - pliki nag³ówkowe i biblioteki
71 dla deweloperów.
72
73 %package static
74 Summary:        OSSP ex - Exception Handling - static libraries
75 Summary(pl):    OSSP ex - biblioteka obs³ugi wyj±tków - biblioteki statyczne
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
78
79 %description static
80 OSSP ex - Exception Handling - static libraries.
81
82 %description static -l pl
83 OSSP ex - biblioteka obs³ugi wyj±tków - biblioteki statyczne.
84
85 %prep
86 %setup -q
87
88 %build
89 mv -f aclocal.m4 acinclude.m4
90 %{__libtoolize}
91 %{__aclocal}
92 %{__autoconf}
93
94 %configure
95 %{__make}
96 %{__make} check
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post   -p /sbin/ldconfig
108 %postun -p /sbin/ldconfig
109
110 %files
111 %defattr(644,root,root,755)
112 %doc AUTHORS ChangeLog README THANKS
113 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
114
115 %files devel
116 %defattr(644,root,root,755)
117 %attr(755,root,root) %{_bindir}/*
118 %attr(755,root,root) %{_libdir}/lib*.so
119 %{_libdir}/lib*.la
120 %{_includedir}/*
121 %{_mandir}/man3/*
122
123 %files static
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_libdir}/lib*.a
This page took 0.095646 seconds and 3 git commands to generate.