]> git.pld-linux.org Git - packages/ewl.git/blob - ewl.spec
57213b5718255df723498e8641dc2019f666dbdf
[packages/ewl.git] / ewl.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         ecore_ver       0.9.9.043
6 %define         edje_ver        0.9.9.043
7 %define         efreet_ver      0.5.0.043
8 %define         emotion_ver     0.1.0.042
9 %define         epsilon_ver     0.3.0.012
10 %define         evas_ver        0.9.9.043
11
12 Summary:        Enlightenment Widget Library
13 Summary(pl.UTF-8):      Biblioteka widgetów Enlightenmenta (Enlightenment Widget Library)
14 Name:           ewl
15 Version:        0.5.2.042
16 Release:        1
17 License:        BSD
18 Group:          Libraries
19 Source0:        http://download.enlightenment.org/snapshots/2008-01-25/%{name}-%{version}.tar.bz2
20 # Source0-md5:  c25a57cdee3e58b016ad8ad5e0767902
21 URL:            http://enlightenment.org/p.php?p=about/libs/ewl
22 BuildRequires:  autoconf >= 2.52
23 BuildRequires:  automake >= 1.6
24 # ecore-file ecore-txt
25 BuildRequires:  ecore-devel >= %{ecore_ver}
26 BuildRequires:  edje >= %{edje_ver}
27 BuildRequires:  edje-devel >= %{edje_ver}
28 BuildRequires:  efreet-devel >= %{efreet_ver}
29 BuildRequires:  emotion-devel >= %{emotion_ver}
30 BuildRequires:  epsilon-devel >= %{epsilon_ver}
31 BuildRequires:  evas-devel >= %{evas_ver}
32 BuildRequires:  libtool
33 BuildRequires:  pkgconfig
34 BuildRequires:  xorg-lib-libX11-devel
35 Requires:       %{name}-libs = %{version}-%{release}
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %undefine       __cxx
39
40 %description
41 EWL is a widget library which uses the E Foundation Libraries (EFL).
42
43 %description -l pl.UTF-8
44 EWL to biblioteka widgetów używająca EFL (E Foundation Libraries -
45 podstawowych bibliotek Englightenmenta).
46
47 %package libs
48 Summary:        EWL library
49 Summary(pl.UTF-8):      Biblioteka EWL
50 Group:          Libraries
51 Requires:       ecore-file >= %{ecore_ver}
52 Requires:       ecore-txt >= %{ecore_ver}
53 Requires:       edje-libs >= %{edje_ver}
54 Requires:       efreet >= %{efreet_ver}
55 Requires:       emotion >= %{emotion_ver}
56 Requires:       epsilon-libs >= %{epsilon_ver}
57 Requires:       evas >= %{evas_ver}
58
59 %description libs
60 EWL library.
61
62 %description libs -l pl.UTF-8
63 Biblioteka EWL.
64
65 %package devel
66 Summary:        EWL header files and test programs
67 Summary(pl.UTF-8):      Pliki nagłówkowe i programy testowe dla biblioteki EWL
68 Group:          Development/Libraries
69 Requires:       %{name}-libs = %{version}-%{release}
70 # ecore-file ecore-txt
71 Requires:       ecore-devel >= %{ecore_ver}
72 Requires:       edje-devel >= %{edje_ver}
73 Requires:       efreet-devel >= %{efreet_ver}
74 Requires:       emotion-devel >= %{emotion_ver}
75 Requires:       epsilon-devel >= %{epsilon_ver}
76 Requires:       evas-devel >= %{evas_ver}
77
78 %description devel
79 EWL header files and test programs.
80
81 %description devel -l pl.UTF-8
82 Pliki nagłówkowe i programy testowe dla biblioteki EWL.
83
84 %package static
85 Summary:        Static EWL library
86 Summary(pl.UTF-8):      Statyczna biblioteka EWL
87 Group:          Development/Libraries
88 Requires:       %{name}-devel = %{version}-%{release}
89
90 %description static
91 Static EWL library.
92
93 %description static -l pl.UTF-8
94 Statyczna biblioteka EWL.
95
96 %prep
97 %setup -q
98
99 %build
100 %configure \
101         %{!?with_static_libs:--disable-static}
102 %{__make}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*/*.{la,a}
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post   libs -p /sbin/ldconfig
116 %postun libs -p /sbin/ldconfig
117
118 %files
119 %defattr(644,root,root,755)
120 %doc AUTHORS COPYING ChangeLog README
121 %attr(755,root,root) %{_bindir}/ewl_config
122 %attr(755,root,root) %{_bindir}/ewl_test
123 %attr(755,root,root) %{_bindir}/ewl_embed_test
124 %attr(755,root,root) %{_bindir}/ewl_simple_test
125 %dir %{_sysconfdir}/ewl
126 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ewl/ewl.cfg
127 %dir %{_libdir}/%{name}/tests
128 %attr(755,root,root) %{_libdir}/%{name}/tests/ewl_*.so
129 %{_datadir}/%{name}
130
131 %files libs
132 %defattr(644,root,root,755)
133 %attr(755,root,root) %{_libdir}/libewl.so.*.*.*
134 %attr(755,root,root) %ghost %{_libdir}/libewl.so.1
135 %dir %{_libdir}/%{name}
136 %dir %{_libdir}/%{name}/engines
137 # missing -avoid-version
138 %attr(755,root,root) %{_libdir}/%{name}/engines/*.so*
139 %dir %{_libdir}/%{name}/plugins
140 %attr(755,root,root) %{_libdir}/%{name}/plugins/ewl_io_manager_*.so
141
142 %files devel
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_libdir}/libewl.so
145 %{_libdir}/libewl.la
146 %dir %{_includedir}/ewl
147 %{_includedir}/ewl/Ewl.h
148 %{_includedir}/ewl/Ewl_Test.h
149 %{_includedir}/ewl/ewl_*.h
150 %{_pkgconfigdir}/ewl.pc
151
152 %if %{with static_libs}
153 %files static
154 %defattr(644,root,root,755)
155 %{_libdir}/libewl.a
156 %endif
This page took 0.065752 seconds and 2 git commands to generate.