]> git.pld-linux.org Git - packages/ewl.git/blob - ewl.spec
- updated to 20080813 snap
[packages/ewl.git] / ewl.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         ecore_ver       0.9.9.044
6 %define         edje_ver        0.9.9.044
7 %define         efreet_ver      0.5.0.044
8 %define         emotion_ver     0.1.0.043
9 %define         epsilon_ver     0.3.0.013
10 %define         evas_ver        0.9.9.044
11 %define         _snap   20080813
12
13 Summary:        Enlightenment Widget Library
14 Summary(pl.UTF-8):      Biblioteka widgetów Enlightenmenta (Enlightenment Widget Library)
15 Name:           ewl
16 Version:        0.5.2.043
17 Release:        0.%{_snap}.1
18 License:        BSD
19 Group:          Libraries
20 Source0:        %{name}-%{version}-%{_snap}.tar.bz2
21 # Source0-md5:  bc0e325e0982fbb2246cfc69ab2beb62
22 URL:            http://enlightenment.org/p.php?p=about/libs/ewl
23 BuildRequires:  autoconf >= 2.52
24 BuildRequires:  automake >= 1.6
25 # ecore-file ecore-txt
26 BuildRequires:  ecore-devel >= %{ecore_ver}
27 BuildRequires:  edje >= %{edje_ver}
28 BuildRequires:  edje-devel >= %{edje_ver}
29 BuildRequires:  efreet-devel >= %{efreet_ver}
30 BuildRequires:  emotion-devel >= %{emotion_ver}
31 BuildRequires:  epsilon-devel >= %{epsilon_ver}
32 BuildRequires:  evas-devel >= %{evas_ver}
33 BuildRequires:  libtool
34 BuildRequires:  pkgconfig
35 BuildRequires:  xorg-lib-libX11-devel
36 Requires:       %{name}-libs = %{version}-%{release}
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %undefine       __cxx
40
41 %description
42 EWL is a widget library which uses the E Foundation Libraries (EFL).
43
44 %description -l pl.UTF-8
45 EWL to biblioteka widgetów używająca EFL (E Foundation Libraries -
46 podstawowych bibliotek Englightenmenta).
47
48 %package libs
49 Summary:        EWL library
50 Summary(pl.UTF-8):      Biblioteka EWL
51 Group:          Libraries
52 Requires:       ecore-file >= %{ecore_ver}
53 Requires:       ecore-txt >= %{ecore_ver}
54 Requires:       edje-libs >= %{edje_ver}
55 Requires:       efreet >= %{efreet_ver}
56 Requires:       emotion >= %{emotion_ver}
57 Requires:       epsilon-libs >= %{epsilon_ver}
58 Requires:       evas >= %{evas_ver}
59
60 %description libs
61 EWL library.
62
63 %description libs -l pl.UTF-8
64 Biblioteka EWL.
65
66 %package devel
67 Summary:        EWL header files and test programs
68 Summary(pl.UTF-8):      Pliki nagłówkowe i programy testowe dla biblioteki EWL
69 Group:          Development/Libraries
70 Requires:       %{name}-libs = %{version}-%{release}
71 # ecore-file ecore-txt
72 Requires:       ecore-devel >= %{ecore_ver}
73 Requires:       edje-devel >= %{edje_ver}
74 Requires:       efreet-devel >= %{efreet_ver}
75 Requires:       emotion-devel >= %{emotion_ver}
76 Requires:       epsilon-devel >= %{epsilon_ver}
77 Requires:       evas-devel >= %{evas_ver}
78
79 %description devel
80 EWL header files and test programs.
81
82 %description devel -l pl.UTF-8
83 Pliki nagłówkowe i programy testowe dla biblioteki EWL.
84
85 %package static
86 Summary:        Static EWL library
87 Summary(pl.UTF-8):      Statyczna biblioteka EWL
88 Group:          Development/Libraries
89 Requires:       %{name}-devel = %{version}-%{release}
90
91 %description static
92 Static EWL library.
93
94 %description static -l pl.UTF-8
95 Statyczna biblioteka EWL.
96
97 %prep
98 %setup -q -n %{name}-%{version}-%{_snap}
99
100 %build
101 %{__libtoolize}
102 %{__aclocal} -I m4
103 %{__autoconf}
104 %{__autoheader}
105 %{__automake}
106 %configure \
107         %{!?with_static_libs:--disable-static}
108 %{__make}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*/*.{la,a}
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post   libs -p /sbin/ldconfig
122 %postun libs -p /sbin/ldconfig
123
124 %files
125 %defattr(644,root,root,755)
126 %doc AUTHORS COPYING ChangeLog README
127 %attr(755,root,root) %{_bindir}/ewl_config
128 %attr(755,root,root) %{_bindir}/ewl_test
129 %attr(755,root,root) %{_bindir}/ewl_embed_test
130 %attr(755,root,root) %{_bindir}/ewl_simple_test
131 %dir %{_sysconfdir}/ewl
132 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ewl/ewl.cfg
133 %dir %{_libdir}/%{name}/tests
134 %attr(755,root,root) %{_libdir}/%{name}/tests/ewl_*.so
135 %{_datadir}/%{name}
136
137 %files libs
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_libdir}/libewl.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libewl.so.1
141 %dir %{_libdir}/%{name}
142 %dir %{_libdir}/%{name}/engines
143 # missing -avoid-version
144 %attr(755,root,root) %{_libdir}/%{name}/engines/*.so*
145 %dir %{_libdir}/%{name}/plugins
146 %attr(755,root,root) %{_libdir}/%{name}/plugins/ewl_io_manager_*.so
147
148 %files devel
149 %defattr(644,root,root,755)
150 %attr(755,root,root) %{_libdir}/libewl.so
151 %{_libdir}/libewl.la
152 %dir %{_includedir}/ewl
153 %{_includedir}/ewl/Ewl.h
154 %{_includedir}/ewl/Ewl_Test.h
155 %{_includedir}/ewl/ewl_*.h
156 %{_pkgconfigdir}/ewl.pc
157
158 %if %{with static_libs}
159 %files static
160 %defattr(644,root,root,755)
161 %{_libdir}/libewl.a
162 %endif
This page took 0.074568 seconds and 3 git commands to generate.