]> git.pld-linux.org Git - packages/ewebkit.git/commitdiff
- fix incompatibilities with cmake 3.4+ auto/th/ewebkit-0.1.0-0.r164189.6
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 28 May 2016 08:52:19 +0000 (08:52 +0000)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 28 May 2016 08:52:19 +0000 (08:52 +0000)
- fix build with g++ 5.3
- rel 6

cmake-3.4.patch [new file with mode: 0644]
cxx.patch [new file with mode: 0644]
ewebkit.spec

diff --git a/cmake-3.4.patch b/cmake-3.4.patch
new file mode 100644 (file)
index 0000000..dc07076
--- /dev/null
@@ -0,0 +1,12 @@
+--- efl-webkit/Source/cmake/OptionsEfl.cmake.orig      2014-02-16 05:16:03.000000000 +0000
++++ efl-webkit/Source/cmake/OptionsEfl.cmake   2016-05-28 08:31:36.818191669 +0000
+@@ -230,7 +230,8 @@
+         set(WTF_USE_EGL 1)
+         add_definitions(-DWTF_USE_EGL=1)
+     else ()
+-        CHECK_INCLUDE_FILES("GL/glx.h" OPENGLX_FOUND)
++        include(CheckIncludeFiles)
++        check_include_files("GL/glx.h" OPENGLX_FOUND)
+         add_definitions(-DWTF_USE_GLX=1)
+     endif ()
+ endif ()
diff --git a/cxx.patch b/cxx.patch
new file mode 100644 (file)
index 0000000..cad0665
--- /dev/null
+++ b/cxx.patch
@@ -0,0 +1,20 @@
+--- efl-webkit/Source/JavaScriptCore/profiler/ProfileNode.cpp~ 2014-02-02 04:21:06.000000000 +0000
++++ efl-webkit/Source/JavaScriptCore/profiler/ProfileNode.cpp  2016-05-28 08:39:06.597242990 +0000
+@@ -123,7 +123,7 @@
+ {
+     ASSERT(!m_calls.isEmpty());
+-    if (isnan(m_calls.last().totalTime()))
++    if (std::isnan(m_calls.last().totalTime()))
+         endAndRecordCall();
+     // Because we iterate in post order all of our children have been stopped before us.
+@@ -147,7 +147,7 @@
+ void ProfileNode::endAndRecordCall()
+ {
+     Call& last = lastCall();
+-    ASSERT(isnan(last.totalTime()));
++    ASSERT(std::isnan(last.totalTime()));
+     last.setTotalTime(currentTime() - last.startTime());
index 6ff7230449903883a5b621ee9773eaa58582ceff..6e61a76d1a5f1c43c520a6c50d74ac89043bcb94 100644 (file)
@@ -3,7 +3,7 @@
 %bcond_with    elementary      # MiniBrowser build (needs Elementary); not installed anyway
 #
 %define                efl_ver 1.8
-%define                rel 5
+%define                rel 6
 Summary:       WebKit-EFL - Web content engine for EFL applications
 Summary(pl.UTF-8):     WebKit-EFL - silnik WWW dla aplikacji EFL
 Name:          ewebkit
@@ -28,6 +28,8 @@ Patch4:               %{name}-x32.patch
 Patch5:                %{name}-glib.patch
 Patch6:                %{name}-link.patch
 Patch7:                gstreamer-headers.patch
+Patch8:                cmake-3.4.patch
+Patch9:                cxx.patch
 URL:           http://trac.enlightenment.org/e/wiki/EWebKit
 BuildRequires: OpenGL-devel
 BuildRequires: atk-devel >= 1:2.10.0
@@ -142,6 +144,8 @@ Pliki nagłówkowe biblioteki WebKit-EFL.
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
+%patch8 -p1
+%patch9 -p1
 
 %build
 # replace -g2 with -g1 to not run into 4 GB ar format limit
This page took 0.10355 seconds and 4 git commands to generate.