]> git.pld-linux.org Git - packages/evolution.git/commitdiff
- don't put libraries in LDFLAGS
authorMarcin Banasiak <marcin.banasiak@gmail.com>
Wed, 26 Sep 2007 21:06:53 +0000 (21:06 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    evolution-as_needed-fix.patch -> 1.3

evolution-as_needed-fix.patch [new file with mode: 0644]

diff --git a/evolution-as_needed-fix.patch b/evolution-as_needed-fix.patch
new file mode 100644 (file)
index 0000000..2bed7f5
--- /dev/null
@@ -0,0 +1,72 @@
+diff -urN evolution-2.12.0/configure.in evolution-2.12.0.new/configure.in
+--- evolution-2.12.0/configure.in      2007-09-17 08:27:28.000000000 +0200
++++ evolution-2.12.0.new/configure.in  2007-09-26 21:50:58.000000000 +0200
+@@ -758,24 +758,24 @@
+ msg_krb5="no"
+ if test "x${with_krb5}" != "xno"; then
+-      LDFLAGS_save="$LDFLAGS"
++      LIBS_save="$LIBS"
+       
+       mitlibs="-lkrb5 -lk5crypto -lcom_err -lgssapi_krb5"
+       heimlibs="-lkrb5 -lcrypto -lasn1 -lcom_err -lroken -lgssapi"
+       sunlibs="-lkrb5 -lgss"
+       AC_CACHE_CHECK([for Kerberos 5], ac_cv_lib_kerberos5,
+       [
+-              LDFLAGS="$LDFLAGS -L$with_krb5_libs $mitlibs"
++              LIBS="$LIBS -L$with_krb5_libs $mitlibs"
+               AC_TRY_LINK_FUNC(krb5_init_context, ac_cv_lib_kerberos5="$mitlibs",
+               [
+-                      LDFLAGS="$LDFLAGS_save -L$with_krb5_libs $heimlibs"
++                      LIBS="$LIBS_save -L$with_krb5_libs $heimlibs"
+                       AC_TRY_LINK_FUNC(krb5_init_context, ac_cv_lib_kerberos5="$heimlibs", 
+                       [
+-                              LDFLAGS="$LDFLAGS_save -L$with_krb5_libs $sunlibs"
++                              LIBS="$LIBS_save -L$with_krb5_libs $sunlibs"
+                               AC_TRY_LINK_FUNC(krb5_init_context, ac_cv_lib_kerberos5="$sunlibs", ac_cv_lib_kerberos5="no")
+                       ])
+               ])
+-              LDFLAGS="$LDFLAGS_save"
++              LIBS="$LIBS_save"
+       ])
+       if test "$ac_cv_lib_kerberos5" != "no"; then
+               AC_DEFINE(HAVE_KRB5,1,[Define if you have Krb5])
+@@ -818,32 +818,32 @@
+ msg_krb4="no"
+ if test "x${with_krb4}" != "xno"; then
+-      LDFLAGS_save="$LDFLAGS"
++      LIBS_save="$LIBS"
+       AC_CACHE_CHECK(for Kerberos 4, ac_cv_lib_kerberos4,
+       [
+               ac_cv_lib_kerberos4="no"
+               mitcompatlibs="-lkrb4 -ldes425 -lkrb5 -lk5crypto -lcom_err"
+               # Look for MIT krb5 compat krb4
+-              LDFLAGS="$LDFLAGS -L$with_krb4_libs $mitcompatlibs"
++              LIBS="$LIBS -L$with_krb4_libs $mitcompatlibs"
+               AC_TRY_LINK_FUNC(krb_mk_req, ac_cv_lib_kerberos4="$mitcompatlibs")
+               
+               if test "$ac_cv_lib_kerberos4" = "no"; then
+                       # Look for KTH krb4
+-                      LDFLAGS="$LDFLAGS_save -L$with_krb4_libs -lkrb -lcrypto -lcom_err -lroken"
++                      LIBS="$LIBS_save -L$with_krb4_libs -lkrb -lcrypto -lcom_err -lroken"
+                       AC_TRY_LINK_FUNC(krb_mk_req, ac_cv_lib_kerberos4="-lkrb -lcrypto -lcom_err -lroken")
+               fi
+               if test "$ac_cv_lib_kerberos4" = "no"; then
+                       # Look for old MIT krb4
+-                      LDFLAGS="$LDFLAGS_save -L$with_krb4_libs -lkrb"
++                      LIBS="$LIBS_save -L$with_krb4_libs -lkrb"
+                       AC_TRY_LINK_FUNC(krb_mk_req, ac_cv_lib_kerberos4="-lkrb",
+                       [
+-                              LDFLAGS="$LDFLAGS -ldes"
++                              LIBS="$LIBS -ldes"
+                               AC_TRY_LINK_FUNC(krb_mk_req, ac_cv_lib_kerberos4="-lkrb -ldes")
+                       ])
+               fi
+       ])
+-      LDFLAGS="$LDFLAGS_save"
++      LIBS="$LIBS_save"
+       if test "$ac_cv_lib_kerberos4" != "no"; then
+               AC_DEFINE(HAVE_KRB4,1,[Define if you have Krb4])
+               msg_krb4="yes"
This page took 0.154955 seconds and 4 git commands to generate.