]> git.pld-linux.org Git - packages/evolution.git/blob - evolution.spec
- up to version 1.5.9.1
[packages/evolution.git] / evolution.spec
1 #
2 # todo:
3 # - splitting mail, addressbook and calendar:
4 #   - etspec?
5 #   - ui?
6 #   - dependencies, i.e.: mail should require addressbook?
7 #
8 # Conditionals:
9 %bcond_without ldap     # build without ldap support
10
11 %define         mver            1.5
12 %define         subver  9.1
13
14 Summary:        The GNOME2 Email/Calendar/Addressbook Suite
15 Summary(pl):    Klient poczty dla GNOME2/Kalendarz/Ksi±¿ka Adresowa
16 Summary(pt_BR): Cliente de email integrado com calendário e catálogo de endereços
17 Summary(zh_CN): Evolution - GNOME2¸öÈ˺͹¤×÷×éÐÅÏ¢¹ÜÀí¹¤¾ß(°üÀ¨µç×ÓÓʼþ£¬ÈÕÀúºÍµØÖ·±¡)
18 Name:           evolution
19 Version:        %{mver}.%{subver}
20 Release:        1
21 License:        GPL
22 Group:          Applications/Mail
23 Source0:        http://ftp.gnome.org/pub/gnome/sources/%{name}/%{mver}/%{name}-%{version}.tar.bz2
24 # Source0-md5:  f075b47071c81950258d51aef50cc657
25 Patch0:         %{name}-locale-names.patch
26 Patch1:         %{name}-nolibs.patch
27 Patch2:         %{name}-schemas.patch
28 Patch3:         %{name}-gnome-icon-theme.patch
29 URL:            http://www.ximian.com/products/ximian_evolution/
30 BuildRequires:  GConf2-devel >= 2.6.1
31 BuildRequires:  ORBit2-devel >= 1:2.10.2
32 BuildRequires:  autoconf
33 BuildRequires:  automake
34 BuildRequires:  bison
35 BuildRequires:  evolution-data-server-devel >= 0.0.94
36 BuildRequires:  flex
37 BuildRequires:  freetype-devel >= 2.0.5
38 BuildRequires:  gal-devel >= 1:2.1.10
39 BuildRequires:  gettext-devel
40 BuildRequires:  gnome-common
41 BuildRequires:  gnome-pilot-devel >= 2.0.0
42 BuildRequires:  gnome-vfs2-devel >= 2.6.1.1
43 BuildRequires:  gtk-doc >= 1.1
44 BuildRequires:  gtkhtml-devel >= 3.1.16
45 BuildRequires:  intltool >= 0.30
46 BuildRequires:  libglade2-devel >= 1:2.4.0
47 BuildRequires:  libgnomeprintui-devel >= 2.6.1
48 BuildRequires:  libgnomeui-devel >= 2.6.1.1
49 BuildRequires:  libsoup-devel >= 2.1.11
50 BuildRequires:  libtool
51 BuildRequires:  libxml2
52 BuildRequires:  nspr-devel
53 BuildRequires:  nss-devel
54 %{?with_ldap:BuildRequires:     openldap-devel >= 2.0.0}
55 #BuildRequires: openssl-devel >= 0.9.7d
56 BuildRequires:  pilot-link-devel >= 0.11.4
57 BuildRequires:  pkgconfig
58 BuildRequires:  psmisc
59 BuildRequires:  python
60 BuildRequires:  scrollkeeper >= 0.1.4
61 BuildRequires:  which
62 Requires(post,postun):  /sbin/ldconfig
63 Requires(post,postun):  /usr/bin/scrollkeeper-update
64 Requires(post):         GConf2
65 Requires:       %{name}-component = %{version}-%{release}
66 Requires:       GConf2 >= 2.6.1
67 Requires:       bonobo-activation
68 Requires:       evolution-data-server >= 0.0.94
69 Requires:       gal >= 1:2.1.9
70 Requires:       gtkhtml >= 3.1.16
71 Requires:       libglade2 >= 1:2.4.0
72 Requires:       psmisc
73 Requires:       scrollkeeper >= 0.1.4
74 Obsoletes:      evolution2
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77 %description
78 Evolution is the GNOME2 mailer, calendar, contact manager and
79 communications tool. The tools which make up Evolution will be tightly
80 integrated with one another and act as a seamless personal
81 information-management tool.
82
83 %description -l pl
84 Evolution to program pocztowy GNOME2, kalendarz, ksi±¿ka adresowa i
85 narzêdzie komunikacyjne.
86
87 %description -l pt_BR
88 Evolution é um cliente de email para o GNOME2 com calendário e outras
89 ferramentas interessantes.
90
91 %package devel
92 Summary:        Header files for evolution
93 Summary(pl):    Pliki nag³ówkowe i dokumentacja
94 Summary(pt_BR): Bibliotecas e arquivos de inclusão para desenvolvimento
95 Summary(zh_CN): Evolution×é¼þ¿ª·¢¿â
96 Group:          Development/Libraries
97 Requires:       %{name} = %{version}-%{release}
98 Requires:       cyrus-sasl-devel
99 Requires:       freetype-devel
100 Requires:       gal-devel >= 1:2.1.10
101 Requires:       gnome-vfs2-devel >= 2.6.1.1
102 Requires:       gtkhtml-devel >= 3.1.16
103 Requires:       libglade2-devel >= 1:2.4.0
104 Requires:       libgnomeprintui-devel >= 2.6.1
105 Requires:       libgnomeui-devel >= 2.6.1.1
106 Requires:       libsoup-devel >= 2.1.11
107 Requires:       nspr-devel
108 Requires:       nss-devel
109 %{?with_ldap:Requires:  openldap-devel >= 2.0.0}
110 #Requires:      openssl-devel >= 0.9.7c
111 Obsoletes:      evolution2-devel
112
113 %description devel
114 This package contains the files necessary to develop applications
115 using Evolution's libraries.
116
117 %description devel -l pl
118 Pakiet zawiera pliki potrzebne do rozwoju aplikacji u¿ywaj±cych
119 bibliotek programu Evolution.
120
121 %description devel -l pt_BR
122 Este pacote contém os arquivos necessários para desenvolvimento de
123 aplicações utilizando as bibliotecas do Evolution.
124
125 %package static
126 Summary:        Static libraries for evolution
127 Summary(pl):    Biblioteki statyczne dla evolution
128 Summary(pt_BR): Bibliotecas estáticas para desenvolvimento
129 Group:          Development/Libraries
130 Requires:       %{name}-devel = %{version}-%{release}
131 Obsoletes:      evolution2-static
132
133 %description static
134 This package contains static libraries for Evolution.
135
136 %description static -l pl
137 Pakiet zawiera statyczne biblioteki Evolution.
138
139 %description static -l pt_BR
140 Este pacote contém as bibliotecas estáticas para desenvolvimento de
141 aplicações.
142
143 %package mail
144 Summary:        Evolution mail component
145 Summary(pl):    Modu³ pocztowy Evolution
146 Group:          X11/Applications
147 # mail composer requires addressbook component
148 Requires:       %{name}-addressbook = %{version}-%{release}
149 Requires(post,postun):  /sbin/ldconfig
150 Requires(post):         GConf2
151 Provides:       %{name}-component = %{version}-%{release}
152
153 %description mail
154 Evolution mail.
155
156 %description mail -l pl
157 Modu³ pocztowy Evolution.
158
159 %package addressbook
160 Summary:        Evolution addressbook component
161 Summary(pl):    Modu³ ksi±¿ki adresowej Evolution
162 Group:          X11/Applications
163 Requires:       %{name} = %{version}-%{release}
164 Requires(post): /sbin/ldconfig
165 Requires(post):         GConf2
166 Provides:       %{name}-component = %{version}-%{release}
167
168 %description addressbook
169 Evolution addressbook.
170
171 %description addressbook -l pl
172 Ksi±¿ka adresowa Evolution.
173
174 %package calendar
175 Summary:        Evolution calendar and todo component
176 Summary(pl):    Modu³ kalendarza i listy zadañ Evolution
177 Group:          X11/Applications
178 Requires:       %{name} = %{version}-%{release}
179 Requires(post): /sbin/ldconfig
180 Requires(post):         GConf2
181 Provides:       %{name}-component = %{version}-%{release}
182
183 %description calendar
184 Evolution calendar and todo component.
185
186 %description calendar -l pl
187 Kalendarz i lista zadañ Evolution.
188
189 %package pilot
190 Summary:        Evolution conduits for gnome-pilot
191 Summary(pl):    Dodatki do wymiany danych z gnome-pilot
192 Group:          X11/Applications
193 Requires:       %{name} = %{version}-%{release}
194 Obsoletes:      evolution2-pilot
195
196 %description pilot
197 This package contains conduits needed by gnome-pilot to synchronize
198 your Palm with Evolution.
199
200 %description pilot -l pl
201 Ten pakiet zawiera dodatki do synchronizacji danych Evolution z
202 Palmem.
203
204 %prep
205 %setup -q
206 %patch0 -p1
207 %patch1 -p1
208 %patch2 -p1
209 %patch3 -p1
210
211 mv po/{no,nb}.po
212
213 %build
214 glib-gettextize --copy --force
215 intltoolize --copy --force
216 %{__libtoolize}
217 %{__aclocal} -I %{_aclocaldir}/gnome2-macros
218 %{__autoheader}
219 %{__autoconf}
220 %{__automake}
221 %configure \
222         --enable-gtk-doc \
223         --enable-pilot-conduits=yes \
224         %{?with_ldap:--with-openldap=yes} \
225         %{!?with_ldap:--with-openldap=no} \
226         --without-static-ldap \
227         --enable-nntp=yes \
228         --enable-file-locking=fcntl \
229         --enable-dot-locking=no \
230         --with-nspr-includes="%{_includedir}/nspr" \
231         --with-nss-includes="%{_includedir}/nss" \
232         --with-nspr-libs="%{_libdir}" \
233         --with-nss-libs="%{_libdir}" \
234         --enable-ipv6=yes \
235         --with-html-dir=%{_gtkdocdir} \
236         --with-kde-applnk-path=no \
237         --disable-schemas-install \
238         --enable-nss=yes \
239         --enable-smime=yes \
240         --enable-static
241
242 # hack to rebuild *.c and *.h from *.idl (check if needed with new versions)
243 # (required if you use ORBit2-devel 2.7.2)
244 find -name \*.idl -exec touch {} \;
245
246 %{__make} \
247         GTKHTML_DATADIR=%{_datadir}/idl
248
249 %install
250 rm -rf $RPM_BUILD_ROOT
251
252 %{__make} install \
253         DESTDIR=$RPM_BUILD_ROOT \
254         KDE_APPLNK_DIR=%{_applnkdir}/Network/Mail \
255         omf_dest_dir=%{_omf_dest_dir}/%{name} \
256         GTKHTML_DATADIR=%{_datadir}/idl \
257         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
258
259 # strip doesn't pass these files and they aren't necessary, so remove them
260 # probably this should be done differently, but I have no idea
261 rm -f $RPM_BUILD_ROOT%{_libdir}/evolution/%{mver}/*/*.a
262 rm -f $RPM_BUILD_ROOT%{_libdir}/evolution/%{mver}/libemiscwidgets.a
263 rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-pilot/*/*.{a,la}
264
265 %find_lang %{name} --all-name --with-gnome
266
267 %clean
268 rm -rf $RPM_BUILD_ROOT
269
270 %post
271 /sbin/ldconfig
272 /usr/bin/scrollkeeper-update
273 %gconf_schema_install
274
275 %postun
276 /sbin/ldconfig
277 /usr/bin/scrollkeeper-update
278
279 %post mail
280 /sbin/ldconfig
281 %gconf_schema_install
282
283 %postun mail
284 /sbin/ldconfig
285
286 %post addressbook
287 /sbin/ldconfig
288 %gconf_schema_install
289
290 %postun addressbook -p /sbin/ldconfig
291
292 %post calendar
293 /sbin/ldconfig
294 %gconf_schema_install
295
296 %postun calendar -p /sbin/ldconfig
297
298 %files -f evolution.lang
299 %defattr(644,root,root,755)
300 %doc AUTHORS ChangeLog NEWS* README
301 %attr(755,root,root) %{_bindir}/*
302 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libeconduit.so.*
303 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libemiscwidgets.so.*
304 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libeselectnames.so.*
305 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libeshell.so.*
306 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libeutil.so.*
307 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libevolution-a11y.so.*
308 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libevolution-importer.so.*
309 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libevolution-widgets-a11y.so.*
310 %attr(755,root,root) %{_libdir}/evolution/%{mver}/evolution-alarm-notify
311 %attr(755,root,root) %{_libdir}/evolution/%{mver}/killev
312 # addressbook requires it:
313 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libcamel*.so.*
314 %dir %{_libdir}/evolution
315 %dir %{_libdir}/evolution/%{mver}
316 %dir %{_libdir}/evolution/%{mver}/components
317 %{_libdir}/bonobo/servers/GNOME_Evolution_Shell_1.5.server
318 %dir %{_datadir}/idl/evolution-%{mver}
319 %dir %{_datadir}/evolution
320 %dir %{_datadir}/evolution/%{mver}
321 %dir %{_datadir}/evolution/%{mver}/views
322 %{_datadir}/evolution/%{mver}/*.xml
323 %dir %{_datadir}/evolution/%{mver}/default
324 %dir %{_datadir}/evolution/%{mver}/default/C
325 %{_datadir}/evolution/%{mver}/errors
326 %{_datadir}/evolution/%{mver}/etspec
327 %{_datadir}/evolution/%{mver}/glade
328 %{_datadir}/evolution/%{mver}/help
329 %{_datadir}/evolution/%{mver}/images
330 %{_datadir}/evolution/%{mver}/ui
331 %{_datadir}/mime-info/*
332 %{_datadir}/idl/evolution-%{mver}/Evolution-Component.idl
333 %{_datadir}/idl/evolution-%{mver}/Evolution-ConfigControl.idl
334 %{_datadir}/idl/evolution-%{mver}/Evolution-Offline.idl
335 %{_datadir}/idl/evolution-%{mver}/Evolution-Shell.idl
336 %{_datadir}/idl/evolution-%{mver}/Evolution-Wizard.idl
337 %{_datadir}/idl/evolution-%{mver}/Evolution-common.idl
338 %{_datadir}/idl/evolution-%{mver}/Evolution.idl
339 %{_datadir}/idl/evolution-%{mver}/GNOME_Evolution_Importer.idl
340 %{_desktopdir}/*
341 %{_pixmapsdir}/*
342 %{_sysconfdir}/gconf/schemas/apps_evolution_shell-1.5.schemas
343 %{_omf_dest_dir}/%{name}
344
345 %files devel
346 %defattr(644,root,root,755)
347 %attr(755,root,root) %{_libdir}/evolution/%{mver}/*.so
348 %{_libdir}/evolution/%{mver}/*.la
349 %{_libdir}/evolution/*/*/*.la
350 %{_includedir}/*
351 %{_pkgconfigdir}/*
352
353 %files static
354 %defattr(644,root,root,755)
355 %{_libdir}/evolution/%{mver}/*.a
356
357 %files mail
358 %defattr(644,root,root,755)
359 %dir %{_libdir}/evolution/%{mver}/camel*
360 %dir %{_libdir}/evolution/%{mver}/evolution-calendar-importers
361 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libevolution-mail-importers.so*
362 %attr(755,root,root) %{_libdir}/evolution/%{mver}/camel/*
363 %attr(755,root,root) %{_libdir}/evolution/%{mver}/components/libevolution-mail.so
364 %attr(755,root,root) %{_libdir}/evolution/%{mver}/camel-providers/*.so
365 %attr(755,root,root) %{_libdir}/evolution/%{mver}/evolution-calendar-importers/*.so
366 %{_libdir}/bonobo/servers/GNOME_Evolution_Mail_1.5.server
367 %{_libdir}/bonobo/servers/GNOME_Evolution_Mail_Importers_1.5.server
368 %{_libdir}/evolution/%{mver}/camel-providers/*.urls
369 %{_datadir}/evolution/%{mver}/views/mail*
370 %{_datadir}/evolution/%{mver}/default/C/mail
371 %{_datadir}/idl/evolution-%{mver}/Composer.idl
372 %{_datadir}/idl/evolution-%{mver}/Evolution-Composer.idl
373 %{_sysconfdir}/gconf/schemas/evolution-mail-1.5.schemas
374
375 %files addressbook
376 %defattr(644,root,root,755)
377 %dir %{_libdir}/evolution/%{mver}/evolution-addressbook-importers
378 %attr(755,root,root) %{_libdir}/evolution/%{mver}/evolution-addressbook-clean
379 %attr(755,root,root) %{_libdir}/evolution/%{mver}/csv2vcard
380 %attr(755,root,root) %{_libdir}/evolution/%{mver}/components/libevolution-addressbook.so
381 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libevolution-addressbook-a11y.so.*
382 %attr(755,root,root) %{_libdir}/evolution/%{mver}/evolution-addressbook-importers/lib*.so
383 %{_libdir}/bonobo/servers/GNOME_Evolution_Addressbook*
384 %{_datadir}/evolution/%{mver}/views/addressbook*
385 %{_datadir}/evolution/%{mver}/ecps
386 %{_datadir}/idl/evolution-%{mver}/Evolution-Addressbook-SelectNames.idl
387 %{_sysconfdir}/gconf/schemas/apps_evolution_addressbook-1.5.schemas
388
389 %files calendar
390 %defattr(644,root,root,755)
391 %attr(755,root,root) %{_libdir}/evolution/%{mver}/components/libevolution-calendar.so
392 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libevolution-calendar-a11y.so.*
393 %{_libdir}/bonobo/servers/GNOME_Evolution_Calendar*
394 %{_datadir}/evolution/%{mver}/views/calendar*
395 %{_datadir}/evolution/%{mver}/views/tasks*
396 %{_datadir}/idl/evolution-%{mver}/evolution-calendar.idl
397 %{_sysconfdir}/gconf/schemas/apps_evolution_calendar-1.5.schemas
398
399 %files pilot
400 %defattr(644,root,root,755)
401 %attr(755,root,root) %{_libdir}/evolution/%{mver}/conduits/*
402 %{_datadir}/gnome-pilot/conduits/*
This page took 0.059838 seconds and 3 git commands to generate.