- very dirty and stupid patch for evolution 2.4
authorMichał 'Wolvverine' Panasiewicz <wolvverine@pld-linux.org>
Mon, 12 Sep 2005 15:02:15 +0000 (15:02 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    evolution-groupdav-confpluginlib_2.4.patch -> 1.1
    evolution-groupdav-pluginlib_2.4.patch -> 1.1

evolution-groupdav-confpluginlib_2.4.patch [new file with mode: 0644]
evolution-groupdav-pluginlib_2.4.patch [new file with mode: 0644]

diff --git a/evolution-groupdav-confpluginlib_2.4.patch b/evolution-groupdav-confpluginlib_2.4.patch
new file mode 100644 (file)
index 0000000..80cb5da
--- /dev/null
@@ -0,0 +1,92 @@
+--- evolution-groupdav-0.2/configure   2005-03-06 20:41:15.000000000 +0100
++++ evolution-groupdav-0.2/configure.new       2005-09-12 16:37:51.000000000 +0200
+@@ -20822,7 +20822,7 @@
+       libebook-$EDS_PACKAGE >= $EDS_REQUIRED
+       libedata-cal-$EDS_PACKAGE >= $EDS_REQUIRED
+       camel-provider-$EDS_PACKAGE >= $EDS_REQUIRED
+-      evolution-plugin-2.2
++      evolution-plugin-2.4
+ " >&5
+ echo $ECHO_N "checking for
+       glib-2.0 >= $GLIB_REQUIRED
+@@ -20842,7 +20842,7 @@
+       libebook-$EDS_PACKAGE >= $EDS_REQUIRED
+       libedata-cal-$EDS_PACKAGE >= $EDS_REQUIRED
+       camel-provider-$EDS_PACKAGE >= $EDS_REQUIRED
+-      evolution-plugin-2.2
++      evolution-plugin-2.4
+ ... $ECHO_C" >&6
+         if $PKG_CONFIG --exists "
+@@ -20863,7 +20863,7 @@
+       libebook-$EDS_PACKAGE >= $EDS_REQUIRED
+       libedata-cal-$EDS_PACKAGE >= $EDS_REQUIRED
+       camel-provider-$EDS_PACKAGE >= $EDS_REQUIRED
+-      evolution-plugin-2.2
++      evolution-plugin-2.4
+ " ; then
+             echo "$as_me:$LINENO: result: yes" >&5
+ echo "${ECHO_T}yes" >&6
+@@ -20889,7 +20889,7 @@
+       libebook-$EDS_PACKAGE >= $EDS_REQUIRED
+       libedata-cal-$EDS_PACKAGE >= $EDS_REQUIRED
+       camel-provider-$EDS_PACKAGE >= $EDS_REQUIRED
+-      evolution-plugin-2.2
++      evolution-plugin-2.4
+ "`
+             echo "$as_me:$LINENO: result: $EVOGROUPDAV_CFLAGS" >&5
+ echo "${ECHO_T}$EVOGROUPDAV_CFLAGS" >&6
+@@ -20914,7 +20914,7 @@
+       libebook-$EDS_PACKAGE >= $EDS_REQUIRED
+       libedata-cal-$EDS_PACKAGE >= $EDS_REQUIRED
+       camel-provider-$EDS_PACKAGE >= $EDS_REQUIRED
+-      evolution-plugin-2.2
++      evolution-plugin-2.4
+ "`
+             echo "$as_me:$LINENO: result: $EVOGROUPDAV_LIBS" >&5
+ echo "${ECHO_T}$EVOGROUPDAV_LIBS" >&6
+@@ -20941,7 +20941,7 @@
+       libebook-$EDS_PACKAGE >= $EDS_REQUIRED
+       libedata-cal-$EDS_PACKAGE >= $EDS_REQUIRED
+       camel-provider-$EDS_PACKAGE >= $EDS_REQUIRED
+-      evolution-plugin-2.2
++      evolution-plugin-2.4
+ "`
+             echo $EVOGROUPDAV_PKG_ERRORS
+         fi
+@@ -20975,7 +20975,7 @@
+       libebook-$EDS_PACKAGE >= $EDS_REQUIRED
+       libedata-cal-$EDS_PACKAGE >= $EDS_REQUIRED
+       camel-provider-$EDS_PACKAGE >= $EDS_REQUIRED
+-      evolution-plugin-2.2
++      evolution-plugin-2.4
+ ) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them." >&5
+ echo "$as_me: error: Library requirements (
+       glib-2.0 >= $GLIB_REQUIRED
+@@ -20995,7 +20995,7 @@
+       libebook-$EDS_PACKAGE >= $EDS_REQUIRED
+       libedata-cal-$EDS_PACKAGE >= $EDS_REQUIRED
+       camel-provider-$EDS_PACKAGE >= $EDS_REQUIRED
+-      evolution-plugin-2.2
++      evolution-plugin-2.4
+ ) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them." >&2;}
+    { (exit 1); exit 1; }; }
+   fi
+@@ -21018,7 +21018,7 @@
+ fi;
+ if test "x$with_plugin_install_dir" = "x" ; then
+-   PLUGIN_INSTALL_DIR=`pkg-config --variable=plugindir evolution-plugin-2.2`
++   PLUGIN_INSTALL_DIR=`pkg-config --variable=plugindir evolution-plugin-2.4`
+    if test "x$PLUGIN_INSTALL_DIR" = "x"; then
+       { { echo "$as_me:$LINENO: error: Unable to find plugin directory" >&5
+ echo "$as_me: error: Unable to find plugin directory" >&2;}
+@@ -21027,7 +21027,7 @@
+ fi
+-ERROR_DIR=`pkg-config --variable=errordir evolution-plugin-2.2`
++ERROR_DIR=`pkg-config --variable=errordir evolution-plugin-2.4`
+ if test "x$ERROR_DIR" = "x"; then
+    { { echo "$as_me:$LINENO: error: Unable to find error file directory" >&5
+ echo "$as_me: error: Unable to find error file directory" >&2;}
diff --git a/evolution-groupdav-pluginlib_2.4.patch b/evolution-groupdav-pluginlib_2.4.patch
new file mode 100644 (file)
index 0000000..b25ff6b
--- /dev/null
@@ -0,0 +1,29 @@
+--- evolution-groupdav-0.2/configure.in        2005-03-06 20:40:40.000000000 +0100
++++ evolution-groupdav-0.2/configure.in.new    2005-09-12 15:51:46.000000000 +0200
+@@ -83,7 +83,7 @@
+       libebook-$EDS_PACKAGE >= $EDS_REQUIRED
+       libedata-cal-$EDS_PACKAGE >= $EDS_REQUIRED
+       camel-provider-$EDS_PACKAGE >= $EDS_REQUIRED
+-      evolution-plugin-2.2
++      evolution-plugin-2.4
+ ])
+ AC_SUBST(EVOGROUPDAV_CFLAGS)
+@@ -110,7 +110,7 @@
+ dnl Evolution plugin install directory
+ AC_ARG_WITH(plugin-install-dir, [  --with-plugin-install-dir=PATH path to evolution source tree])
+ if test "x$with_plugin_install_dir" = "x" ; then
+-   PLUGIN_INSTALL_DIR=`pkg-config --variable=plugindir evolution-plugin-2.2`
++   PLUGIN_INSTALL_DIR=`pkg-config --variable=plugindir evolution-plugin-2.4`
+    if test "x$PLUGIN_INSTALL_DIR" = "x"; then
+       AC_MSG_ERROR(Unable to find plugin directory)
+    fi
+@@ -118,7 +118,7 @@
+ AC_SUBST(PLUGIN_INSTALL_DIR)
+ dnl Evolution e-error install directory
+-ERROR_DIR=`pkg-config --variable=errordir evolution-plugin-2.2`
++ERROR_DIR=`pkg-config --variable=errordir evolution-plugin-2.4`
+ if test "x$ERROR_DIR" = "x"; then
+    AC_MSG_ERROR(Unable to find error file directory)
+ fi
This page took 0.041528 seconds and 4 git commands to generate.