]> git.pld-linux.org Git - packages/evince.git/blob - evince.spec
44ff0321b8cbbea67de80f88c5fa01d311577095
[packages/evince.git] / evince.spec
1 #
2 # TODO: fix t1lib build time misdetection (very low prio)
3 #
4 # Conditional build:
5 %bcond_without  dbus    # enable DBUS support
6 #
7 Summary:        Document viewer for multiple document formats
8 Summary(pl):    Przegl±darka dokumentów w wielu formatach
9 Name:           evince
10 Version:        0.5.5
11 Release:        1
12 License:        GPL v2
13 Group:          X11/Applications/Graphics
14 Source0:        http://ftp.gnome.org/pub/gnome/sources/evince/0.5/%{name}-%{version}.tar.bz2
15 # Source0-md5:  d32d7ee1b84be2c18ad3249aea79d966
16 Patch0:         %{name}-desktop.patch
17 Patch1:         %{name}-gs8.patch
18 URL:            http://www.gnome.org/projects/evince/
19 BuildRequires:  GConf2-devel >= 2.14.0
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 %{?with_dbus:BuildRequires:     dbus-glib-devel >= 0.71}
23 BuildRequires:  djvulibre-devel >= 3.5.17
24 BuildRequires:  ghostscript
25 BuildRequires:  gnome-doc-utils >= 0.7.2
26 BuildRequires:  gnome-vfs2-devel >= 2.15.91
27 BuildRequires:  gtk+2-devel >= 2:2.10.1
28 BuildRequires:  intltool >= 0.35.0
29 BuildRequires:  kpathsea-devel
30 BuildRequires:  libglade2-devel >= 1:2.6.0
31 BuildRequires:  libgnomeui-devel >= 2.15.91
32 BuildRequires:  libstdc++-devel
33 BuildRequires:  libtiff-devel
34 BuildRequires:  libxslt-progs >= 1.1.17
35 BuildRequires:  nautilus-devel >= 2.15.91
36 BuildRequires:  pkgconfig
37 BuildRequires:  poppler-glib-devel >= 0.5.3
38 BuildRequires:  python-libxml2
39 BuildRequires:  rpmbuild(macros) >= 1.197
40 BuildRequires:  scrollkeeper
41 Requires(post,preun):   GConf2
42 Requires(post,postun):  desktop-file-utils
43 Requires(post,postun):  gtk+2 >= 2:2.10.1
44 Requires(post,postun):  scrollkeeper
45 Requires:       cairo >= 1.2.2
46 Requires:       djvulibre >= 3.5.17
47 Requires:       gtk+2 >= 2:2.10.1
48 Requires:       libgnomeui >= 2.15.91
49 Requires:       poppler-glib >= 0.5.3
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 Evince is a document viewer for multiple document formats like pdf,
54 postscript, and many others. The goal of evince is to replace the
55 multiple document viewers that exist on the GNOME Desktop, like ggv,
56 gpdf, and xpdf with a single simple application.
57
58 %description -l pl
59 Evince jest przegl±dark± dokumentów w wielu formatach takich jak pdf,
60 postscript i wielu innych. W zamierzeniach program ma zast±piæ
61 przegl±darki dokumentów dla ¶rodowiska GNOME, takie jak ggv, gpdf i
62 xpdf jedn± prost± aplikacj±.
63
64 %package -n nautilus-extension-evince
65 Summary:        Evince extension for Nautilus
66 Summary(pl):    Rozszerzenie Evince dla Nautilusa
67 Group:          X11/Applications
68 Requires:       %{name} = %{version}-%{release}
69 Requires:       nautilus >= 2.15.4
70
71 %description -n nautilus-extension-evince
72 Shows Evince document properties in Nautilus.
73
74 %description -n nautilus-extension-evince -l pl
75 Pokazuje w³a¶ciwo¶ci dokumentu Evince w Nautilusie.
76
77 %prep
78 %setup -q
79 %patch0 -p1
80 %patch1 -p1
81
82 %build
83 %{__gnome_doc_prepare}
84 %{__intltoolize}
85 %{__aclocal}
86 %{__autoconf}
87 %{__autoheader}
88 %{__automake}
89 %configure \
90         --disable-static \
91         --disable-schemas-install \
92         --enable-comics \
93         %{?with_dbus:--enable-dbus} \
94         --enable-djvu \
95         --enable-dvi \
96         --enable-impress \
97         --enable-nautilus \
98         --enable-pixbuf \
99         --enable-tiff \
100         --with-print=gtk
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 rm -f $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-1.0/*.la
110
111 %find_lang Evince
112 %find_lang %{name} --with-gnome
113 cat Evince.lang >> %{name}.lang
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post
119 %gconf_schema_install evince.schemas
120 %gconf_schema_install evince-thumbnailer-comics.schemas
121 %gconf_schema_install evince-thumbnailer-djvu.schemas
122 %gconf_schema_install evince-thumbnailer-dvi.schemas
123 %gconf_schema_install evince-thumbnailer.schemas
124 %update_desktop_database_post
125 %scrollkeeper_update_post
126 %update_icon_cache hicolor
127
128 %preun
129 %gconf_schema_uninstall evince.schemas
130 %gconf_schema_uninstall evince-thumbnailer-comics.schemas
131 %gconf_schema_uninstall evince-thumbnailer-djvu.schemas
132 %gconf_schema_uninstall evince-thumbnailer-dvi.schemas
133 %gconf_schema_uninstall evince-thumbnailer.schemas
134
135 %postun
136 %update_desktop_database_postun
137 %scrollkeeper_update_postun
138 %update_icon_cache hicolor
139
140 %files -f %{name}.lang
141 %defattr(644,root,root,755)
142 %doc AUTHORS ChangeLog NEWS README TODO
143 %attr(755,root,root) %{_bindir}/*
144 %{_sysconfdir}/gconf/schemas/evince.schemas
145 %{_sysconfdir}/gconf/schemas/evince-thumbnailer-comics.schemas
146 %{_sysconfdir}/gconf/schemas/evince-thumbnailer-djvu.schemas
147 %{_sysconfdir}/gconf/schemas/evince-thumbnailer-dvi.schemas
148 %{_sysconfdir}/gconf/schemas/evince-thumbnailer.schemas
149 %{_datadir}/%{name}
150 %{_desktopdir}/*.desktop
151 %{_iconsdir}/*/*/*
152 %{_omf_dest_dir}/evince
153
154 %files -n nautilus-extension-evince
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{_libdir}/nautilus/extensions-1.0/*.so*
This page took 0.081961 seconds and 2 git commands to generate.