]> git.pld-linux.org Git - packages/evince-gtk.git/blob - evince-gtk.spec
- up to 2.28.2
[packages/evince-gtk.git] / evince-gtk.spec
1 #
2 # - are schemas (thus GConf) needed?
3 #
4 # Conditional build:
5 %bcond_without  dbus            # disable DBUS support
6 %bcond_without  apidocs         # disable gtk-doc
7 #
8 Summary:        Document viewer for multiple document formats -- the no libgnome version
9 Summary(pl.UTF-8):      Przeglądarka dokumentów w wielu formatach -- wersja nie wykorzystująca libgnome
10 %define         _realname       evince
11 Name:           evince-gtk
12 Version:        2.28.2
13 Release:        1
14 License:        GPL v2
15 Group:          X11/Applications/Graphics
16 Source0:        http://ftp.gnome.org/pub/gnome/sources/evince/2.28/%{_realname}-%{version}.tar.bz2
17 # Source0-md5:  f8b9a1ee6fe8cd0a1b7a51ad4db96e59
18 URL:            http://www.gnome.org/projects/evince/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 %{?with_dbus:BuildRequires:     dbus-glib-devel >= 0.71}
22 BuildRequires:  djvulibre-devel >= 3.5.17
23 BuildRequires:  ghostscript
24 %{?with_apidocs:BuildRequires:  gnome-doc-utils >= 0.3.2}
25 BuildRequires:  gtk+2-devel >= 2:2.10.6
26 BuildRequires:  intltool >= 0.35.0
27 BuildRequires:  kpathsea-devel
28 BuildRequires:  libglade2-devel >= 1:2.6.0
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  libtiff-devel
31 BuildRequires:  libxslt-progs >= 1.1.17
32 BuildRequires:  pkgconfig
33 BuildRequires:  poppler-glib-devel >= 0.6
34 BuildRequires:  python-libxml2
35 BuildRequires:  rpmbuild(macros) >= 1.197
36 BuildRequires:  scrollkeeper
37 Requires(post,postun):  desktop-file-utils
38 Requires(post,postun):  gtk+2 >= 2:2.10.6
39 Requires(post,postun):  scrollkeeper
40 Requires:       cairo >= 1.2.4
41 Requires:       djvulibre >= 3.5.17
42 Requires:       gtk+2 >= 2:2.10.6
43 Requires:       poppler-glib >= 0.6
44 Conflicts:      evince
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         backendsdir     %{_libdir}/evince/1/backends
48
49 %description
50 Evince is a document viewer for multiple document formats like pdf,
51 postscript, and many others. The goal of evince is to replace the
52 multiple document viewers that exist on the GNOME Desktop, like ggv,
53 gpdf, and xpdf with a single simple application.
54
55 This version doesn't use GNOME libraries, but only GTK+.
56
57 %description -l pl.UTF-8
58 Evince jest przeglądarką dokumentów w wielu formatach takich jak pdf,
59 postscript i wielu innych. W zamierzeniach program ma zastąpić
60 przeglądarki dokumentów dla środowiska GNOME, takie jak ggv, gpdf i
61 xpdf jedną prostą aplikacją.
62
63 Ta wersja nie korzysta z bibliotek GNOME, a jedynie z GTK+.
64
65 %package devel
66 Summary:        Header files for Evince GTK+
67 Summary(pl.UTF-8):      Pliki nagłówkowe Evince GTK+
68 Group:          X11/Development/Libraries
69 Requires:       %{name} = %{version}-%{release}
70 Requires:       gtk+2-devel >= 2:2.16.0
71
72 %description devel
73 Header files for Evince GTK+.
74
75 %description devel -l pl.UTF-8
76 Pliki nagłówkowe Evince GTK+.
77
78 %package apidocs
79 Summary:        Evince API documentation
80 Summary(pl.UTF-8):      Dokumentacja API aplikacji Evince
81 Group:          Documentation
82 Requires:       gtk-doc-common
83
84 %description apidocs
85 Evince API documentation.
86
87 This version doesn't use GNOME libraries, but only GTK+.
88
89 %description apidocs -l pl.UTF-8
90 Dokumentacja API aplikacji Evince.
91
92 Ta wersja nie korzysta z bibliotek GNOME, a jedynie z GTK+.
93
94 %prep
95 %setup -q -n %{_realname}-%{version}
96
97 %build
98 %{__intltoolize}
99 %{__aclocal}
100 %{__autoconf}
101 %{__autoheader}
102 %{__automake}
103 %configure \
104         %{!?with_apidocs:--disable-gtk-doc} \
105         %{!?with_apidocs:--disable-scrollkeeper} \
106         --disable-nautilus \
107         --disable-static \
108         --disable-schemas-install \
109         --enable-comics \
110         %{!?with_dbus:--disable-dbus} \
111         --enable-djvu \
112         --enable-dvi \
113         --enable-impress \
114         --enable-pdf \
115         --enable-pixbuf \
116         --enable-ps \
117         --enable-t1lib \
118         --enable-thumbnailer \
119         --enable-tiff \
120         --with-html-dir=%{_gtkdocdir} 
121
122 %{__make}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT \
129         HTML_DIR=%{_gtkdocdir}
130
131 %{__rm} $RPM_BUILD_ROOT%{backendsdir}/*.la
132
133 %find_lang %{_realname}
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %post
139 /sbin/ldconfig
140 %update_desktop_database_post
141 %scrollkeeper_update_post
142 %update_icon_cache hicolor
143
144 %preun
145
146 %postun
147 /sbin/ldconfig
148 %update_desktop_database_postun
149 %scrollkeeper_update_postun
150 %update_icon_cache hicolor
151
152 %files -f %{_realname}.lang
153 %defattr(644,root,root,755)
154 %doc AUTHORS ChangeLog NEWS README TODO
155 %attr(755,root,root) %{_bindir}/evince
156 %attr(755,root,root) %{_bindir}/evince-previewer
157 %attr(755,root,root) %{_bindir}/evince-thumbnailer
158 %attr(755,root,root) %{_libdir}/libevdocument.so.*.*.*
159 %attr(755,root,root) %ghost %{_libdir}/libevdocument.so.1
160 %attr(755,root,root) %{_libdir}/libevview.so.*.*.*
161 %attr(755,root,root) %ghost %{_libdir}/libevview.so.1
162 %dir %{_libdir}/evince
163 %dir %{_libdir}/evince/1
164 %dir %{backendsdir}
165 %attr(755,root,root) %{backendsdir}/libcomicsdocument.so
166 %{backendsdir}/comicsdocument.evince-backend
167 %attr(755,root,root) %{backendsdir}/libdjvudocument.so
168 %{backendsdir}/djvudocument.evince-backend
169 %attr(755,root,root) %{backendsdir}/libdvidocument.so*
170 %{backendsdir}/dvidocument.evince-backend
171 %attr(755,root,root) %{backendsdir}/libimpressdocument.so
172 %{backendsdir}/impressdocument.evince-backend
173 %attr(755,root,root) %{backendsdir}/libpdfdocument.so
174 %{backendsdir}/pdfdocument.evince-backend
175 %attr(755,root,root) %{backendsdir}/libpixbufdocument.so
176 %{backendsdir}/pixbufdocument.evince-backend
177 %attr(755,root,root) %{backendsdir}/libpsdocument.so
178 %{backendsdir}/psdocument.evince-backend
179 %attr(755,root,root) %{backendsdir}/libtiffdocument.so
180 %{backendsdir}/tiffdocument.evince-backend
181 %{_mandir}/man1/*
182 %{_datadir}/%{_realname}
183 %{_desktopdir}/*.desktop
184 %{_iconsdir}/*/*/*/*
185 %{_omf_dest_dir}/evince
186
187 %files devel
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{_libdir}/libevdocument.so
190 %attr(755,root,root) %{_libdir}/libevview.so
191 %{_libdir}/libevdocument.la
192 %{_libdir}/libevview.la
193 %{_includedir}/evince
194 %{_pkgconfigdir}/evince-document-*.pc
195 %{_pkgconfigdir}/evince-view-*.pc
196
197 %if %{with apidocs}
198 %files apidocs
199 %defattr(644,root,root,755)
200 %{_gtkdocdir}/*
201 %endif
This page took 0.046093 seconds and 4 git commands to generate.