]> git.pld-linux.org Git - packages/evince-gtk.git/blob - evince-gtk.spec
- up to 2.23.6
[packages/evince-gtk.git] / evince-gtk.spec
1 #
2 # - are schemas (thus GConf) needed?
3 #
4 # Conditional build:
5 %bcond_without  dbus            # disable DBUS support
6 %bcond_without  apidocs         # disable gtk-doc
7 #
8 Summary:        Document viewer for multiple document formats -- the no libgnome version
9 Summary(pl.UTF-8):      Przeglądarka dokumentów w wielu formatach -- wersja nie wykorzystująca libgnome
10 %define         _realname       evince
11 Name:           evince-gtk
12 Version:        2.23.6
13 Release:        1
14 License:        GPL v2
15 Group:          X11/Applications/Graphics
16 Source0:        http://ftp.gnome.org/pub/gnome/sources/evince/2.23/%{_realname}-%{version}.tar.bz2
17 # Source0-md5:  04763835f04c3c8f52bfcef2041948a9
18 Patch0:         %{_realname}-desktop.patch
19 URL:            http://www.gnome.org/projects/evince/
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 %{?with_dbus:BuildRequires:     dbus-glib-devel >= 0.71}
23 BuildRequires:  djvulibre-devel >= 3.5.17
24 BuildRequires:  ghostscript
25 %{?with_apidocs:BuildRequires:  gnome-doc-utils >= 0.3.2}
26 BuildRequires:  gtk+2-devel >= 2:2.10.6
27 BuildRequires:  intltool >= 0.35.0
28 BuildRequires:  kpathsea-devel
29 BuildRequires:  libglade2-devel >= 1:2.6.0
30 BuildRequires:  libstdc++-devel
31 BuildRequires:  libtiff-devel
32 BuildRequires:  libxslt-progs >= 1.1.17
33 BuildRequires:  pkgconfig
34 BuildRequires:  poppler-glib-devel >= 0.6
35 BuildRequires:  python-libxml2
36 BuildRequires:  rpmbuild(macros) >= 1.197
37 BuildRequires:  scrollkeeper
38 Requires(post,postun):  desktop-file-utils
39 Requires(post,postun):  gtk+2 >= 2:2.10.6
40 Requires(post,postun):  scrollkeeper
41 Requires:       cairo >= 1.2.4
42 Requires:       djvulibre >= 3.5.17
43 Requires:       gtk+2 >= 2:2.10.6
44 Requires:       poppler-glib >= 0.6
45 Conflicts:      evince
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 Evince is a document viewer for multiple document formats like pdf,
50 postscript, and many others. The goal of evince is to replace the
51 multiple document viewers that exist on the GNOME Desktop, like ggv,
52 gpdf, and xpdf with a single simple application.
53
54 This version doesn't use GNOME libraries, but only GTK+.
55
56 %description -l pl.UTF-8
57 Evince jest przeglądarką dokumentów w wielu formatach takich jak pdf,
58 postscript i wielu innych. W zamierzeniach program ma zastąpić
59 przeglądarki dokumentów dla środowiska GNOME, takie jak ggv, gpdf i
60 xpdf jedną prostą aplikacją.
61
62 Ta wersja nie korzysta z bibliotek GNOME, a jedynie z GTK+.
63
64 %package apidocs
65 Summary:        Evince API documentation
66 Summary(pl.UTF-8):      Dokumentacja API aplikacji Evince
67 Group:          Documentation
68 Requires:       gtk-doc-common
69
70 %description apidocs
71 Evince API documentation.
72
73 This version doesn't use GNOME libraries, but only GTK+.
74
75 %description apidocs -l pl.UTF-8
76 Dokumentacja API aplikacji Evince.
77
78 Ta wersja nie korzysta z bibliotek GNOME, a jedynie z GTK+.
79
80 %prep
81 %setup -q -n %{_realname}-%{version}
82 %patch0 -p1
83
84 %build
85 #%%{__intltoolize}
86 #%%{__aclocal}
87 #%%{__autoconf}
88 #%%{__autoheader}
89 #%%{__automake}
90 %configure \
91         %{!?with_apidocs:--disable-gtk-doc} \
92         %{!?with_apidocs:--disable-scrollkeeper} \
93         --disable-nautilus \
94         --disable-static \
95         --disable-schemas-install \
96         --enable-comics \
97         %{!?with_dbus:--disable-dbus} \
98         --enable-djvu \
99         --enable-dvi \
100         --enable-impress \
101         --enable-pdf \
102         --enable-pixbuf \
103         --enable-ps \
104         --enable-t1lib \
105         --enable-thumbnailer \
106         --enable-tiff \
107         --with-print=gtk \
108         --with-html-dir=%{_gtkdocdir} \
109         --without-libgnome
110
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT \
118         HTML_DIR=%{_gtkdocdir}
119
120 %find_lang %{_realname}
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post
126 %update_desktop_database_post
127 %scrollkeeper_update_post
128 %update_icon_cache hicolor
129
130 %preun
131
132 %postun
133 %update_desktop_database_postun
134 %scrollkeeper_update_postun
135 %update_icon_cache hicolor
136
137 %files -f %{_realname}.lang
138 %defattr(644,root,root,755)
139 %doc AUTHORS ChangeLog NEWS README TODO
140 %attr(755,root,root) %{_bindir}/*
141 %attr(755,root,root) %{_libdir}/*.so.*.*.*
142 %attr(755,root,root) %{_libdir}/*.so.*
143 %dir %{_libdir}/%{_realname}
144 %dir %{_libdir}/%{_realname}/backends
145 %attr(755,root,root) %{_libdir}/%{_realname}/backends/*.so
146 %{_libdir}/%{_realname}/backends/*.evince-backend
147 %{_mandir}/man1/*
148 %{_datadir}/%{_realname}
149 %{_desktopdir}/*.desktop
150 %{_iconsdir}/*/*/*/*
151 %{_omf_dest_dir}/evince
152
153 %if %{with apidocs}
154 %files apidocs
155 %defattr(644,root,root,755)
156 %{_gtkdocdir}/*
157 %endif
This page took 0.043872 seconds and 4 git commands to generate.